Desktop icons link to actual .desktop files

Bug #294638 reported by Herr Irrtum
16
Affects Status Importance Assigned to Milestone
KDE Base
Unknown
Wishlist
kdebase-workspace (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: kde4

Hi there,
at first - I use the *german* kubuntu 8.10 64bit - so maybe some terms are not correctly translated here... Sorry for that.

+++ Update: I've checked it back on the kubuntu live cd v. 8.10. x386 in english on a Virtualizer (virtual Box) ---> Same bug here (as on KDE 4.1.3 from backports). +++

System: Kde4.1.2 (apt-cache policy packagename), latest regular updates as of today / kubuntu 8.10 - AMD64

How should it be:

I add a icon from k menue to the Desktop or the panel per right klick. I change the name of the appearing minimal plasmoid. Now the plasmoid name should be changed - and nothing else.

What goes wrong:

Let's say you have added an icon from the k menue to your panel or to your workspace/desktop (right click to a an item in k menue - and choose "Add to Desktop / Panel") .
The icon will appear as minimal plasmoid (including the typical plasmoid controls like turning or resizing).
If you now change the name of the plasmoid (lets say from "firefox web browser" to firefox) - and nothing else is touched! - it will change the icon from the well known firefox symbol into a question mark. It will also disappear from K Menue --> Applications --> Internet and will reapear (as question mark) in K Menue --> Applications --> Lost & Found.
However it still starts firefox.
BTW: The original firefox icon itself does not appear, when you you look for it in system icons under the general plasmoid properties tab. And WTF: The name remains unchanged!
BTW: Changing the name was archived with right clicking on the desktop icon-plasmoid --> icon settings --> application --> Name. F2 does not work here - unlike in every other environment known to mankind (gnome, XFCE, errrm windows, etc.).
I of course did not change the start command :)

However I did change the start command of another program also added to the panel directly per right click from the k menue.

I wanted another geometry for konsole (which by the way does not work anyway - the --geometry switch just is not reacting - I think/hope this is reported) so I changed the start command from "konsole" to "konsole --geometry 132x25" --> this changed the konsole icon from the well known terminal symbol to a questionmark *and* did not start konsole at all and moved it inside the k menue to the "lost & found" section.
So I changed the start command back to simply "konsole" - so anything should be back like before. But no - the question mark stayed and konsole is not startable again, the original k menue entry is lost.
Konsole is not starting even when typing "konsole" into the ALT F2 panel (but wait - there comes a second symbol "konsole au" - klicking this works) - Thanks god it starts from within the commandline from krusader - the "total commander" clone.

So basically - changing something unimportant - like the name of Program Starter Plasmoids - moves them inside the K Menue, changes the icon to a stupid question mark and may make them unusable forever.

Regards,
Herr Irrtum, Italy

(my first and now even reedited launchpad bug report - hope its ok this way :) )

Revision history for this message
In , Tonne2004 (tonne2004) wrote :

Version: (using Devel)
Installed from: Compiled sources
OS: Linux

1) Go to a folderview
2) Right-Click and say "Create new Link to Application"
3) Fill in icon, command etc
4) Drag and drop the new icon to the panel
5) Be happy that everything worked perfectly so far
6) Decide some days later that you don't need the icon in the folderview
7) Delete the icon from the folderview (while retaining the one in the panel)
8) Click the icon in the panel (which worked perfectly well before you deleted the one in the folderview)

You get an error message saying "The desktop entry file /home/kde4daily/Desktop/Konsole.desktop has no Type=... entry."

First bug:
This message is misleading: The file home/kde4daily/Desktop/Konsole.desktop is in fact deleted.

Second bug:
This shouldn't happen at all. The panel icon should just continue working. It's very unintuitive that both icons somehow stay linked together.

Revision history for this message
In , Jasonbstubbs (jasonbstubbs) wrote :

"First bug" is obviously a problem that needs to be fixed.

FWIW, for "Second bug" I think that it'd be more intuitive that a shortcut applet copy the details of a .desktop file rather than creating a shortcut to it when using drag and drop.

Revision history for this message
In , Marco Martin (notmart) wrote :

the icon plasmoid should be made smarter is many ways.
perhaps monitoring the linked file and closing itself when it got deleted?

Revision history for this message
In , aseigo (aseigo) wrote :

monitoring the linked file is one thing that should be done; but also not linking to a .desktop file if it represents an entry that we can grab as a kservice directly.

Revision history for this message
In , aseigo (aseigo) wrote :

*** Bug 166945 has been marked as a duplicate of this bug. ***

Herr Irrtum (die-nmi)
description: updated
Revision history for this message
Jonathan Thomas (echidnaman) wrote : Re: KDE4: Changing non important Properties of a Starter-Icon (in panel or on desktop) destroys Icon and changes its place in KMenue to the "lost n found" subfolder

The main problem here is that Plasma is linking to the actual .desktop file instead of making a copy.
However, the only way that this would be editable is if you were running KDE as root.This is dangerous for many reasons, including the dataloss you received due to this bug. If you weren't running KDE as root you would have gotten a message saying that you do not have permission to make the changed Plasma was erroneously trying to make.

Changed in kdebase-workspace:
importance: Undecided → Low
status: New → Triaged
Changed in kdebase:
status: Unknown → New
Revision history for this message
In , Jonathan Thomas (echidnaman-f) wrote :

Implementing Jason's suggestion would also make Application Launchers dragged from KMenu editable. Currently one cannot edit them at all since they point to the actual desktop file in /etc/path/to/desktop.desktop

Changed in kdebase:
status: New → Invalid
Revision history for this message
Jonathan Thomas (echidnaman) wrote :

I think I linked the wrong upstream report to this...

Changed in kdebase:
status: Invalid → Unknown
Changed in kdebase:
status: Unknown → New
Revision history for this message
In , Tyrerj-4 (tyrerj-4) wrote :

Re: Comment #5

In KDE-3.5, icons dragged from the menu are links. Perhaps the best choice in all cases is to have the little dialog that pops up and asks if you want to copy or link. However, icons dragged from the file system or a Folder View should _always_ be copies.

IAC, there is a problem with the current links. Since they are links, you should not be allowed to click: "Icon Settings" and modify them. Another possibility would be that when you modify a link from the menu that the 'desktop' file is copied and the copy is modified.

Revision history for this message
In , aseigo (aseigo) wrote :

*** Bug 186418 has been marked as a duplicate of this bug. ***

Changed in kdebase:
status: New → Confirmed
Revision history for this message
In , Jtamate (jtamate) wrote :

With svn r954171 (kde 4.2.70), when I remove the application link in the folder view I get a message that says +/- "The file ..../application link.desktop does not exists".

The problem (but this is another bug) is that until I close that message, I can not change desktops, nor applications clicking in the task bar.

Revision history for this message
Jonathan Thomas (echidnaman) wrote :

Hi there!

Thanks for reporting this bug! Your bug seems to be a problem with the KDE program itself, and not with our KDE packages. But don't worry! This issue is being tracked by the KDE developers at: http://bugs.kde.org/show_bug.cgi?id=166284
Once fixed in KDE, it will be included in Kubuntu once the KDE version the fix is in in reaches Kubuntu.

Thanks!

Changed in kdebase-workspace (Ubuntu):
status: Triaged → Invalid
Revision history for this message
In , Asraniel (asraniel) wrote :

I'm changing this to a wishlist. Copy by default is not the wanted feature, but link is. So this is not a bug, but a feature request (beeing able to chose if a copy or a link is created)

Changed in kdebase:
importance: Unknown → Wishlist
Revision history for this message
In , Nate-b (nate-b) wrote :

Hello!

This feature request was filed for KDE Plasma 4, which reached end-of-support status in August 2015. KDE Plasma 5's desktop shell has been almost completely rewritten for better performance and usability, so it is likely that this feature request is already implemented in Plasma 5, or is no longer applicable.

Accordingly, we hope you understand why we must close this feature request. If the requested feature is still desired but not implemented in KDE Plasma 5.12 or later, please feel free to open a new ticket in the "plasmashell" product after reading https://community.kde.org/Get_Involved/Bug_Reporting

If you would like to get involved in KDE's bug triaging effort so that future mass bug closes like this are less likely, please read https://community.kde.org/Get_Involved#Bug_Triaging

Thanks for your understanding!

Nate Graham

Changed in kde-baseapps:
status: Confirmed → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.