[Intrepid] Klick on logout in kickoff leads to shutdown

Bug #279807 reported by Martin Gräßlin on 2008-10-07
4
Affects Status Importance Assigned to Milestone
openSUSE
Fix Released
Unknown
kdebase-workspace (Ubuntu)
High
Harald Sitter

Bug Description

It happened twice today: I clicked on the logout button in Kickoff and the computer did a shutdown.

I have not tried if it happens in Krunner as well (I will when I shut down the PC).

FYI: I set a config option to not display the logout dialog when I click an item in Kickoff. Don't know if it is related (don't think so) and I don't remember where the option is hidden in systemsetting ;-)

Harald Sitter (apachelogger) wrote :

Probably caused by the ksmserver patch. Needs some investigation.

Changed in kdebase-workspace:
importance: Undecided → High
Jonathan Thomas (echidnaman) wrote :

For what it's worth I can't reproduce this one.

I'll try to reproduce this evening when I turn off the PC. Just have to remember to use logout, I'll put plasmoid on the desktop to remember

I was still able to reproduce this behaviour. I'll try to reproduce the problem on my laptop and I'll try to investigate it a little bit if I am able to reproduce on another system.

I just was able to configure my laptop the way so that the bug appears. It is related to confirm logout dialog.

So open Systemsettings -> Advanced -> Session Manager
remove check "confirm logout", click apply, open Kickoff and click logout and your system will shut down.

logout via krunner is not affected, only kickoff.

Jonathan Thomas (echidnaman) wrote :

Ah, so that's why I couldn't reproduce. ;-)

Changed in kdebase-workspace:
status: New → Triaged
Harald Sitter (apachelogger) wrote :

I am beginning to wonder why no one listens to me when I say "patchs are baaad".

Changed in kdebase-workspace:
assignee: nobody → apachelogger
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdebase-workspace - 4:4.1.2-0ubuntu8

---------------
kdebase-workspace (4:4.1.2-0ubuntu8) intrepid; urgency=low

  * Remove kubuntu_17_kwin_branch.diff completely
  * Fix shutdown where logout was selected, by adding kdisplaymanager.cpp to
    kubuntu_15_kickoff_ksmserver_logout.diff (LP: #279807)

 -- Harald Sitter <email address hidden> Sat, 11 Oct 2008 16:36:55 +0200

Changed in kdebase-workspace:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.