Ubuntu

no login possible after installing kubuntu-desktop

Reported by HB on 2008-08-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kdebase-workspace (Ubuntu)
Undecided
Unassigned

Bug Description

I installed kubuntu-desktop, choose kdm as default window manager. after installing i am not able to login as the "primary" user neither using kdm nor using gdm. after trying to log in i find in auth.log:

Aug 23 23:30:32 holle-laptop kdm: :0[5186]: pam_unix(kdm:auth): authentication failure; logname= uid=0 euid=0 tty=:0 ruser= rhost= user=holle

I had to create a second user in order to be able to log in.

I'm using hardy, all packages up-to-date.

p.s. to avoid misunderstandings: login to gnome from gdm worked fine before i installed kubuntu-desktop.

ProblemType: Bug
Architecture: i386
Date: Sat Aug 23 23:36:29 2008
DistroRelease: Ubuntu 8.04
NonfreeKernelModules: ath_hal
Package: kubuntu-desktop 1.75
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: kubuntu-meta
Uname: Linux 2.6.24-19-generic i686

HB (hbemail) wrote :
Steve Langasek (vorlon) wrote :

I don't know why this bug was reassigned to pam; this looks like an error in setting up the user account with the requested password, not a bug in pam for failing to authenticate the user. As the submitter notes, setting up a second user and logging in with that account works fine, it's only the initial user that fails. So this is not an error in the PAM authentication process.

Reassigning back to kubuntu-desktop.

HB (hbemail) on 2008-08-24
description: updated
Harald Sitter (apachelogger) wrote :

Is this reproducible in any way?

Changed in kubuntu-meta:
status: New → Incomplete

no, because at the moment i'm running opensuse.

On Sat, Jan 3, 2009 at 3:04 PM, Harald Sitter <email address hidden> wrote:
> Is this reproducible in any way?
>
> ** Changed in: kdebase-workspace (Ubuntu)
> Sourcepackagename: kubuntu-meta => kdebase-workspace
> Status: New => Incomplete
>
> --
> no login possible after installing kubuntu-desktop
> https://bugs.launchpad.net/bugs/260744
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "kdebase-workspace" source package in Ubuntu: Incomplete
>
> Bug description:
> I installed kubuntu-desktop, choose kdm as default window manager. after installing i am not able to login as the "primary" user neither using kdm nor using gdm. after trying to log in i find in auth.log:
>
> Aug 23 23:30:32 holle-laptop kdm: :0[5186]: pam_unix(kdm:auth): authentication failure; logname= uid=0 euid=0 tty=:0 ruser= rhost= user=holle
>
> I had to create a second user in order to be able to log in.
>
> I'm using hardy, all packages up-to-date.
>
> p.s. to avoid misunderstandings: login to gnome from gdm worked fine before i installed kubuntu-desktop.
>
> ProblemType: Bug
> Architecture: i386
> Date: Sat Aug 23 23:36:29 2008
> DistroRelease: Ubuntu 8.04
> NonfreeKernelModules: ath_hal
> Package: kubuntu-desktop 1.75
> PackageArchitecture: i386
> ProcEnviron:
> PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: kubuntu-meta
> Uname: Linux 2.6.24-19-generic i686
>

Harald Sitter (apachelogger) wrote :

Closing then.

Changed in kdebase-workspace:
status: Incomplete → Invalid
Montblanc (montblanc) wrote :

I'm affected by this bug after upgrading Kubuntu Oneiric to Precise by changing every "oneiric" occurrence to "precise" in sources.list and then running a dist-upgrade (because my environment was not triggering an available upgrade notification).

Something weird has happened in PAM, since it's trying to look for my user with a wrong uid.

I can login with "startx /usr/bin/startkde" only, but then I would get authentication failures everywhere I'm asked to input my password for root privileges, unless I run the same commands from terminal with sudo.

I wrote in the Kubuntu forums: http://www.kubuntuforums.net/showthread.php?58623-Can-t-login-via-KDM-after-upgrading-to-Precise

German forum with same problem: http://forum.ubuntuusers.de/topic/kein-login-in-kdm-nach-upgrade/#post-4316707

Debian bug related: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=440096

Please, tell me if you need more information.

Changed in kdebase-workspace (Ubuntu):
status: Invalid → Confirmed
Montblanc (montblanc) wrote :
Changed in kdebase-workspace (Debian):
status: Unknown → Fix Released
Montblanc (montblanc) wrote :

I thought this might be related: I can run "sudo" without any problem, but "su -" is failing.

$ su -
Password:
su: Autenticazione non riuscita
$ sudo uname -r
[sudo] password for montblanc:
3.2.0-24-generic-pae

Montblanc (montblanc) wrote :

I'm sorry, I forgot I'm on Ubuntu which uses "sudo -s", my fault. Please, disregard the comment above.

The only thing that might help is that a newly created user can log in (password is accepted), but after trying to load X, it pops back to the login screen.

Montblanc (montblanc) on 2012-05-07
no longer affects: kdebase-workspace (Debian)
Changed in kdebase-workspace (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.