Kubuntu 8.04: OpenGL screensavers zoom out randomly when starting up in KDE4

Bug #211422 reported by Rob Marques on 2008-04-03
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KDE Base
Fix Released
Medium
kdebase-workspace (Ubuntu)
Low
Jonathan Thomas

Bug Description

Binary package hint: kscreensaver-kde4

When the screensaver starts, the screensaver itself will zoom out and display in the upper-left corner of the screen, as if I had used the "zoom-out" feature that is available in the upper-right corner menu in KDE4. It does not happen every time, but rather at random. Also, when I move the mouse to get my login screen to get back into my system, if I move it more than once (e.g., I move the mouse left and right in a back-n-forth motion), the login dialog will appear then disappear, requiring me to press escape a couple of times to get a login dialog.

Using Kubunto 8.04 Hardy (development branch)
Lenovo T-61 laptop
Nvidia NVS140 grahics chip and latest Nvidia-glx driver from pkg manager

Rob Marques (marques-rob) wrote :

As mentioned in the subject line, I can only reproduce this in the OpenGL screensavers. The others seem unaffected.

Rob Marques (marques-rob) wrote :

Your bug database keeps changing the package from kscreensaver-kde4 to kdeartwork-kde4 for some reason....

Vlad Tepes (tspgallagher) wrote :

I also have a Lenovo T61 running Kubuntu 8.04, but with an Intel GPU instead of Nvidia. I am also experiencing the same problems.

Harald Sitter (apachelogger) wrote :

Does this still happen in KDE 4.1?
If so, please report this issue on http://bugs.kde.org and paste the report's URL here.

Thank you for helping us improve Kubuntu.

Changed in kdeartwork-kde4:
importance: Undecided → Low
status: New → Incomplete
John Stamp (jstamp) wrote :

It's already been reported, and it still affects 4.1:

http://bugs.kde.org/show_bug.cgi?id=165552

The patch works for me, but it'd be nice to see if it helps other folks.

Risto H. Kurppa (risto.kurppa) wrote :

Still happens on 4.1rc1 w. Hardy

On GL screensavers, yes, except KPendulum and KRotation

Changed in kdeartwork:
status: Incomplete → Confirmed
Changed in kdebase:
status: Unknown → New

I would try the patch if I succeeded compiling kdesavers from source... For me, cmake (version 2.6-patch 0) complains about an unknown command "kde4_add_executable" when I attempt to run it in the kdesavers directory. I know this is slightly off-topic in this bug report, but I'd appreciate any hint.

Jonathan Thomas (echidnaman) wrote :

You could try sudo apt-get build-dep kdeartwork-kde4.
But even the patch's author says it doesn't work.

Changed in kdeartwork:
status: Confirmed → Triaged

I verified that the patch provided in the KDE bug report works correctly. Would it be possible to integrate this patch directly into the Kubuntu packages? There does not seem to be too much activity on the KDE side...

Harald Sitter (apachelogger) wrote :

In theory, yes.

But since the patch author himself doubts the solution path of the patch, I don't think it is a good idea to include it in the Kubuntu package.

eschoeller (eric-junk) wrote :

I am also experiencing the same problem, on two systems. Initially, my system at work only had this problem (running KDE4.x) but now, after I have upgraded my machine at home to intrepid this issue occurs on my home machine as well. I am very disappointed this upgrade messed my screensaver up, and I have to deal with this in TWO places now! I''l watch this thread, and the thread over at bugs.kde.org for any developments.

Thanks.

Changed in kdebase:
status: New → Invalid
Changed in kdebase:
status: Invalid → Unknown
Changed in kdebase:
status: Unknown → Confirmed
Changed in kdebase:
status: Confirmed → Fix Released
Jonathan Thomas (echidnaman) wrote :

A fix has been committed for KDE 4.2.3, but we need to backport this to our 4.2.2 packages since KDE 4.2.3 will be released after Kubuntu 9.o4.

Changed in kdeartwork (Ubuntu):
assignee: nobody → echidnaman
affects: kdeartwork (Ubuntu) → kdebase-workspace (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdebase-workspace - 4:4.2.2-0ubuntu2

---------------
kdebase-workspace (4:4.2.2-0ubuntu2) jaunty; urgency=low

  [ Harald Sitter ]
  * Add kubuntu_13_startkde_set_country.diff to set KDE's country setting
    (based upon the locale value, so 'de_AT' would be 'at' as country) at
    login. If no LANG is set, or parsing results in an empty string, nothing
    will be done. (LP: #224461)
  * Don't remove gtk-qt-engine cruft and .gtkrc-2.0-kde4 not only when
    qtcurve and kds are installed but also when gtk-qt-engine itself is
    installed. Otherwise the latter will be unapplied post-login (LP: #352946)

  [ Jonathan Thomas ]
  * Add kubuntu_75_fix_shellrunner_crash.diff, fixes KDE bug 186036, and can
    be removed in KDE 4.2.3 (LP: #340607)
  * Add kubuntu_76_disable_dim_for_polkit.diff, the dim plugin breaks the
    policykit-kde dialog (LP: #350225)
  * Add kubuntu_77_fix_autohide_glowbar_flicker.diff, unappliable in KDE 4.2.3
  * Add kubuntu_78_kubuntu_78_krunner_history_combobox_palette.diff to fix an
    invisible scrollbar background in the combobox, unappliable in KDE 4.2.3
  * Add kubuntu_79_fix_small_screensavers.diff to fix small OpenGL
    screensavers, can be unapplied in KDE 4.2.3 (LP: #211422)

 -- Jonathan Thomas <email address hidden> Mon, 06 Apr 2009 14:35:52 -0400

Changed in kdebase-workspace (Ubuntu):
status: Triaged → Fix Released
Changed in kdebase:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.