KDE apps freeze on startup

Bug #877336 reported by Dmitry Risenberg on 2011-10-18
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
kdebase-runtime (Ubuntu)
Undecided
Unassigned

Bug Description

I upgraded my KDE installation from 11.04 to 11.10.
Now when I run "systemsettings", it freezes before anything is shown. The same thing happens if I run "kate", although apps from my previous session are started OK on KDE startup. Also "konsole" starts without problems.

The same apps run without any problems when I'm in GNOME session, so it's something KDE-specific, yet I don't know in what package the problem is.

Relevant piece of "strace systemsettings" log is attached

affects: ubuntu → kdebase-runtime (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kdebase-runtime (Ubuntu):
status: New → Confirmed
Nerdfest (nerdfest) wrote :

The cause of this for me is actually kate itself. It runs on startup and stops anything else from launching. Going to a text console and killing kate will allow things to start properly. Any application that I tried to launch before killing kate open immediately after kate is killed. I've been through the config files, erased any session files and backups I could find, and ensured ownership of the configurations, etc, is me, not root. Kate is set to *not* restore previous sessions as well.

My apologies if this is not exactly the same as the stated bug, but it seems to be at least related.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers