kio_thumbnail uses 100% CPU and eats RAM

Bug #762381 reported by Mark Greenwood on 2011-04-16
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
kdebase-runtime (Ubuntu)
Undecided
Unassigned

Bug Description

No idea which package to file this against.

lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

I've only noticed this after "upgrading" to KDE 4.6.2. With 4.6.1 it never happened.

After a day or so of uptime I start to notice increasing amounts of hard disc activity. This can occur at any time - when the computer is idle, when I'm in the middle of sending an email, whatever. There appears to be no pattern to it. The cause is the process kio_thumbnail - which is thrashing the hard disc like crazy, using 100% of the CPU, and gradually eating RAM (the last time I saw it it was using 2 Gigs of RAM, and climbing).

There appears to be no way to kill this process - killall kio_thumbnail has no effect, and killing it via the pid either crashes KDE, or KDE just starts it up again.

Usually it will calm down for a while, only to start up again some time later. Each time it gets worse and worse until eventually there is no course of action left but to reboot. I don't have any open windows which would require thumbnails to be created, so I've no idea what KDE thinks it's doing.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: kubuntu-desktop 1.205
ProcVersionSignature: Ubuntu 2.6.35-28.50~ppa1~loms~maverick-generic 2.6.35.11
Uname: Linux 2.6.35-28-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sat Apr 16 02:42:39 2011
InstallationMedia: Kubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: kubuntu-meta

Mark Greenwood (fatgerman) wrote :
affects: ubuntu → kdebase-runtime (Ubuntu)
Mark Greenwood (fatgerman) wrote :

I think I have an idea what's causing this. In Dolphin there is an option for 'Do not create previews for local files above :'. I had this set to 25MB, so as to get previews of my Nikon RAW (NEF) files. I've now set this to 8MB and am no longer noticing the behaviour I described above. I do still see kio_thumbnail use a lot of CPU when I open a directory, but it quickly drops back down again, and also it stops if I close the Dolphin window. This was not the case when I had the limit set to 25MB.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kdebase-runtime (Ubuntu):
status: New → Confirmed
hasi (whynot-nurfuerspam) wrote :

I still have this problem with konqueror in KDE 4.13.3 (!) on kubuntu 14.04.
I also saw similar reports here: https://bbs.archlinux.org/viewtopic.php?id=146607
and here: https://forum.kde.org/viewtopic.php?f=223&t=111172

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers