Ubuntu

nepomukservicestub crashed with SIGSEGV [QUrl::isEmpty(), Nepomuk::ResourceData::resetAll(), ~ResourceData]

Reported by John Hibdon on 2010-02-22
84
This bug affects 13 people
Affects Status Importance Assigned to Milestone
KDE Base
Fix Released
High
kdebase-runtime (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: kdebase-runtime

All I know is I was booting up and this occurred. I rebooted twice and the same thing happened so I am reporting it.
Licid Alpha updated as of 22 Feb

ProblemType: Crash
Architecture: amd64
Date: Mon Feb 22 15:58:45 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/bin/nepomukservicestub
InstallationMedia: Kubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100216)
NonfreeKernelModules: nvidia
Package: kdebase-runtime 4:4.4.0-0ubuntu3
ProcCmdline: /usr/bin/nepomukservicestub nepomukfilewatch
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
 LANGUAGE=
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SegvAnalysis:
 Segfault happened at: 0x7f2e1e16da14 <_ZNK4QUrl7isEmptyEv+180>: mov 0x8(%rax),%edx
 PC (0x7f2e1e16da14) ok
 source "0x8(%rax)" (0x39302f736572757c) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: kdebase-runtime
StacktraceTop:
 QUrl::isEmpty() const ()
 ?? () from /usr/lib/libnepomuk.so.4
 ?? () from /usr/lib/libnepomuk.so.4
 ?? () from /usr/lib/libnepomuk.so.4
 ?? () from /usr/lib/kde4/nepomukfilewatch.so
Title: nepomukservicestub crashed with SIGSEGV in QUrl::isEmpty()
Uname: Linux 2.6.32-14-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (process:1758): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (polkit-gnome-authentication-agent-1:1813): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

John Hibdon (jwhibdon) wrote :

StacktraceTop:
 QUrl::isEmpty (this=0x2446a08)
 Nepomuk::ResourceData::resetAll (this=0x2446a00,
 ~ResourceData (this=0x2446a08)
 Nepomuk::ResourceManagerPrivate::cleanupCache (
 Nepomuk::MetadataMover::run (this=0x1c32040)

Changed in kdebase-runtime (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public

Hi there!

Thanks for reporting this bug! Your bug seems to be a problem with the KDE program itself, and not with our KDE packages. But don't worry! This issue is being tracked by the KDE developers at: https://bugs.kde.org/show_bug.cgi?id=228138
Once fixed in KDE, it will be included in Kubuntu once the KDE version the fix is in in reaches Kubuntu.

Thanks!

Changed in kdebase-runtime (Ubuntu):
importance: Medium → Low
status: New → Invalid
Jonathan Thomas (echidnaman) wrote :

Reopening, since this report has garnered enough duplicates that it makes sense to track this, so that once a fix is made we can get it into Kubuntu 10.04, should the fix come after the final release.

Changed in kdebase-runtime (Ubuntu):
status: Invalid → Triaged
importance: Low → Medium
Changed in kdebase:
status: Unknown → Confirmed
summary: - nepomukservicestub crashed with SIGSEGV in QUrl::isEmpty()
+ nepomukservicestub crashed with SIGSEGV { QUrl::isEmpty(),
+ Nepomuk::ResourceData::resetAll(), ~ResourceData]
summary: - nepomukservicestub crashed with SIGSEGV { QUrl::isEmpty(),
+ nepomukservicestub crashed with SIGSEGV [QUrl::isEmpty(),
Nepomuk::ResourceData::resetAll(), ~ResourceData]
Changed in kdebase:
status: Confirmed → Fix Released
Changed in kdebase:
importance: Unknown → High
Changed in kdebase-runtime (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.