Ubuntu

On laptop Acer Aspire 1810TZ, brightness switch changes brightness twice

Reported by Andreas Bulling on 2010-01-20
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
kdebase-runtime (Ubuntu)
Low
Unassigned

Bug Description

On the above laptop running Ubuntu Karmic if you press Fn+Brightness up/down the brightness level changes two steps instead of one (i.e. it actually skips one step). The solution described in
http://forum.notebookreview.com/showthread.php?t=434638
doesn't work for me

peddanet (peter-wein) wrote :

Yup, same with me, first solution described worked fine, but then things became ugly again, and now it jumps across the brightness bar without a sensitive rule! Two steps forward or three and then back maybe only 1 or two. And UP and Down keys work partly like the opposite key...

adriangoodyer (adriangoodyer) wrote :

Thanks for reporting this bug and making Ubuntu better. I have changed the package to gnome-power-manager as this package is responsible for handling brightness and power hot keys.

affects: ubuntu → gnome-power-manager (Ubuntu)
Changed in gnome-power-manager (Ubuntu):
status: New → Incomplete
adriangoodyer (adriangoodyer) wrote :

Please run the following command which will attach necessary information:

apport-collect BUGNUMBER

where BUGNUMBER is the number of the bug you've reported.

Bear in mind that you may need to install the python-launchpadlib package from the universe repository with 'sudo apt-get install python-launchpadlib'. Additionally, when prompted to give apport-collect permissions for Launchpad you will need to give it at least the ability to "Change Non-Private" data as it will be adding information to your bug report.

As this bug has already been confirmed I can then mark it accordingly and this bug can go straight on to the developers to be solved

Andreas Bulling (spam-hierher) wrote :

As mentioned in my bug report I'm running Kubuntu Karmic 9.10. I'm therefore not using gnome-power-manger and to be honest I'm also not very motivated to install it with all its dependencies. @peddanet: Which version of Ubuntu are you running? If yes, maybe you could provide the required information? @AdeGoodyer: Other possibility: Could you assign the bug to some KDE folks (as well)? I'd be happy to provide the required information but only without installing all Gnome dependencies...

adriangoodyer (adriangoodyer) wrote :

Ah, in your bug report it actually does say Ubuntu not Kubuntu which does change things somewhat.

In order to do anything further I need you to run the following command in terminal which will gather the relevant information about your system.

apport-collect 510138

This will gather the relevant critical information and attach itself to this report.

As you have also correctly stated, KDE is the GUI for Kubuntu but I'm not sure if this is the correct place to report a bug for that?

While i find out, run the above command line as even if this bug has to be passed on they are still going to need that info.

adriangoodyer (adriangoodyer) wrote :

I think this should be the correct package, someone please correct me if i am wrong!

affects: gnome-power-manager (Ubuntu) → kubuntu-kde4-meta (Ubuntu)
Andreas Bulling (spam-hierher) wrote :

It just says:

~# apport-collect 510138
Logging into Launchpad... You have to allow "Change anything" privileges.
Downloading bug information...
Bug title: On laptop Acer Aspire 1810TZ, brightness switch changes brightness twice
Package kubuntu-kde4-meta not installed and no hook available, ignoring
No additional information collected.
~#

adriangoodyer (adriangoodyer) wrote :

@Andreas Bulling

Not to worry, for some reason it has chosen not to provide the information, we will have to collect the info ourselves which will require a little work on your behalf I'm afraid.

If you could open the terminal again and run the following commands, separately and by pressing enter after each one.

1) uname -a > uname-a.log
2) dmesg > dmesg.log
3) sudo lspci -vvnn > lspci-vvnn.log
4) cat /proc/version_signature > version.log
then attach the files separately to the bug report (not pasted into comments or tar/zip-ed).

The if you go to "Places" > "Home folder" at the top of your screen you should find the four .log files from above in there.

You need to go back to the bug report on launchpad and attach these files to the bug report. You can do this by clicking on the text "add attachment or patch" which is located at the bottom of the screen below the add comment box. Thank you.

affects: kubuntu-kde4-meta (Ubuntu) → kdebase-runtime (Ubuntu)
Changed in kdebase-runtime (Ubuntu):
importance: Undecided → Low
adriangoodyer (adriangoodyer) wrote :

Thanks Yuriy!

@Andreas Bulling

Please ignore my previous post about attaching the files yourself, after seeking some advice we now should be in the right package so running the following command in the terminal should now work;

apport-collect 510138

Architecture: i386
DistroRelease: Ubuntu 9.10
InstallationMedia: Kubuntu-Netbook 9.10 "Karmic Koala" - Release i386 (20091028.4)
Package: kdebase-runtime 4:4.3.5-0ubuntu1~karmic1
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 LANGUAGE=
ProcVersionSignature: Ubuntu 2.6.31-18.55-generic
Uname: Linux 2.6.31-18-generic i686
UserGroups:

XsessionErrors:
 (polkit-gnome-authentication-agent-1:1940): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (firefox:2124): GLib-WARNING **: g_set_prgname() called multiple times
 (firefox:2296): GLib-WARNING **: g_set_prgname() called multiple times

Changed in kdebase-runtime (Ubuntu):
status: Incomplete → New
tags: added: apport-collected
adriangoodyer (adriangoodyer) wrote :

We got there in the end! Thanks Andreas for being patient. As there is enough information for the developer to start work I am going to mark this bug as confirmed and let then deal with the bug from here on in. Many thanks.

Changed in kdebase-runtime (Ubuntu):
status: New → Confirmed
Andreas Bulling (spam-hierher) wrote :

Thank you for taking care of this bugreport!

Andreas Bulling (spam-hierher) wrote :

Any news on this yet? I just noticed that the bug is still not assigned to anybody. Thanks!

adriangoodyer (adriangoodyer) wrote :

Nothing yet. I have requested the bug to be marked as Triaged, hopefully this will instigate some activity on it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers