[karmic] Strigi indexer notifications after suspend/hiberbation

Bug #406167 reported by Jithin Emmanuel on 2009-07-29
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
Strigi
Fix Released
Medium
kdebase-runtime (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: strigi-daemon

After resuming from suspend or hibernate, I am always getting notifications from Nepomuk.
First Its says "suspending strigi indexing to preserve system resources"
then after a few seconds its says "Resuming Strigi file indexing".

Then again after few seconds it goes back to suspending this goes on for ever until I logout or restart.

This happens only after I do a suspend or hibernation in my laptop.

summary: - Strigi indexer notifications after suspend/hiberbation
+ [karmic] Strigi indexer notifications after suspend/hiberbation

I'm seeing this too and it's extremely annoying. For me, it doesn't depend on a suspend/resume cycle. I get this on and off all the time. As I wrote in the upstream bug report, just now I watched a 50 min film clip with tons of these notifications completely ruining my experience.

I'll attach a patch (and a debdiff) that simply removes two lines from eventmonitor.cpp in kdebase-runtime. This might not be the most elegant way to go about, but I can't see how it would hurt. In either case it does wonders for usability while watching a film :-p

And here's the debdiff against 4:4.2.98-0ubuntu2

And here's the debdiff against 4:4.2.98-0ubuntu2.

By the way, I haven't tested this yet, but I'm going ahead with that just about now.

If it's at all plausible that this patch would make it to karmic, I can provide debs for testing as well.

affects: strigi (Ubuntu) → kdebase-runtime (Ubuntu)
Changed in kdebase-runtime (Ubuntu):
status: New → Confirmed
Changed in hundredpapercuts:
status: New → Confirmed
tags: added: hundredpaperkuts kde
Changed in kdebase-runtime (Ubuntu):
importance: Undecided → Low
Changed in strigi:
status: Unknown → Confirmed

I have built some packages with this patch if anyone is interested in testing (but please remember to remove my PPA from your sources.list after installing these packages - you do not want packages being installed from there accidentally). https://launchpad.net/~khashayar/+archive/builder

Also, I'm adding a new debdiff, since the official package was bumped to 0ubuntu3.

Jonathan Thomas (echidnaman) wrote :

Fix committed in bzr for release with KDE 4.3.0 (http://bazaar.launchpad.net/~kubuntu-members/kdebase-runtime/ubuntu/revision/49) Thank you for your contribution to Kubuntu.

Changed in kdebase-runtime (Ubuntu):
status: Confirmed → Fix Committed
Changed in hundredpapercuts:
status: Confirmed → Fix Committed
Jithin Emmanuel (jithin1987) wrote :

There might be more to this bug than the work around of removing notification emitting. Upstream bug dealing with this issue.
https://bugs.kde.org/show_bug.cgi?id=200327

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdebase-runtime - 4:4.3.0-0ubuntu1

---------------
kdebase-runtime (4:4.3.0-0ubuntu1) karmic; urgency=low

  [ Jonathan Thomas ]
  * New upstream release:
    - Bump KDE versions
  * Merge from Debian Experimental, remaining changes:
    - helpcenter4 no recommend on htdig
    - kde-base is not an alternative dep to kdebase-runtime-data-common in
      kdebase-runtime-data
    - Keep khelpcenter transitional package with appropriate replaces
    - Remove dependency from kdebase-runtime-bin-kde4 on pmount
    - khelpcentre4 Conflicts: khelpcenter (<< 4:4.1.2), khelpcenter-kde4
    - Set DEB_KDE_LINK_WITH_AS_NEEDED = no for kde file dialogs in Qt apps
    - Remove:
      - 01_kde4_information_menu.diff
      - 02_ksvgtopng4.diff
      - 03_ktrash4.diff
    - Keep:
      - kubuntu_01_nodisplay_knetattach.diff
      - kubuntu_02_fix_dash_incompatibility.diff
      - kubuntu_03_knetattach_use_sftp.diff
      - kubuntu_04_kiosmb.diff
      - kubuntu_05_knetattach_open_filebrowser.diff
      - kubuntu_06_fix_knetattach_folder_icon.diff
      - kubuntu_07_oxygenify_knetattach_icon.diff
      - kubuntu_85_language_selector.diff
  * Update KUBUNTU_DEBIAN_DIFFERENCES
  * Bump kdebase-runtime-data's replace version of kdebase-workspace-data to
    (<< 4:4.2.95) (LP: #405726)

  [ Khashayar Naderehvandi ]
  * Add kubuntu_09_remove_indexer_notifications.diff to remove unnecessary
    notifications from strigi (LP: #406167)

 -- Jonathan Thomas <email address hidden> Wed, 29 Jul 2009 16:40:04 -0400

Changed in kdebase-runtime (Ubuntu):
status: Fix Committed → Fix Released
Celeste Lyn Paul (seele) on 2009-08-10
Changed in hundredpapercuts:
milestone: none → round-8
Michael Rooney (mrooney) wrote :

Marking the paper cut task as released since the fix has landed in Karmic!

Changed in hundredpapercuts:
status: Fix Committed → Fix Released

I have installed the RC yesterday and am seeing the exact symptoms mentioned above. It's quite possible this bug has found its way back in to the RC.

Jonathan Thomas (echidnaman) wrote :

The patch was removed as it couldn't be applied in KDE 4.3.2.
Strigi not being enabled by default cemented its removal.

FriedChicken (domlyons) wrote :

As Jithin Emmanuel wrote above there's an upstream bug report: https://bugs.kde.org/show_bug.cgi?id=200327

There it is said that the underlying bug (not only the notification) is fixed upstream. Maybe this can be backported.

Changed in strigi:
status: Confirmed → Unknown
Jonathan Thomas (echidnaman) wrote :

Yeah, the fix will come in KDE 4.3.3, which should be released in a week and a day's time.

Changed in strigi:
status: Unknown → Fix Released
Changed in strigi:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.