nepomukservicestub causes crash in Soprano::Redland backend

Bug #317271 reported by hackel on 2009-01-14
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Redland librdf
Won't Fix
High
kdebase-runtime (Ubuntu)
Medium
Unassigned
Jaunty
Medium
Unassigned
kubuntu-default-settings (Ubuntu)
High
Unassigned
Jaunty
High
Unassigned

Bug Description

Binary package hint: kdebase-runtime

This occurred on my very first boot of a kubuntu jaunty daily CD from 14 Jan.

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/nepomukservicestub
Package: kdebase-runtime 4:4.1.85-0ubuntu2
ProcCmdline: /usr/bin/nepomukservicestub nepomukstorage
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
 LANGUAGE=en_US
Signal: 11
SourcePackage: kdebase-runtime
StacktraceTop:
 librdf_world_open () from /usr/lib/librdf.so.0
 librdf_new_hash_datum () from /usr/lib/librdf.so.0
 librdf_hash_get_one () from /usr/lib/librdf.so.0
 librdf_new_uri () from /usr/lib/librdf.so.0
 ?? () from /usr/lib/librdf.so.0
Title: nepomukservicestub crashed with SIGSEGV in librdf_world_open()
Uname: Linux 2.6.28-4-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

hackel (hackel) wrote :

StacktraceTop:librdf_world_open (world=0xb7e55fd8) at rdf_init.c:261
librdf_new_hash_datum (world=0xb7e55fd8, data=0x0, size=0)
librdf_hash_get_one (hash=0xbfbce970, key=0xb3da6018)
librdf_new_uri (world=0x911d9a8,
librdf_raptor_new_uri (context=0x911d9a8,

Changed in kdebase-runtime:
importance: Undecided → Medium

It seems to be crashing in the redland soprano backend.

Connor Imes (rocket2dmn) wrote :

Jonathan, do you know if this bug is filed upstream, or if it needs to be? I searched on bugs.kde.org for "nepomukservicestub" and found 2 bugs, one from Mandriva and another from a compiled from source. Do we need to file another?

Thanks.

Changed in redland:
importance: Medium → High
status: New → Triaged
Loopy (ronny-naeder) on 2009-01-31
description: updated
Connor Imes (rocket2dmn) wrote :

Bug 323296 shows that this is still present in the final release of KDE 4.2

Loopy, please do not add "me too" comments in the bug description. If you do have information to add to bugs, please add a regular comment, like this one. Thank you.

Connor Imes (rocket2dmn) on 2009-01-31
description: updated
Changed in librdf:
status: Unknown → New
Connor Imes (rocket2dmn) wrote :

I filed this upstream and attached it to the report. I included the backtrace from bug 323296 since it is the stable release of KDE4.2 rather than the trace from this one.

Jonathan Thomas (echidnaman) wrote :

Thanks for filing this upstream.

Connor Imes (rocket2dmn) wrote :

The upstream developer says:

"Cannot reproduce this with KDE 4.2, Sorprano 2.2.1, and redland 1.0.7 on Kubuntu. (Hint to Kubuntu maintainers: please update Soprano to 2.2.1). BTW: It is highly recommended to use the sesame2 backend instead of the redland one. Redland has very bad query performance and misses many important features. Thus, Nepomuk in KDE will not work reliable with the redland backend. "

What say the Kubuntu devs? Thanks.

Steve Stalcup (vorian) wrote :

Soprano has been updated to 2.2.1

Changed in redland:
status: Triaged → Fix Released
Changed in librdf:
status: New → Invalid
Jonathan Riddell (jr) wrote :

Re-opening, I still have a crash on today's live CD which includes libsoprano4 2.2.1

Changed in redland:
status: Fix Released → Confirmed
Jonathan Riddell (jr) wrote :

soprano-backend-sesame is now available in multiverse, but can't be on the CD since it's non-free (can't be built from source) and we have no space for java.

Changed in librdf:
status: Invalid → New
Sergei Andreev (seajey) wrote :

And how about this new backend:
"A new backend for Soprano which could finally let us drop the sesame2 backend which needs a JVM.

Today I committed the new Virtuoso Soprano backend. Virtuoso is a powerful SQL/RDF DB server created by OpenLink Software. OpenLink provides an open-source version of their database server released under the GPL. The official description from their homepage reads:

    At core, Virtuoso is a high-performance object-relational SQL database. As a database, it provides transactions, a smart SQL compiler, powerful stored-procedure language with optional Java and .Net server-side hosting, hot backup, SQL-99 support and more. It has all major data-access interfaces, such as ODBC, JDBC, ADO .Net and OLE/DB.
    [...]
    OpenLink Virtuoso supports SPARQL embedded into SQL for querying RDF data stored in Virtuoso’s database. SPARQL benefits from low-level support in the engine itself, such as SPARQL-aware type-casting rules and a dedicated IRI data type. This is the newest and fastest developing area in Virtuoso."

[...]
Virtuoso not only frees us from the shackles of the java dependency. It also provides a bunch of features that Sesame2 does not. Most importantly Virtuoso features full text indexing which can be used within SPARQL queries
[...]
The nice guys at OpenLink were very open to the idea of using their server in KDE. With the release of Virtuoso 5.0.10 they introduced a new lite mode which trims the server down to our needs. The memory usage goes down to a minimum: IMHO roughly 80M is acceptable. (Especially since the JVM easily goes up to 10 times that value!) That in combination with disabling pretty much all features except for SPARQL we have a decent desktop DB solution.

Source:
http://trueg.wordpress.com/2009/02/19/a-new-blog-and-the-possible-end-to-the-java-dependancy-in-nepomuk-kde/

Shaved Wookie (shavedwookie) wrote :

Sounds interesting to me (not that I know anything about these things).

By the way, I installed the soprano-backend-sesame package and am still getting this error. Is there somewhere one needs to go to activate the sesame backend instead of Redland? I couldn't see any option in System Settings ->Nepomuk...

Connor Imes (rocket2dmn) on 2009-02-21
Changed in redland:
status: Confirmed → Triaged

Is the sesame2 backend really working the way it should?
No matter what I do, the redland backend seems to be used. Even after I change ~/.kde/share/config/nepomukserverrc to use the sesame2 backend, the config file reverts to redland after I restart nepomuk. What gives?

Szabó András (szabo-a-a-g) wrote :

Just downloaded the Kubuntu 9.04 distro and when started the Live CD just then appeared the error message.
Pentium 2.4 GHz, BH7 motherboard with 1.5 GByte RAM, Nvidia Geforce 4 MMX 440 64 MByte RAM monitor card.

If I have found other observations will describe. Have Ubuntu 9.04 also that does not shown any problems, except it did not recognised the Logitech STX WEB camera.

Good luck!

Dave Morley (davmor2) wrote :

Szabo you will need to list the webcam as a separate bug other wise it will get missed when this bug is fixed

Jonathan Thomas (echidnaman) wrote :

Aurelien Gateau fixed this by turning off Nepomuk and nepomukstrigiservice by default in kubuntu-default-settings.
The crash would still be there if you turned it back on, but by default most people won't notice the bug any more. :)

Changed in kubuntu-default-settings (Ubuntu Jaunty):
importance: Undecided → High
status: New → Fix Released
Changed in redland (Ubuntu Jaunty):
importance: High → Medium
Martin Pitt (pitti) wrote :

Not a jaunty blocker then, should be fixed in karmic.

Changed in kdebase-runtime (Ubuntu Jaunty):
status: Triaged → Won't Fix
Norbert Schultz (zaiib) wrote :

So no desktop search in kubuntu 09.04?

Jonathan Riddell (jr) wrote :

"soprano-backend-sesame is now available in multiverse"

MY SYSTEM IS UBUNTU + KDE, NOT KUBUNTU
I DID NOT SPEAK ENGLISH
--------------------------------------------------
From: "Norbert Schultz" <email address hidden>
Sent: Friday, April 17, 2009 1:23 PM
To: <email address hidden>
Subject: [Bug 317271] Re: nepomukservicestub causes crash in
Soprano::Redlandbackend

> So no desktop search in kubuntu 09.04?
>
> --
> nepomukservicestub causes crash in Soprano::Redland backend
> https://bugs.launchpad.net/bugs/317271
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Redland librdf: New
> Status in “kdebase-runtime” source package in Ubuntu: Triaged
> Status in “kubuntu-default-settings” source package in Ubuntu: Fix
> Released
> Status in kdebase-runtime in Ubuntu Jaunty: Won't Fix
> Status in kubuntu-default-settings in Ubuntu Jaunty: Fix Released
>
> Bug description:
> Binary package hint: kdebase-runtime
>
> This occurred on my very first boot of a kubuntu jaunty daily CD from 14
> Jan.
>
> ProblemType: Crash
> Architecture: i386
> DistroRelease: Ubuntu 9.04
> ExecutablePath: /usr/bin/nepomukservicestub
> Package: kdebase-runtime 4:4.1.85-0ubuntu2
> ProcCmdline: /usr/bin/nepomukservicestub nepomukstorage
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> LANGUAGE=en_US
> Signal: 11
> SourcePackage: kdebase-runtime
> StacktraceTop:
> librdf_world_open () from /usr/lib/librdf.so.0
> librdf_new_hash_datum () from /usr/lib/librdf.so.0
> librdf_hash_get_one () from /usr/lib/librdf.so.0
> librdf_new_uri () from /usr/lib/librdf.so.0
> ?? () from /usr/lib/librdf.so.0
> Title: nepomukservicestub crashed with SIGSEGV in librdf_world_open()
> Uname: Linux 2.6.28-4-generic i686
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Szabó András (szabo-a-a-g) wrote :

Dear Dave Morley,

Yes I know and will report the webcam problem. Thanks & good luck!

tags: added: iso-testing
Jonathan Thomas (echidnaman) wrote :

Upstream has depreciated the redland backend, so this won't be fixed. Though it won't be fixed, it shouldn't be an issue in any recent Kubuntu release.

Changed in kdebase-runtime (Ubuntu):
status: Triaged → Won't Fix
Changed in librdf:
status: New → Won't Fix
Szabó András (szabo-a-a-g) wrote :

In the meantime I have changed my computer and system so as this way the problem does not affect me anymore.

Anyway, thanks all helpness!

Changed in librdf:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.