kscreensaver-xsavers 4:4.5.80-0ubuntu1 package fails to install

Bug #682467 reported by Gareth Hart on 2010-11-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kdeartwork (Ubuntu)
Medium
Philip Muškovac

Bug Description

Binary package hint: kdeartwork

Attempting to upgrade my Natty install tonight, the package kscreensaver-xsavers 4:4.5.80-0ubuntu1 fails to install. It fails with the error message:

dpkg: error processing /var/cache/apt/archives/kscreensaver-xsavers_4%3a4.5.80-0ubuntu1_amd64.deb (--unpack):
 trying to overwrite '/usr/share/kde4/services/ScreenSavers/fiberlamp.desktop', which is also in package kscreensaver-xsavers-extra 4:4.5.80-0ubuntu1
Errors were encountered while processing:
 /var/cache/apt/archives/kscreensaver-xsavers_4%3a4.5.80-0ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:

I am using the 64-bit version of Natty.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: kscreensaver-xsavers 4:4.5.3-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.37-6.17-generic 2.6.37-rc3
Uname: Linux 2.6.37-6-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sun Nov 28 20:15:04 2010
ProcEnviron:
 LANGUAGE=
 LANG=C
 SHELL=/bin/bash
SourcePackage: kdeartwork

Related branches

Gareth Hart (tghe-retford) wrote :
Philip Muškovac (yofel) wrote :

Thank you for taking your time to report this bug.

Can be reproduced by installing kscreensaver-xsavers and kscreensaver-xsavers-extra.

Changed in kdeartwork (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Philip Muškovac (yofel) on 2010-11-29
Changed in kdeartwork (Ubuntu):
assignee: nobody → Philip Muškovac (yofel)
status: Triaged → In Progress
Gareth Hart (tghe-retford) wrote :

Just to add, an update for kscreensaver-xsavers 4:4.5.80-0ubuntu2 appeared when I did aptitude safe-upgrade, and it's now showing a different error:

dpkg: error processing /var/cache/apt/archives/kscreensaver-xsavers_4%3a4.5.80-0ubuntu2_amd64.deb (--unpack):
 trying to overwrite '/usr/share/kde4/services/ScreenSavers/glcells.desktop', which is also in package kscreensaver-xsavers-extra 4:4.5.80-0ubuntu2
Errors were encountered while processing:
 /var/cache/apt/archives/kscreensaver-xsavers_4%3a4.5.80-0ubuntu2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdeartwork - 4:4.5.80-0ubuntu3

---------------
kdeartwork (4:4.5.80-0ubuntu3) natty; urgency=low

  [ Philip Muskovac ]
  * remove fiberlamp, glcells and glschool from kscreensaver-xsavers-extra
    since they moved to kscreensaver-xsavers (LP: #682467)

  [ Jonathan Riddell ]
  * Sync kscreensaver-xsavers-extra.install with contents of
    xscreensaver-gl-extra and xscreensaver-data-extra
 -- Jonathan Riddell <email address hidden> Tue, 30 Nov 2010 18:29:23 +0000

Changed in kdeartwork (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers