Invisible lock screen in KDE

Bug #1252662 reported by kolen on 2013-11-19
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
kde-workspace
Unknown
Medium
kdeartwork (Ubuntu)
Undecided
Unassigned

Bug Description

When I lock screen in KDE (or return from suspend), I can see all windows and move mouse, but mouse button presses and keypresses don't work. Seems that there is invisible fully transparent lock screen that blocks all mouse and keyboard buttons but don't cloak screen and don't allow to enter password and unlock.

Only way to exit this is to restart X server or whole system.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: kscreensaver 4:4.11.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-14.21-generic 3.11.7
Uname: Linux 3.11.0-14-generic x86_64
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
Date: Tue Nov 19 13:04:07 2013
InstallationDate: Installed on 2013-10-23 (27 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MarkForUpload: True
SourcePackage: kdeartwork
UpgradeStatus: No upgrade log present (probably fresh install)

When trying that, I got to my desktop screen after a suspend, but it was frozen, no reaction to mouse or keyboard. Maybe the screen locker overlay has focus but is invisible/hidden?

I did this because I wanted to set a wallpaper for the locker - that should be possible for the simple locker too!

Reproducible: Always

Steps to Reproduce:
1. change the screen locker to "Desktop Widgets"
2. change the wallpaper in the settings for that option
3. suspend
4. resume
Actual Results:
desktop is visible, but inaccessible

Expected Results:
Desktop Widgets screen locker visible and accessible

This is the RC1 packages, not the beta2 - but there is no such version here.
lenovo u310 / intel 3000 gpu / x86_64 / chakra linux kde-unstable packages

I can confirm this! Screen locker with widgets used to work in both beta1 and beta2 but got broken with RC1 of 4.10.0

Running openSUSE 12.2 binary packages.

With kde 4.10 RC2, when I resume the cachew menu is visible, and contains an item "unlock screen". Clicking it makes the password entry show.

Why isn't that just displayed???

I have now twice experienced that this did not work.

First time, there was no screen locker, but I could not use the mouse. I eventually found a window that had mouse focus, and regained it. Prior to that suspend, I had detached a wacom pad, and shut down krita.

Second time, I had to kill X and restart my session

Obviously, I do not find this configuratipon of the screen locker trustworthy at this point ;)

Tried suspending an extra time, same result as above - had to kill X.

How can I change the wallpaper of the "simle locker"?

I have this bug too. If I set the screen locker to "desktop widgets" and then "configure" it works normally. As soon as I lock the screen the following happens: no visible change (I see my desktop exactly as it was when I choose to lock the screen); I can move the mouse but cannot interact with anything on the desktop (it's like the screen is locked but the screenlocker is completely transparent). The only thing to do it restart X

This used to work fine for a while, then the bug popped up and I had to switch back to the simple locker. Eventually I tried again and the bug disappeared. Now it's back on two of my boxes.

Yesterday, I tried switching it on / off and revering to default themes and then back. Eventually it just starting working again. It was working fine when I went to bed, but this morning its back again!

Running Arch Linux, kdm, KDE 4.10.5-1.

Also, I'm wondering if this bug is in the correct section. Shouldn't this apply to kscreensaver / locker-qml?

I can confirm this bug in KDE versions prior to 4.11, but, in my tests, seems solved in 4.11.2 (not tested in previous bugfixes releases of this major series).

It's funny you mention it as fixed today, because it has been working fine for me for a while now too, but just last night I did an updated (via pacman) and it seems much of kde was bumped to 4.11.2-1.

Anyway, now the same problem is back and I had to switch to the normal locker again.

This is also a recent (few months) fresh install of arch and I'm running stock theme, etc.

Hmm. I'm also running Arch Linux testing up-to-date, KDE 4.11.2-1, Qt-theme bespin and plasma-theme Amakage, and seems to be working ok in some couples of suspend/resumes.

kolen (incredible-angst) wrote :
Changed in kdeartwork (Ubuntu):
status: New → Invalid
kolen (incredible-angst) on 2013-11-19
affects: kdeartwork → kde-workspace
Changed in kde-workspace:
importance: Unknown → Medium

This disappeared for a while. Just updated KDE on Arch today and this is back.

I had never experienced this problem until I ran updates this last weekend (archlinux).

The following packages (ones that seem like they might be relevant) were updated:
[2014-12-06 14:23] [PACMAN] upgraded phonon-qt4-gstreamer (4.8.0-2 -> 4.8.1-1)
[2014-12-06 14:23] [PACMAN] upgraded phonon-qt4 (4.8.2-1 -> 4.8.3-1)
[2014-12-06 14:23] [PACMAN] upgraded xapian-core (1:1.2.18-1 -> 1:1.2.19-1)
[2014-12-08 01:51] [PACMAN] upgraded libdbus (1.8.10-1 -> 1.8.12-1)
[2014-12-08 01:51] [PACMAN] upgraded dbus (1.8.10-1 -> 1.8.12-1)
[2014-12-08 01:51] [PACMAN] upgraded ffmpeg (1:2.4.4-1 -> 1:2.5-1)
[2014-12-08 01:51] [PACMAN] upgraded lib32-libdbus (1.8.10-1 -> 1.8.12-1)
[2014-12-08 01:51] [PACMAN] upgraded lib32-mesa-dri (10.3.4-1 -> 10.3.5-1)
[2014-12-08 01:51] [PACMAN] upgraded mesa-dri (10.3.4-1 -> 10.3.5-1)
[2014-12-08 01:51] [PACMAN] upgraded mesa (10.3.4-1 -> 10.3.5-1)
[2014-12-08 01:51] [PACMAN] upgraded lib32-mesa (10.3.4-1 -> 10.3.5-1)
[2014-12-08 01:51] [PACMAN] upgraded libevdev (1.3.1-1 -> 1.3.2-1)

Now, I can activate the desktop widgets locker from the settings and everything works fine. However if it is legitimately activated (from key-chord to lock desktop, time-out, closing laptop lid, etc.), then the locker does not show up, I just see my desktop but I can't interact with it. Only way I know of to get out of this state is by restarting the X server (Ctrl+Alt+Backspace or "systemctl restart kdm").

By the way, you can still access the lock screen, with the keyboard. It is a fairly good workaround, although muon discover is also broken for me(not updating to the screen), along with the desktop effect settings dialogue.

Hello!

This bug report was filed for KDE Plasma 4, which reached end-of-support status in August 2015. KDE Plasma 5's desktop shell has been almost completely rewritten for better performance and usability, so it is likely that this bug has already been resolved in Plasma 5.

Accordingly, we hope you understand why we must close this bug report. If the issue described here is still present in KDE Plasma 5.12 or later, please feel free to open a new ticket in the "plasmashell" product after reading https://community.kde.org/Get_Involved/Bug_Reporting

If you would like to get involved in KDE's bug triaging effort so that future mass bug closes like this are less likely, please read https://community.kde.org/Get_Involved#Bug_Triaging

Thanks for your understanding!

Nate Graham

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.