systemsettings crashed with ImportError in /usr/share/kde4/apps/system-config-printer-kde/options.py: No module named ppdippstr

Bug #793679 reported by Marián Kadaňka on 2011-06-06
64
This bug affects 7 people
Affects Status Importance Assigned to Milestone
kdeadmin (Ubuntu)
High
Jonathan Riddell
Oneiric
High
Scott Kitterman
Precise
High
Jonathan Riddell

Bug Description

Binary package hint: kdebase-workspace

Using Kubuntu 11.10 Alpha1 x64 Live CD:
System Settings -> Printer Configuration -> CRASH with this text in the Printer Config window:
"The service 'Printer Configuration' does not provide an interface 'KCModule' with keyword 'system-config-printer-kde/system-config-printer-kde.py'The factory does not support creating components of the specified type."

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: systemsettings 4:4.6.3-1ubuntu3
ProcVersionSignature: Ubuntu 2.6.39-3.10-generic 2.6.39
Uname: Linux 2.6.39-3-generic x86_64
Architecture: amd64
Date: Mon Jun 6 18:11:40 2011
ExecutablePath: /usr/bin/systemsettings
LiveMediaBuild: Kubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110601)
ProcCmdline: /usr/bin/systemsettings -caption System\ Settings --icon preferences-system
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
 LANGUAGE=
SourcePackage: kdebase-workspace
Title: systemsettings crashed with ImportError in /usr/share/kde4/apps/system-config-printer-kde/options.py: No module named ppdippstr
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

visibility: private → public
tags: removed: need-duplicate-check
affects: kdebase-workspace (Ubuntu) → kdeadmin (Ubuntu)
Ingo Ratsdorf (ingo-envirology) wrote :
Download full text (4.2 KiB)

I can confirm this bug.
I have copied from https://fedorahosted.org/system-config-printer/browser/ppdippstr.py and placed into /usr/share/kde4/apps/system-config-printer-kde/

then the output changes to:

kcmshell(6089)/kdecore (KSycoca) KSycocaPrivate::openDatabase: Trying to open ksycoca from "/var/tmp/kdecache-ingo/ksycoca4"
kcmshell(6089)/kutils (KCMultiDialog) KCMultiDialog::addModule: "Printer Configuration"
kcmshell(6089)/kutils (KCModuleProxy) KCModuleProxyPrivate::loadModule: Module not already loaded, loading module "Printer Configuration" from library "kpythonpluginfactory" using symbol "kpythonpluginfactory"
kcmshell(6089)/python (plugin) KPythonPluginFactory::KPythonPluginFactory: KPythonPluginFactory::KPythonPluginFactory()
kcmshell(6089)/python (plugin) KPythonPluginFactory::initialize: Initializing Python interpreter.
kcmshell(6089)/python (plugin) KPythonPluginFactory::initialize: Succesfully initialized Python interpreter.
kcmshell(6089)/python (plugin) KPythonPluginFactory::create: KPythonPluginFactory::create iface: KCModule
kcmshell(6089)/python (plugin) KPythonPluginFactory::create: keyword to be used for finding the plugin code: "system-config-printer-kde/system-config-printer-kde.py"
kcmshell(6089)/python (plugin) KPythonPluginFactory::create: Path to plugin code is: "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py"
kcmshell(6089)/python (plugin): Failed to import module
Traceback (most recent call last):
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 66, in <module>
    from cupshelpers.smburi import SMBURI
ImportError: No module named smburi
kcmshell(6089)/python (plugin) KPythonPluginFactory::create: KPythonPluginFactory::create iface: KCModule
kcmshell(6089)/python (plugin) KPythonPluginFactory::create: keyword to be used for finding the plugin code: ""
kcmshell(6089)/python (plugin) KPythonPluginFactory::create: Path to plugin code is: "/home/ingo/.kde/share/apps/"
kcmshell(6089)/python (plugin): Failed to import module
kcmshell(6089)/kcontrol KCModuleLoader::loadModule: This module has no valid entry symbol at all. The reason could be that it's still using K_EXPORT_COMPONENT_FACTORY with a custom X-KDE-FactoryName which is not supported anymore
kcmshell(6089)/kutils (KCMultiDialog) KCMultiDialog::addModule: adding KCM "Printer Configuration" at the top level
kcmshell(6089)/kutils (KCMultiDialog) KCMultiDialogPrivate::_k_slotCurrentPageChanged:
kcmshell(6089)/kutils (KCMultiDialog) KCMultiDialogPrivate::_k_clientChanged:
kcmshell(6089)/kutils (KCMultiDialog) KCMultiDialogPrivate::_k_clientChanged:
kcmshell(6089)/kutils (KCMultiDialog) KCMultiDialogPrivate::_k_dialogClosed:
kcmshell(6089)/python (plugin) KPythonPluginFactory::~KPythonPluginFactory: KPythonPluginFactory::~KPythonPluginFactory()

However, there is a lot of cupshelpers:
/usr/lib/python2.7/dist-packages/cupshelpers
/usr/lib/python2.7/dist-packages/cupshelpers/cupshelpers.pyc
/usr/lib/python2.7/dist-packages/cupshelpers/cupshelp...

Read more...

tags: added: iso-testing
Scott Kitterman (kitterman) wrote :

Confirmed based on dupes.

Changed in kdeadmin (Ubuntu):
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Jonathan Riddell (jr)
tags: added: rls-mgr-o-tracking
Scott Kitterman (kitterman) wrote :

Fix uploaded. The problem is that those files are provided by system-config-printer-common and not in the python path for system-config-printer-kde.

Changed in kdeadmin (Ubuntu Oneiric):
assignee: Jonathan Riddell (jr) → Scott Kitterman (kitterman)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdeadmin - 4:4.7.1-0ubuntu3

---------------
kdeadmin (4:4.7.1-0ubuntu3) oneiric; urgency=low

  * Add system-config-printer-kde.links to link s-c-p-common python modules
    that are used in s-c-d-kde (ppdippstr.py, pysmb.py, smburi.py)
    (LP: #793679)
  * Add python-smbc to system-config-printer-kde Depends (it is already a
    transative depends through system-config-printer-system, but since it
    uses smbc directly, it should be in depends)
  * Re-apply dh_python2 conversion that got dropped by the rebuild (LP: #825536)
 -- Scott Kitterman <email address hidden> Tue, 04 Oct 2011 11:47:13 -0500

Changed in kdeadmin (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Jonathan Riddell (jr) wrote :

reopening for precise, I want to fix this properly upstream

Changed in kdeadmin (Ubuntu Precise):
assignee: Scott Kitterman (kitterman) → Jonathan Riddell (jr)
status: Fix Released → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdeadmin - 4:4.7.3-0ubuntu1

---------------
kdeadmin (4:4.7.3-0ubuntu1) precise; urgency=low

  * New upstream release
  * Merge with Debian git remaining changes:
    - debian/control:
      - kde-config-cron conflicts/replaces on kcron (<< 4:4.4.60)
      - system-config-printer-kde depends on system-printer-common
      - system-config-printer-kde doesn't depend on python-cupsutils
    - debian/patches:
      - Remove 01_system_config_printer_kde_cupsutils.diff, it's only
        relevant for Debian not Ubuntu
    - Add system-config-printer-kde.links to link s-c-p-common python modules
      that are used in s-c-d-kde (ppdippstr.py, pysmb.py, smburi.py) LP: #793679
    - Do not include full copies of files from system-config-printer-common in
      debian/ and remove from system-config-printer-kde.install

kdeadmin (4:4.7.2-0r2) UNRELEASED; urgency=low

  [ Daniele E. Domenichelli ]
  * New upstream release.
  * Update patches/system_config_printer_kde_cupsutils.diff.
  * Update installed files.
  * Fix lintian infos:
    * copyright-with-old-dh-make-debian-copyright
    * kcron: capitalization-error-in-description kde KDE

  [ José Manuel Santamaría Lema ]
  * Add some files needed by system-config-printer-kde.

kdeadmin (4:4.6.5-2) unstable; urgency=low

  [ Modestas Vainius ]
  * Switch to dh_python2 and actually enable byte-compilation for
    system-config-printer-kde.

kdeadmin (4:4.6.5-1) unstable; urgency=low

  * New upstream release.

  [ José Manuel Santamaría Lema ]
  * Bump kde-sc-dev-latest build dependency to 4:4.6.5.
 -- Jonathan Riddell <email address hidden> Wed, 23 Nov 2011 23:46:47 +0000

Changed in kdeadmin (Ubuntu Precise):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers