Printer configuration was working, installed Samba4 for browsing samba shares, crashes now

Bug #763369 reported by steve
102
This bug affects 18 people
Affects Status Importance Assigned to Milestone
kdeadmin (Ubuntu)
Confirmed
Medium
Unassigned

Bug Description

Binary package hint: kdebase-workspace

Kubuntu 11.04 Beta 2 - Printer configuration appeared to be working but couldn't browse samba shares. I installed samba4 and was able to scan "some" of the samba shares. Now on all attempts, the Printer configuration immediately crashes.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: systemsettings 4:4.6.2a-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Sun Apr 17 00:13:32 2011
ExecutablePath: /usr/bin/systemsettings
InstallationMedia: Kubuntu 11.04 "Natty Narwhal" - Beta i386 (20110413.1)
ProcCmdline: /usr/bin/systemsettings -caption System\ Settings -icon preferences-system
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: kdebase-workspace
Title: systemsettings crashed with AttributeError in fillPrinterOptions(): 'bool' object has no attribute 'markDefaults'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (knotify4:1567): GStreamer-CRITICAL **: gst_debug_add_log_function: assertion `func != NULL' failed
 (<unknown>:1927): Gdk-CRITICAL **: IA__gdk_window_get_origin: assertion `GDK_IS_WINDOW (window)' failed
 (<unknown>:1927): Gdk-WARNING **: /build/buildd/gtk+2.0-2.24.4/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window

Revision history for this message
steve (stephencorey) wrote :
tags: removed: need-duplicate-check
visibility: private → public
affects: kdebase-workspace (Ubuntu) → kdeadmin (Ubuntu)
Changed in kdeadmin (Ubuntu):
status: New → Confirmed
Changed in kdeadmin (Ubuntu):
status: New → Confirmed
Revision history for this message
Scott Kitterman (kitterman) wrote :

Looking at this bug and the duplicates, I think this is caused by python-cups failing to find the relevant PPD file and system-config-printer-kde not handling the situation very well.

Revision history for this message
Guido Jäkel (guido-jaekel) wrote :

Dear Scott,
you're completely right:

configuring a new computer I run into the same issue:

* adding a remote printer (via ipp:), first tests works fine
* after declaring it as the default, the Printer Administration Page on systemsettings fail. Running it from the console, it drops the same error messages as above.

The solution was to copy the appropriate ppd file for the defined remote printer to /etc/cups/ppd/ . (I my case, i was able to copy it from the same directory on the remote server, because in my case the printer is attached there as a local one.)

After restarting the cups service, the Administration Panel works, again. In addition, the print dialogs in other applications now choose the right default settings for the paper size.

Revision history for this message
Carsten Schlipf (carsten-schlipf) wrote :

Thank you very much, Guido. After quite some googling this finally saved the problem for me as well.

Changed in kdeadmin (Ubuntu):
importance: Undecided → Medium
Revision history for this message
memartin (memartin) wrote :

Using the workaround proposed by Guido I was able to fix the problem here under Precise 12.04 with a printer attached to another CUPS -Server in the LAN. It seems to be important, however, that the PPD file be named exactly like the CUPS printer name, or CUPS won't recognise it.

Revision history for this message
Myke Tux (tux-h) wrote :

I don't have access to the ppd files of my remote printer, so what I did was to rename the files at /etc/cups/printers.conf* and starting configuring the printers all over again.

Revision history for this message
Myke Tux (tux-h) wrote :

In addition, I created a "Generic" text-only PDF printer and set it to default. Also putted other printers inside groups. Now the bug is gonne and all printers work fine.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers