system-config-printer-kde doesn't work

Bug #383517 reported by Adam Reeve on 2009-06-04
64
This bug affects 12 people
Affects Status Importance Assigned to Milestone
kdeadmin (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kdeadmin-kde4

Opening Printer Configuration under System Settings I get this message:

The service 'Printer Configuration' does not provide an interface 'KCModule' with keyword 'system-config-printer-kde/system-config-printer-kde.py'The factory does not support creating components of the specified type.

In my ~/.xsession-errors this shows up:

Traceback (most recent call last):
  File "<string>", line 18, in kpythonpluginfactory_bridge
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 4003, in CreatePlugin
    0;0kcm = u.makeui(component_data, widget_parent)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 128, in makeui
    self.ui = PyKcm(component_data, parent, self)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 104, in __init__
    uic.loadUi(APPDIR + "/" + "system-config-printer.ui", self)
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/__init__.py", line 106, in loadUi
    return loader.DynamicUILoader().loadUi(uifile, baseinstance)
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/Loader/loader.py", line 22, in loadUi
    return self.parse(filename)
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/uiparser.py", line 690, in parse
    actor(elem)
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/uiparser.py", line 538, in createUserInterface
    self.traverseWidgetTree(elem)
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/uiparser.py", line 516, in traverseWidgetTree
    handler(self, child)
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/uiparser.py", line 320, in createLayout
    self.traverseWidgetTree(elem)
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/uiparser.py", line 516, in traverseWidgetTree
    handler(self, child)
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/uiparser.py", line 340, in handleItem
    self.traverseWidgetTree(elem)
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/uiparser.py", line 516, in traverseWidgetTree
    handler(self, child)
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/uiparser.py", line 163, in createWidget
    self.traverseWidgetTree(elem)
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/uiparser.py", line 516, in traverseWidgetTree
    handler(self, child)
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/uiparser.py", line 163, in createWidget
    self.traverseWidgetTree(elem)
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/uiparser.py", line 516, in traverseWidgetTree
    handler(self, child)
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/uiparser.py", line 320, in createLayout
    self.traverseWidgetTree(elem)
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/uiparser.py", line 516, in traverseWidgetTree
    handler(self, child)
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/uiparser.py", line 340, in handleItem
    self.traverseWidgetTree(elem)
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/uiparser.py", line 516, in traverseWidgetTree
    handler(self, child)
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/uiparser.py", line 320, in createLayout
    self.traverseWidgetTree(elem)
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/uiparser.py", line 516, in traverseWidgetTree
    handler(self, child)
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/uiparser.py", line 340, in handleItem
    self.traverseWidgetTree(elem)
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/uiparser.py", line 516, in traverseWidgetTree
    handler(self, child)
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/uiparser.py", line 157, in createWidget
    self.stack.push(self.setupObject(widgetClass(elem), parent, elem))
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/uiparser.py", line 130, in setupObject
    obj = self.factory.createQObject(clsname, name, args, is_attribute)
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/objcreator.py", line 63, in createQObject
    classType = self.findQObjectType(classname)
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/objcreator.py", line 73, in findQObjectType
    w = module.search(classname)
  File "/usr/lib/pymodules/python2.6/PyQt4/uic/Loader/qobjectcreator.py", line 50, in search
    self._modules[module] = __import__(module, {}, {}, (cls,))
ImportError: No module named kpushbutton

I'm running KDE 4.2.85-0ubuntu6 on Kubuntu 9.10.

Jonathan Thomas (echidnaman) wrote :

Confirming.

affects: kdeadmin-kde4 (Ubuntu) → kdeadmin (Ubuntu)
Changed in kdeadmin (Ubuntu):
status: New → Confirmed
Adam Reeve (adreeve) wrote :

Thought I should add that as a work around users can configure printers using the CUPS web interface at http://localhost:631.

Adam Reeve (adreeve) wrote :

This appears to be fixed after recent updates.

Jonathan Thomas (echidnaman) wrote :

Yeah, this should be fixed.

Changed in kdeadmin (Ubuntu):
status: Confirmed → Fix Released
David Solbach (d-vidsolbach) wrote :

The bug is present in the current kubuntu KDE 4.4 packages (I think since beta1, I just upgraded to 4.4 RC1 (PPA) and it's still there.)

I reopened this bug, I hope that's okay.

Changed in kdeadmin (Ubuntu):
status: Fix Released → In Progress
Jonathan Thomas (echidnaman) wrote :

It's probably a different issue. Probably because kdebindings for KDE 4.4 isn't compilable at the moment. That should be sorted by the time KDE 4.4.0 is released.

Changed in kdeadmin (Ubuntu):
status: In Progress → Fix Released
Zane (zanetu) wrote :

Same issue. Kubuntu 10.04 with KDE v4.4.2.

Changed in kdeadmin (Ubuntu):
status: Fix Released → New
Sybren Stüvel (sybren-stuvel) wrote :

Same issue. Kubuntu 10.04 with KDE 4.4.5 from the Kubuntu PPA:

kdelibs5:
  Installed: 4:4.4.5-0ubuntu1~lucid1~ppa1
  Candidate: 4:4.4.5-0ubuntu1~lucid1~ppa1
  Version table:
 *** 4:4.4.5-0ubuntu1~lucid1~ppa1 0
        500 http://ppa.launchpad.net/kubuntu-ppa/ppa/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
     4:4.4.2-0ubuntu4 0
        500 http://nl.archive.ubuntu.com/ubuntu/ lucid/main Packages

Peter Lemieux (seijisensei) wrote :

Same problem with kubuntu Maverick daily build from two days ago.

kdeadmin 4:4.4.92-0ubuntu1

By the way, kubuntu Maverick doesn't seem to install kdeadmin by default. Installing it manually does not fix this bug, however.

Jonathan Riddell (jr) wrote :

Works in current natty

Changed in kdeadmin (Ubuntu):
status: New → Fix Released
melendro (melendro) wrote :

Doesn't work for me in natty (kibuntu).
Please, reopen this bug.

Error now is:

Traceback (most recent call last):
  File "<string>", line 18, in kpythonpluginfactory_bridge
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 4398, in CreatePlugin
    kcm = u.makeui(component_data, widget_parent)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 374, in makeui
    self.populateList(start_printer, change_ppd)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 657, in populateList
    self.on_tvMainList_cursor_changed()
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 445, in on_tvMainList_cursor_changed
    self.fillPrinterTab(name)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 1267, in fillPrinterTab
    self.fillPrinterOptions(name, editablePPD)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 1311, in fillPrinterOptions
    ppd.markDefaults()
AttributeError: 'bool' object has no attribute 'markDefaults'

I got similar difficulties in this machine, however I've got no problems in another one I installed Kubuntu. I just upgraded to Kubuntu Natty from Maverick.

The problems that are displayed when I execute systemsettings in the terminal are identical to the ones of Melendro. Here is the log:

Traceback (most recent call last):
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 445, in on_tvMainList_cursor_changed
    self.fillPrinterTab(name)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 1267, in fillPrinterTab
    self.fillPrinterOptions(name, editablePPD)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 1311, in fillPrinterOptions
    ppd.markDefaults()
AttributeError: 'bool' object has no attribute 'markDefaults'
systemsettings(4062)/python (plugin): Error while running factory function for Python plugin: "system-config-printer-kde/system-config-printer-kde.py"
Traceback (most recent call last):
  File "<string>", line 18, in kpythonpluginfactory_bridge
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 4398, in CreatePlugin
    kcm = u.makeui(component_data, widget_parent)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 374, in makeui
    self.populateList(start_printer, change_ppd)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 657, in populateList
    self.on_tvMainList_cursor_changed()
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 445, in on_tvMainList_cursor_changed
    self.fillPrinterTab(name)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 1267, in fillPrinterTab
    self.fillPrinterOptions(name, editablePPD)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 1311, in fillPrinterOptions
    ppd.markDefaults()
AttributeError: 'bool' object has no attribute 'markDefaults'
systemsettings(4062)/python (plugin): Failed to import module
systemsettings(4062)/kcontrol KCModuleLoader::loadModule: This module has no valid entry symbol at all. The reason could be that it's still using K_EXPORT_COMPONENT_FACTORY with a custom X-KDE-FactoryName which is not supported anymore

If you need more information about my configuration please don't hesitate to ask. Thank you very much in advanced for any help given about this issue!

With today's updates I got this problem fixed. So I don't have any more issues in this matter. Thank you so much for all you good work!

Best regards,

-Andrey

N7DR (doc-evans) wrote :

I started getting this error following an upgrade from maverick to natty:

----

[HN:~] systemsettings
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
QFileSystemWatcher: failed to add paths: /home/n7dr/.config/ibus/bus
[HN:~] Traceback (most recent call last):
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 445, in on_tvMainList_cursor_changed
    self.fillPrinterTab(name)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 1267, in fillPrinterTab
    self.fillPrinterOptions(name, editablePPD)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 1311, in fillPrinterOptions
    ppd.markDefaults()
AttributeError: 'bool' object has no attribute 'markDefaults'
systemsettings(21589)/python (plugin): Error while running factory function for Python plugin: "system-config-printer-kde/system-config-printer-kde.py"
Traceback (most recent call last):
  File "<string>", line 18, in kpythonpluginfactory_bridge
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 4398, in CreatePlugin
    kcm = u.makeui(component_data, widget_parent)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 374, in makeui
    self.populateList(start_printer, change_ppd)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 657, in populateList
    self.on_tvMainList_cursor_changed()
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 445, in on_tvMainList_cursor_changed
    self.fillPrinterTab(name)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 1267, in fillPrinterTab
    self.fillPrinterOptions(name, editablePPD)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 1311, in fillPrinterOptions
    ppd.markDefaults()
AttributeError: 'bool' object has no attribute 'markDefaults'
systemsettings(21589)/python (plugin): Failed to import module
systemsettings(21589)/kcontrol KCModuleLoader::loadModule: This module has no valid entry symbol at all. The reason could be that it's still using K_EXPORT_COMPONENT_FACTORY with a custom X-KDE-FactoryName which is not supported anymore

----

My system is fully current, as of 31 May.

Gard Spreemann (gspreemann) wrote :

I'm seeing this in Oneiric as well, and it was not related to the upgrade from Natty. Printing and printing configuration have been working fine in Oneiric until I added a new printer. After adding it, I started encountering this bug and can no longer open the printer configuration.

Gard Spreemann (gspreemann) wrote :

Addendum to comment 15: If I remove the newly added printer in CUPS, the printer configuration module starts to work again.

David Grossberg (davidgro) wrote :

I'm seeing the same as comment 15 on a *Fresh* Kubuntu Oneiric install, except that I have yet to find a way to remove the printer; I can see it in the http://localhost:631 interface, I just can't do anything with it at all. Next I'll see if I can find it mentioned in in /etc/

The printer I added is physically connected to another machine on my network and shared in cups via IPP, and the one I am trying to add it to is my laptop.

Matteo Croce (teknoraver) wrote :

Happens on a fresh pangolin install

Matteo Croce (teknoraver) wrote :

Traceback (most recent call last):
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 445, in on_tvMainList_cursor_changed
    self.fillPrinterTab(name)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 1267, in fillPrinterTab
    self.fillPrinterOptions(name, editablePPD)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 1311, in fillPrinterOptions
    ppd.markDefaults()
AttributeError: 'bool' object has no attribute 'markDefaults'
systemsettings(4184)/python (plugin): Error while running factory function for Python plugin: "system-config-printer-kde/system-config-printer-kde.py"
Traceback (most recent call last):
  File "<string>", line 18, in kpythonpluginfactory_bridge
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 4398, in CreatePlugin
    kcm = u.makeui(component_data, widget_parent)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 374, in makeui
    self.populateList(start_printer, change_ppd)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 657, in populateList
    self.on_tvMainList_cursor_changed()
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 445, in on_tvMainList_cursor_changed
    self.fillPrinterTab(name)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 1267, in fillPrinterTab
    self.fillPrinterOptions(name, editablePPD)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 1311, in fillPrinterOptions
    ppd.markDefaults()
AttributeError: 'bool' object has no attribute 'markDefaults'
systemsettings(4184)/python (plugin): Failed to import module
systemsettings(4184)/kcontrol KCModuleLoader::loadModule: This module has no valid entry symbol at all. The reason could be that it's still using K_EXPORT_COMPONENT_FACTORY with a custom X-KDE-FactoryName which is not supported anymore

Lothar (lothar-tradescape) wrote :

When I run kcmshell4 system-config-printer-kde on the command line I get:

$ kcmshell4 system-config-printer-kde
Traceback (most recent call last):
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 445, in on_tvMainList_cursor_changed
    self.fillPrinterTab(name)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 1267, in fillPrinterTab
    self.fillPrinterOptions(name, editablePPD)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 1311, in fillPrinterOptions
    ppd.markDefaults()
AttributeError: 'bool' object has no attribute 'markDefaults'
kcmshell(8244)/python (plugin): Error while running factory function for Python plugin: "system-config-printer-kde/system-config-printer-kde.py"
Traceback (most recent call last):
  File "<string>", line 18, in kpythonpluginfactory_bridge
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 4398, in CreatePlugin
    kcm = u.makeui(component_data, widget_parent)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 374, in makeui
    self.populateList(start_printer, change_ppd)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 657, in populateList
    self.on_tvMainList_cursor_changed()
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 445, in on_tvMainList_cursor_changed
    self.fillPrinterTab(name)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 1267, in fillPrinterTab
    self.fillPrinterOptions(name, editablePPD)
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 1311, in fillPrinterOptions
    ppd.markDefaults()
AttributeError: 'bool' object has no attribute 'markDefaults'
kcmshell(8244)/python (plugin): Failed to import module
kcmshell(8244)/kcontrol KCModuleLoader::loadModule: This module has no valid entry symbol at all. The reason could be that it's still using K_EXPORT_COMPONENT_FACTORY with a custom X-KDE-FactoryName which is not supported anymore

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers