include print-ruler in Kubuntu

Bug #340958 reported by Mark on 2009-03-11
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KDE-Admin
Unknown
Wishlist
kdeadmin (Ubuntu)
Wishlist
Unassigned

Bug Description

There is a programme called printruler http://code.google.com/p/printruler/ which allows it to collect print jobs from different sources and allows it to rearrange them, delete single pagess before printing. It is very nice tool, but it could need some love and integration. I would be good to have it as a pseudo printer and not as a single programme and have it automatically give unique names to the temporary files (so that files are not overwritten accidentally because the have the same name). There is also a bug in KDE for this https://bugs.kde.org/show_bug.cgi?id=90989 , but may be it is also useful here, because I heard that Kubuntu folks were responsible for the printing stuff in KDE.

Revision history for this message
In , M-wege (m-wege) wrote :

Version: 0.1 (using KDE 3.3.0, (3.1))
Compiler: gcc version 3.3.4 (Debian 1:3.3.4-12)
OS: Linux (i686) release 2.6.8.1-kanotix-5

To limit the amount of paper used during printing. I often print 2 pages on one side. But this feature only works within one printjob. I want the possibility to merge different printjobs to one, mix them and create the possibility to print more than one page on a side. The functionality should be similar like fineprint provides for windows

Revision history for this message
In , Kurt Pfeifle (pfeifle) wrote :

Mark,

thank you for your bug report/wishlist item.

The bug that your reported however, does not apply to KDEPrint. The reason:

--> this functionality has been implemented many years ago already! <--

The bug report will be closed.

To get the 2-up output you want, you should have CUPS installed. I did this
with the current KDE CVS HEAD version of KDEPrint (but this is the same in
the last few releases):

1. start kprinter
2. click "Expand" button (lower left)
3. select the "Files" tab
4. click "Add file" button (the uppermost one on the right side of the
    tab, see also tooltip)
5. select as many printable files as you want to put into one printjob
    (these may be PDF, PostScript, ASCII text, images like jpeg, png,
    tiff... -- and these may be mixed into the same job too!)
6. order the files as you want them to appear in the final printout (use
    the arrow buttons to the right of the tab)
7. select your target printer
8. click "Properties..." (upper right of the dialog)
9. on the "General" tab, select your 2-up or 4-up settings, on the other
    tabs select whatever applies (NOTE, that some settings do apply to
    some file types, like "scale to 100% of page size" only applies to
    images...)
10. print and be happy with KDEPrint ;-)

Final note: KDEPrint is just a frontend to the underlying print
subsystem. As such it works best with CUPS, which is very powerful
(and KDEPrint really shines with it).

KDEPrint's own functionality are the "Virtual Printers" such as "Print
to File (PDF)". If you want to use these in a similar way as described
above, you have to make sure that you have all the required pre-filters
installed which you can access via "Properties" --> "Filters" tab (see
the "Requirement: "exec:/...." comments there).

Cheers,
Kurt Pfeifle

Revision history for this message
In , M-wege (m-wege) wrote :

Thanks for your explaination. But this seems rather complicated. The
suggested procedure would require me to have the files I printed on my
computer and to print the whole file and not only parts of (at least I
understood it that). Also this procedure doesn't seem to support
OpenOffice-Files. If CUPS already in general support this functionality
this may be not be so difficult.
When I send a printing job to kprinter there should be the additional
choice "collect print job". Print jobs are collected and can be
rearranged until you choose print". This is the way Fineprint (unfortuneatly
only for Windows) does it.

Revision history for this message
In , Kdeprint-bugs (kdeprint-bugs) wrote :

What you describe looks like an intermediate layer between the application-level "print" (kdeprint in this case) and the spooler itself. IMO, this can be (and should be) implemented as a separate tool that can be fired from kdeprint through the pseudo-printer framework: just imagine a "Fineprint" printer bound to a fineprint-like tool that would do what you expect (collect, merge, rearrange, preprocess... print jobs). Unfortunately, I don't have the time neither the resources to implement such an addon.

Michael.

Revision history for this message
In , M-wege (m-wege) wrote :

Ok, but in this case. I will at least reopen this wish, so that me be somebody else gets attracted to the idea of implementing it.

Revision history for this message
In , Kurt Pfeifle (pfeifle) wrote :

# But this seems rather complicated.

Did you even try it? Did it work?

# The suggested procedure would require me to have the files I printed on
# my computer

Of course... (*)

Fineprint also can't print files if they aren't on the same computer as
Fineprint is.

(*) Oh waaaiiit..... Have you ever tried to open a file in kprinter, which
is residing on a smb:// or fish:// or ftp:// or http:// remote share??

# print the whole file and not only parts of (at least I understood it that)

Correct.

# The suggested procedure would require me to have the files I printed on
# my computer and to print the whole file and not only parts of (at least
# I understood it that).

What you are asking for now is different from what you reported initially.
Your initially reported requirement is perfectly implemented already in
KDEPrint. The example I gave went even further, and explained how you can
do even *more* than you wanted.

What you want *now* is a sort of "Page Layouting and Impositioning Software".
You want to select individual or several pages from various document sources,
and be able to re-arrange them freely as you like.

This is way beyond the scope of KDEPrint. It would be a completely new
application. (I'd very much like to see such an application too, BTW)

I am not sure if it is a good way to leave this wishlist item open at this
place. If you manage to open a separate, prominent wishlist item, I'd vote
for it... ;-)

For the time being, I leave it here....

Revision history for this message
In , M-wege (m-wege) wrote :

## The suggested procedure would require me to have the files I printed on
## my computer

#Of course... (*)

#Fineprint also can't print files if they aren't on the same computer as
#Fineprint is.
What I meant by this was, that I can not use this to print Internetsources. I would have to save them as file, the best thing would be to first create a PDF. And then load it into a printing list.

It seems like that I have not described correctly what I want.
No you are saying this would need a seperate programme. I am not a programmer. But couldn't it work like this: There would be a pseudo-printer. You print your files to this printer one after another. By doing this, you can choose which pages you want to print. This pseuso-printer would keep this list of files until you decide to release it to the real printer. Does this really require a seperate programme. O.k. this may would not allow to arrange the files in advance. But at least the collecting mechanism would work.

If this is something sepate to wish, where would be a good place for that?

Revision history for this message
In , Kurt Pfeifle (pfeifle) wrote :

# What I meant by this was, that I can not use this to print Internetsources.

Sigh...

Look at the PDF attachment. It is clearly printed 2-up, it is clearly an internet source, and it used kprinter to do it. A perfect fulfillment of what you described as your requirement in your first posting.

# I am not a programmer.

I am neiter. I am a documentation writer.

# No you are saying this would need a seperate programme.

Yes.

# But couldn't it work like this: There would be a pseudo-printer.

We could disguise that separate program as a pseudo-printer. (All the pseudo-printers in KDEPrint are/use separate programs.)

The features you described are huge. As I said, I would love to see a thing like this. But the problem is to find a developer who *likes* it too (*). Remember, OSS developers mainly work because they like what they work on. You can switch one onto another project by "ordre de mufti". [(*) or find one with the requested skills who does it for payment...]

# This pseuso-printer would keep this list of files until you decide to
# release it to the real printer.

I am thinking that this would best be implemented as a "PDF impositioning programm". I will see if some of the Scribus and/or kpdf developers might find this an interesting project to work on.

Dont hold your breath on it, though.

# If this is something sepate to wish, where would be a good place for that?

I do not know yet. I have to find out first. (If I had known, I had closed this wishlist item and asked you to go there and propose it again ;-)

Revision history for this message
In , Kurt Pfeifle (pfeifle) wrote :

Created attachment 9179
Printjob by KDEPrint to "Pseudo PDF Printer", using internet resource and 2-up (as required by reporter)

Revision history for this message
In , Kdeprint-bugs (kdeprint-bugs) wrote :

As a developer, I can tell you that it's best implemented as a separate program, because it can be done so (using pseudo-printers, which *are* separate programs, for example the "Print to PDF" simply uses ghostscript to convert PS to PDF) and it wouldn't overload kdeprint code base. AFAIK, Fineprint is also a separate program, it simply integrates well within Windows print system, like a pseudo-printer would do in kdeprint.
However, a Fineprint-like program (BTW, you're not the first one to ask for such a feature) is a mini-project by itself, and I don't have the time neither the resource to work on that.

Michael

Revision history for this message
In , Kurt Pfeifle (pfeifle) wrote :

Mark,

I'm closing this now. What you want to do is already possible.

Use the prefilter-system with the "Multiple Pages Per Sheet Filter", set it up as a separate "printer instance" and you have it available for each job with a simple selection of that printer instance in the drop down list. It can't be made much simpler, I'm afraid...

Revision history for this message
In , M-wege (m-wege) wrote :

Sorry, I do not understand what you mean how this should work. Could you explain this step by step?

Revision history for this message
In , Kurt Pfeifle (pfeifle) wrote :

Not now. No time. See also comment 1, last paragraph. See also http://www.kdedevelopers.org/node/2630

To create a printer instance in KDE, run

  [alt]+[f2]
  "kdesu kcmshell printers"
  click the printer to highlight
  go to the "Instances" tab
  Create a new instance
  give it a name you like
  make all settings as they should be

you'll find the instance in the printers drop-down list of the print dialog. And it will be set up with all the settings and pre-filters you defined.

Printing with these exact settings will just be a matter of selecting this instance. And you can create 2, 5, 100 instances if you like.

Revision history for this message
In , M-wege (m-wege) wrote :

Hi Kurt,
I followed your instructions till

>make all settings as they should be

I could not find any new instance in the printers list. May be this has something to do that I have no actual printer installed and using the PDF-Printer as a starting point.
Are you really sure that it is possible to do the following. Surf around doing some research, send some pages which are collected here and then, also send pdfs and .odt's to the collecting. Then finally go to the list of collected pages. Delete some, rearrange them and then finally print to a PDF-file or a real printer?

Following your instructions I can not see where this is going to happen. (That does not mean that it is impossible, I may missed some detail or you forgot in your instruction because for you it is normal to use.

Revision history for this message
In , Asraniel (asraniel) wrote :

Hello,
i'm developing this as a semester project. We are a team of two and this is the current plan:

install cups-pdf and print to a pdf file (or ps file, you can configure cups-pdf to do one or the other).
Observe the output directory and launch our application when a new pdf arrives.

When kdeprint exists again, it should be trivial to add a virtual printer that directly saves the file in a specified directory and launches our application.
We are probably doing it in pure QT at first.

Revision history for this message
In , M-wege (m-wege) wrote :

That is really cool, great news. So should I remove it from http://techbase.kde.org/index.php?title=Projects/Summer_of_Code/2008/Ideas#KDE-Print
again or would your like to do it as a Summer of Code Project?
Will it be possible to have it ready for KDE4? See http://techbase.kde.org/index.php?title=Schedules/KDE4/4.1_Release_Schedule
Then you could put it in:
http://techbase.kde.org/index.php?title=Schedules/KDE4/4.1_Feature_Plan

If you need any feedback on general conception, not on programing (I do not know anything about that), I am willing to discuss/ read thing and of course test things. I do not have KDE4 running at the moment, but I could install it for testing purposes.

Revision history for this message
In , Asraniel (asraniel) wrote :

Hi,

and as promised, the "beta" version. This is the version i submitted at the end of the semester. You can write bug reports in the bugtracker on the project homepage. The user manual might be interesting, there are quite a few limitations right now (only works with A4 documents for example)

http://code.google.com/p/printruler/

Revision history for this message
In , M-wege (m-wege) wrote :

What is the state of integrating this into KDE and the print dialogue. It would be really a shame, if your work would not be used, because nobody know about it.

Revision history for this message
In , M-wege (m-wege) wrote :

Another reason for directly integrating printerruler in KDE: I have noticed that PDF-Printer in Firefox gives the same names to PDF files, when the page title of a page is similar. So you can't really collect pages from these sources then.

BTW: Some naming suggestions: Print magic, Magic Printer, Page Collector, ...

Revision history for this message
Jonathan Thomas (echidnaman) wrote :

system-config-printer-kde now lives in the KDE Admin software module, so I am moving this bug accordingly.

Changed in system-config-printer-kde:
importance: Undecided → Wishlist
Changed in kdeadmin:
status: Unknown → Confirmed
Changed in kdeadmin:
importance: Unknown → Wishlist
Revision history for this message
In , Jlayt (jlayt) wrote :

KDEPrint is obsolete, unmaintained and will never be revived. Closing all open bugs.

Changed in kdeadmin:
status: Confirmed → Unknown
Revision history for this message
In , M-wege (m-wege) wrote :

Can't this be reassigned to whatever component is responsible for printing in KDE?

Revision history for this message
In , Rivasgilbie121 (rivasgilbie121) wrote :

(In reply to Kurt Pfeifle from comment #1)
> Mark,
>
> thank you for your bug report/wishlist item.
>
> The bug that your reported however, does not apply to KDEPrint. The reason:
>
> --> this functionality has been implemented many years ago already! <--
>
> The bug report will be closed.
>
> To get the 2-up output you want, you should have CUPS installed. I did this
> with the current KDE CVS HEAD version of KDEPrint (but this is the same in
> the last few releases):
>
> 1. start kprinter
> 2. click "Expand" button (lower left)
> 3. select the "Files" tab
> 4. click "Add file" button (the uppermost one on the right side of the
> tab, see also tooltip)
> 5. select as many printable files as you want to put into one printjob
> (these may be PDF, PostScript, ASCII text, images like jpeg, png,
> tiff... -- and these may be mixed into the same job too!)
> 6. order the files as you want them to appear in the final printout (use
> the arrow buttons to the right of the tab)
> 7. select your target printer
> 8. click "Properties..." (upper right of the dialog)
> 9. on the "General" tab, select your 2-up or 4-up settings, on the other
> tabs select whatever applies (NOTE, that some settings do apply to
> some file types, like "scale to 100% of page size" only applies to
> images...)
> 10. print and be happy with KDEPrint ;-)
>
>
> Final note: KDEPrint is just a frontend to the underlying print
> subsystem. As such it works best with CUPS, which is very powerful
> (and KDEPrint really shines with it).
>
> KDEPrint's own functionality are the "Virtual Printers" such as "Print
> to File (PDF)". If you want to use these in a similar way as described
> above, you have to make sure that you have all the required pre-filters
> installed which you can access via "Properties" --> "Filters" tab (see
> the "Requirement: "exec:/...." comments there).
>
> Cheers,
> Kurt Pfeifle

Good comments ! For my two cents , if others is searching for a service to merge PDF files , my family saw a service here <a href="http://www.altomerge.com/" >http://www.altomerge.com/</a>.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.