Wireless Configuration Writes Bad Interfaces File

Bug #24516 reported by Richard Heck on 2005-10-24
8
Affects Status Importance Assigned to Milestone
kdeadmin (Ubuntu)
Medium
Jonathan Riddell

Bug Description

When attempting to configure the wireless interface wlan0, managed by
ndiswrapper, with systemsettings, the interface file that was written ended up
containing the lines:
iface wlan0 inet dhcp
wireless-essid RGHNLW
wireless-key **********
The asterisks were present, as shown, rather than the correct key. As a result,
when I ran 'ifup --verbose wlan0', $IF_WIRELESS_KEY became "**********", and
if-pre-up.d/wireless-tools tried to run "iwconfig wlan0 key **********", thereby
failing to set the key and therefore not associating with the access point. Thus:
root@rghlaptop:/etc/network# ifup --verbose wlan0
Configuring interface wlan0=wlan0 (inet)
run-parts --verbose /etc/network/if-pre-up.d
run-parts: executing /etc/network/if-pre-up.d/wireless-tools
Error for wireless request "Set Encode" (8B2A) :
    invalid argument "if-down.d".
The argument is taken from expansion of "*": if-down-d is the first file in the
directory from which I was running ifup, viz: /etc/network.

Editing /etc/network/interfaces by hand and and replacing the offending line
with a good one corrects the problem. So the issue is what systemsettings writes
to this file.

Luka Renko (lure) wrote :

Confirmed. Working on the fix.

Changed in kde-systemsettings:
status: Unconfirmed → In Progress
Luka Renko (lure) wrote :

Fixed in 3.5.2-0ubuntu4

Changed in kdeadmin:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.