kfilemetadatareader crashed with SIGSEGV in d_func()

Bug #948973 reported by stolman on 2012-03-07
106
This bug affects 11 people
Affects Status Importance Assigned to Milestone
kde4libs (Ubuntu)
Medium
Unassigned

Bug Description

 ll

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: kdelibs-bin 4:4.8.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
ApportVersion: 1.94-0ubuntu2
Architecture: amd64
Date: Wed Mar 7 14:52:09 2012
ExecutablePath: /usr/bin/kfilemetadatareader
InstallationMedia: Kubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120228.1)
ProcCmdline: /usr/bin/kfilemetadatareader file:///home/username/Desktop/home
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
 LANGUAGE=
SegvAnalysis:
 Segfault happened at: 0x7f8e32601381 <_ZNK9KMimeType7commentERK4KUrl+1>: mov 0x10(%rsi),%rsi
 PC (0x7f8e32601381) ok
 source "0x10(%rsi)" (0x00000010) not located in a known VMA region (needed readable region)!
 destination "%rsi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: kde4libs
StacktraceTop:
 KMimeType::comment(KUrl const&) const () from /usr/lib/libkdecore.so.5
 Nepomuk::Utils::formatPropertyValue(Nepomuk::Types::Property const&, Nepomuk::Variant const&, QList<Nepomuk::Resource> const&, QFlags<Nepomuk::Utils::PropertyFormatFlag>) () from /usr/lib/libnepomukutils.so.4
 _start ()
Title: kfilemetadatareader crashed with SIGSEGV in KMimeType::comment()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
XsessionErrors: GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

stolman (stoltin) wrote :

StacktraceTop:
 d_func (this=0x0) at ../../kdecore/services/kmimetype.h:48
 KMimeType::comment (this=0x0, url=...) at ../../kdecore/services/kmimetype.cpp:501
 Nepomuk::Utils::formatPropertyValue (property=..., value=..., resources=<optimized out>, flags=...) at ../../../nepomuk/utils/utils.cpp:141
 KFileMetaDataReaderApplication::readFileAndContextMetaData (this=0x7fff8edb2e60, urls=...) at ../../kio/kfile/kfilemetadatareaderprocess.cpp:187
 KFileMetaDataReaderApplication::readAndSendMetaData (this=0x7fff8edb2e60) at ../../kio/kfile/kfilemetadatareaderprocess.cpp:89

Changed in kde4libs (Ubuntu):
importance: Undecided → Medium
summary: - kfilemetadatareader crashed with SIGSEGV in KMimeType::comment()
+ kfilemetadatareader crashed with SIGSEGV in d_func()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kde4libs (Ubuntu):
status: New → Confirmed
visibility: private → public

Git commit 61e27b31f8f4b10e1378ba700345acecc3b6c9c5 by Jonathan Thomas.
Committed on 02/04/2012 at 00:21.
Pushed by jmthomas into branch 'KDE/4.8'.

KMimeType::mimeType() can return null if the mimetype is not found, so check the pointer before we use it to avoid crashing.

CCMAIL:<email address hidden>

M +2 -1 nepomuk/utils/utils.cpp

http://commits.kde.org/kdelibs/61e27b31f8f4b10e1378ba700345acecc3b6c9c5

diff --git a/nepomuk/utils/utils.cpp b/nepomuk/utils/utils.cpp
index 5dab792..d4c1f28 100644
--- a/nepomuk/utils/utils.cpp
+++ b/nepomuk/utils/utils.cpp
@@ -138,7 +138,8 @@ QString Nepomuk::Utils::formatPropertyValue( const Nepomuk::Types::Property& pro
     }

     else if(property == Vocabulary::NIE::mimeType()) {
- valueString = KMimeType::mimeType(value.toString())->comment();
+ KMimeType::Ptr mimeType = KMimeType::mimeType(value.toString());
+ valueString = (mimeType ? mimeType->comment() : value.toString());
     }

     else {

Changed in kde4libs (Ubuntu):
status: Confirmed → Fix Committed
justin curtis mathews (jmate31) wrote :

occurs when a new file is formed. (i.e. .ogv or .flac or .ogg Video or Audio files) and it tries to index them but they do not follow the format of ogv flac or ogg may also occur with mp3 or odt etc. files. as well occurs for me frequently when I am ripping a CD or a DVD that I own with sound-juicer 3.3.90 or thoggen 0.7.1. also I have noticed that when this happens sometimes thoggen or sound-juicer fails to read the disk and crashes.

My System Specs are:

AMD Athlon II X4 640 3.6GHz
16 GB G.SKILL RAM
750 GB HDD
2 Sony Optiarc DVD+RW (internal) + 1 NEC DVD-R (external) Optical Drive
Sapphire ATI Radeon 5670 EVERGREEN
500W Dual 12V Rail PSU
10/100/1000 Gigabit Ethernet
SB16 Audio and Headset
acer H203H LCD Flat-Panel Display

USB Devices:
HUMMINGBIRD SD/MC etc. Card Reader
Apple Aluminum Keyboard and Apple 4-button Wired Laser Mouse
GPX 2GB Audio Player
iPod Shuffle 2GB
3 port USB-B and 1 Port USB Mini-A Hub

OS: Kubuntu 12.04 precise (development branch)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde4libs - 4:4.8.2-0ubuntu1

---------------
kde4libs (4:4.8.2-0ubuntu1) precise; urgency=low

  [ Rohan Garg ]
  * New upstream release
    - Update symbols for libkparts4 and libkio5

  [ Jonathan Thomas ]
  * Add kubuntu_fix_nepomuk_utils_crash.diff cherry-pick from KDE's 4.8
    branch. (LP: #948973)
 -- Rohan Garg <email address hidden> Fri, 30 Mar 2012 18:44:02 +0530

Changed in kde4libs (Ubuntu):
status: Fix Committed → Fix Released
tags: added: bugpattern-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers