Ubuntu

kbuildsycoca4 abort (Cannot mix incompatible Qt versions)

Reported by Josh Dalziel on 2011-09-12
48
This bug affects 7 people
Affects Status Importance Assigned to Milestone
kde4libs (Ubuntu)
Medium
Unassigned

Bug Description

happened while doing a apt-get upgrade

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: kdelibs-bin 4:4.7.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
Date: Mon Sep 12 10:52:15 2011
ExecutablePath: /usr/bin/kbuildsycoca4
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcCmdline: /usr/bin/kbuildsycoca4 --incremental
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: kde4libs
StacktraceTop:
 __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
 __GI_abort () at abort.c:92
 qt_message_output(QtMsgType, char const*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
 ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
 ?? ()
Title: kbuildsycoca4 crashed with SIGABRT in __GI_raise()
UpgradeStatus: Upgraded to oneiric on 2011-09-12 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Josh Dalziel (josh-dalziel) wrote :

StacktraceTop:
 __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
 __GI_abort () at abort.c:92
 qt_message_output (msgType=<optimized out>, buf=<optimized out>) at global/qglobal.cpp:2320
 ?? () at global/qglobal.cpp:2335 from /tmp/tmprja9ZO/usr/lib/x86_64-linux-gnu/libQtCore.so.4
 ?? ()

Changed in kde4libs (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public
summary: - kbuildsycoca4 crashed with SIGABRT in __GI_raise()
+ kbuildsycoca4 abort (Cannot mix incompatible Qt versions)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kde4libs (Ubuntu):
status: New → Confirmed
Harald Sitter (apachelogger) wrote :

"Expected" misbehavior on upgrades and rather unavoidable as libraries getting changed around will always cause temporary incompatibilities.

Changed in kde4libs (Ubuntu):
status: Confirmed → Won't Fix
Lynne Stevens (jackie40d) wrote :

I do not run KDE and the HPLIP file does not work in Gnome either ! . . And that means I will not up grade if no one wants to fix the error in the HPLIP code that come out with 11.10 and 12.04 plus 12.10 . . And I use Gnome . . Because If I up grade to any of the versions past 11.04 My printer scanner and copier WILL NOT talk to the computer . . And I need them to work as I use them every day like today the printer will be busy making print out of a PDF file to take to a meeting . . Seems the HPLIP file is missing about 700 or more HP Printers ! . . As it stops at HP 1300 and begins again at HP 2000 . . My printer is inbetween those two numbers and I would guess a gob of other people are in the same boat ! . . Temporary ? it started in 11.10 and continued in 12.04 and still is there in 12.10 if the new version is out every 6 months, that is what 1 1/2 years . .
I went through CUPS 1.6 and sure enough MY printer is one of a gob that is not there and I added a report about it months ago . . If the printer is not there it is a mess and guessing which printer to buy . . Naw I will stay here at 11.04 . . I have had 12.10 on this laptop 2 times now and same thing Printer is not there or disconnected . . that is what it says in the printer area

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers