Launching HTTP Cache Cleaner

Bug #60315 reported by DaTa on 2006-09-13
168
This bug affects 21 people
Affects Status Importance Assigned to Milestone
kdelibs
Fix Released
Medium
kde4libs (Ubuntu)
Low
Unassigned
Nominated for Intrepid by Oli
Nominated for Jaunty by Matej Vitasek

Bug Description

I'm using GNOME on dapper, every now and then a "hidden" window with the title "Launching HTTP Cache Cleaner" appears. "hidden" means, that it is only shown in the task bar, and there is no corresponding window. This is annoying. I don't mind that the HTTP Cache Cleaner is launched, but it should run in the background.

Version: (using KDE KDE 3.4.1)
Installed from: FreeBSD Ports
OS: FreeBSD

Every once in a while, a 'HTTP Cache Cleaner' process pops up in my taskbar and makes my cursor bouncy (i.e. triggers the launch feedback as configured in my settings).

I suspect it's Konqueror keeping the cache below the size threshold - I think it would make sense to do this silently though, regardless of launch feedback settings.

I think this behaviour started with KDE 3.4.0.

I found the .desktop file for the cache cleaner service in the meantime and it contains X-KDE-StartupNotify=false as it's supposed to ... yet I get the notifications.

Post-3.4.0 CVS branch as well. FreeBSD, amd64.

Still seeing this on 3.5.2 on gentoo linux

Seeing it on 3.5.3 on FreeBSD. Quite distracting.

> I suspect it's Konqueror keeping the cache below the size threshold

Do not think so. I have cache size in my konqueror set to 1 KB (in reality konqueror have cache about few megabytes with many small files - this is also bug; you may ask why I need so much small cache - this is simple, I need it for correct work with my cache-proxy, this is because of enabling or disabling cache in the browser changes its special headers within packets), and my cursor becomes bouncy and only after about 5-10 minutes becomes normal again (this MUCH more than maximum time in my setting - so this program probably try to start more than one time I think).

I have currently KDE 3.4.2, Debian GNU/Linux.

I can confirm this in KDE 3.5.2

This is visible in GNOME when running KDE applications, as GNOME does not honour "X-KDE-StartupNotify=false". The proper cross-desktop way to do this is with "StartupNotify=False", I believe.

Also, this isn't a Konqueror issue, but a kdelibs issue. Basically, http_cache_cleaner.desktop needs "StartupNotify=False" instead of "X-KDE-StartupNotify=false". Can someone reassign this?

I'm having the same annoyance on edgy, it happens when running KDE applications like amarok. In the desktop file for HTTP Cache Cleaner (/usr/share/services/http_cache_cleaner.desktop) there is a line "X-KDE-StartupNotify=false" which probably avoids that the program appears in the window list in KDE but it doesn't seem to work in Gnome.

Caminomaster (caminomaster) wrote :

I've found that:

http://ubuntuforums.org/showthread.php?t=63119

There's information for that. I think that the matter is that line "X-KDE-StartupNotify=false" sets it for KDE; maybe must be a similar option to Gnome.

Asheesh Laroia (paulproteus) wrote :

I can report that this persists when running amaroK on Feisty (as of April 2, 2007).

Bug is filed in kde.org aswel

seems that /usr/share/services/http_cache_cleaner.desktop is not set correctly

it says

"X-KDE-StartupNotify=false"

gnome doesnt understand this

"StartupNotify=False"

should be the correct way, I've added it and it seems O.K. now

here's the documentation on .desktop files

StartupNotify=false

seems to be the official way

http://standards.freedesktop.org/desktop-entry-spec/latest/ar01s05.html

I've got the same issue with "Launching CvsService" when I start Quanta in Gnome

Christof Krüger (christofkr) wrote :

Does KDE understand the standard or does it need the "X-KDE" prefix? In the former case the fix is trivial. In the latter, would it be possible to have both lines to satisfy both gnome and kde?
I find this bug rather annoying because the cursor also changes to the busy one while the cache cleaner is running. For this time I don't have a precise cursor any more (but this round spinning animated thingy).

Christof Krüger (christofkr) wrote :

Just a note:
The above solution (adding StartupNotify=false) to the .desktop file does not help on GNOME.

Here it is sometimes still worse: when I am using KDE, I see "HTTP Cache Cleaner" appearing in my task list, and a bouncing cursor of an empty document, and this does not stop. Only way to get rid of the HTTP Cache cleaner in the task list, and the bouncing cursor, is to log out :-(

So, there is still no fix for this annoying bug ?

This bug exists now for more than two years, and is part of the "Most hated bugs" list. Can anybody please take a look at this finally? I'm currently again having a bouncing cursor and HTTP Cache Cleaner in my task list which do not go away at all :-(

Anteus (anteus) on 2007-10-25
Changed in kdelibs:
assignee: nobody → anteus92
rgbiernat (info-24prompt) wrote :

Confirmed on Gutsy

Did not yet try the above fix..

I can confirm this in KDE 3.5.8

Andrew (andrewkvalheim) wrote :

I'm also getting this on Gutsy.

Don't know if it's relevant, but the KDE apps I have installed are:
Amarok, Kate, Konversation, Krdc, Qtpfsgui

Shirish Agarwal (shirishag75) wrote :

Got this on Hardy as well but this is alpha 4

naurus (scruyou) wrote :

Installing kcontrol (sudo apt-get install kcontrol) and using it to disable cache in "Internet & Network -> Web Browser -> Cache" has worked for some people.

Daniel LaGesse (dlagesse1992) wrote :

I'm running Gutsy, can also confirm this problem. I'm trying the fix suggested above for adding to the .desktop file.

I haven't seen it again yet, but it doesn't show up all that often anyways.

Ubuntu 8.04 RC with Amarok - still getting this!

TonyGrisier (anthony-grisier) wrote :

Also running 8.04 RC and Amarok with the same problem.

Scott Beamer (angrykeyboarder) wrote :

And it looks like it made it to 8.04 final...

Changed in kdelibs:
assignee: nobody → kubuntu-kde-3.5.9
assignee: kubuntu-kde-3.5.9 → kubuntu-team
Martin Kossick (hacktick) wrote :

Hum, when will this problem be solved?

Isaac Henry (isaachenry) wrote :

I also see a similar "hidden" window (as in only a task bar entry, no actual window when clicked) for "Launching knotify" (or something very similar).

Still seeing both of these in a fully updated 8.04. I use Gnome but run Konsole and Konqueror regularly.

I will try out Vijnana's suggestion. Any chance this will see some action? Its been open for almost a year and a half, has been several times confirmed, and has a proposed solution. This detracts significantly from the generally polished feel of Ubuntu, and looks like it probably has a simple solution.

Spacedog (spacedog-gubuwire) wrote :

got this in hardy 8.04, ubuntu with kde_desktop package installed,

I'm using gnome running ktorrent

superandy (superandy) wrote :

I have this with amarok installed on Hardy x64 fully updated. This is the only KDE app I ever have running. I have tried the fix, and will report back if it seems to work.

Same bug on KDE 4.0.4

This is a problem for me as well but on Gentoo Linux (KDE 3.5.9 - kde-base/kdelibs-3.5.9-r4).

I also find the launch feedback and entry in the task list quite annoying and distracting.

I'm getting this problem with KDE 4.1.0. Oddly, it had never happened to me before, though I've been using KDE since version 1.

Martin Kossick (hacktick) wrote :

Hey, could we fix this one until the 8.10 release? If I can help by doing something, please let me know!

dreikin (dreikin) wrote :

Also happening on Intrepid (fresh install) with Amarok. A visible bug that's made it through three releases sure deserves more importance than 'undecided', no?

Martin Kossick (hacktick) wrote :

Hum, I think the importance of this bug is low.

Anyway, this bug was reported more than 2 years ago and has a bunch of subscribers...

Jeffery Davis (heavensblade23) wrote :

I'm also seeing this on Intrepid. Not a huge deal, but still annoying.

Changed in kdelibs:
assignee: kubuntu-bugs → nobody
importance: Undecided → Low
Sidarth Dasari (sirsid) wrote :

I can confirm intrepid

dah bien-hwa (dahbien-hwa) wrote :

I can confirm it for intrepid, running a few KDE apps.

Vijnana's suggested solution with "StartupNotify=false" in http_cache_cleaner.desktop did not work for me.

I can't try naurus's suggestion because the package kcontrol seems not to exist in intrepid repositories.

I am also having the same problem in 8.10, and have tried the fixes suggested. Although it is not a major problem, I hope this bug is solved to stop annoyance.

dah bien-hwa (dahbien-hwa) wrote :

I now also frequently see the "Launching KNotify" and another hidden "window" saying something similar to "Starting graphical UI Server" (only a rough translation, my installation is german, but from what I can say from googling I guess this is the "kio_uiserver" application).

munzli (munzli) wrote :

well i found a way to resolve this... and it seems to be working
http://www.munz.li/?p=52

Martin Kossick (hacktick) wrote :

munzli: I created a ~/.kde/share/config/klaunchrc like yours,
but the window still appears in the bar.

munzli (munzli) wrote :

funny thing is that the file is created by the systemsettings window and everytime i reopen it the checkbox is still checked eventhough the TaskbarButton=false is still set.

and from time to time the windows still appears (but never as much as it used to)... still checking to see how this can be permanently resolved

I'm getting this problem with KDE 4.1.82 (KDE 4.1.82 (KDE 4.2 >= 20081204)) opensuse unstable packages in 11.0

Wayno (ichabod) wrote :

It is an annoyance for sure. I've tried the solution above, and it does not work. Ubuntu 8.10 (64 bit) -- all updates.

Wayno

Still exists on Fedora rawhide kdelibs-4.1.85-6.fc11.i386.
Ridiculous, annoying, and plain poor UI practice.

David Reagan (jerrac) wrote :

This bug shows up for me as well. I am using 8.10. The only KDE app I have install is amarok. Why do they even need the cache cleaner to run for that? Does streaming actually cache that much data?

I dunno it is frustrating -- I am gun shy of kde 4.1 I should see how
hard it would be to deprecate to 3.5.

Wayno

----------------

David Reagan wrote:
> This bug shows up for me as well. I am using 8.10. The only KDE app I
> have install is amarok. Why do they even need the cache cleaner to run
> for that? Does streaming actually cache that much data?
>
>

I agree, this is annoying. I'm using amarok on ubuntu 8.10.

I can confirm this bug on Intrepid while running KDE (not Gnome!). What's even more annoying is that I cannot find the item in the System Monitor to kill it.

Wayno (ichabod) wrote :

yeah I've tried to track it down - seems like they could fix this....

Wayno

--------

John Bradley Bulsterbaum wrote:
> I can confirm this bug on Intrepid while running KDE (not Gnome!).
> What's even more annoying is that I cannot find the item in the System
> Monitor to kill it.
>
>

Changed in kdelibs:
status: Confirmed → Triaged
Changed in kdelibs:
status: Unknown → Confirmed

*** Bug 187314 has been marked as a duplicate of this bug. ***

skajoeska (punkiscrunk) wrote :

This problem still persists for me in Jaunty 9.04. Amarok is the only KDE program I have. The package kcontrol no longer seems to be available. It tells me that it is obsolete and install kdelibs4c2a and kdebase-workspace-bin instead. I don't want to install 66 Mb of extra stuff just to fix a simple problem.

jfulton3 (jfulton3) wrote :

It is still persistent for me in Jaunty, after upgrading from Intrepid. I have tried all the above fixes with no luck. I also tried devilspie to create a rule to close the notification but that doesn't work either.

copacetickid (copacetickid) wrote :

I just installed amarok 2.1 on Jaunty by adding

http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu

to sources.list, and started experiencing this bug. I know it's in backports; just hoping it helps someone track this down. Along with amarok, it also upgraded to the latest KDE4 binaries.

Habib Tamala (drpyro) wrote :

Encountering the same problem here with Ubuntu jaunty 9.04 running gnome, all that began when i installed amarok and since, that annoying thing appear on my task bar and holds the mouse on busy status for a 5-10 seconds... tried out mentioned fixes desperately...
someone give help please..

pitboss (pitboss2000) wrote :

same as Habib Tamala.

Also seen in 4.2.4 (arch linux, kdelibs 4.2.4-4)
I got rid of the task bar entry by restarting plasma. The bouncing cursor stopped while typing this, 5-10 minutes after it started. KDE applications running at the time it occured: amarok, kopete and konsole + various plasmoids. I've been using kde since for ever, but this is the first time I've seen this bug.

Just wondering and don't know if that might be related, but why exactly is that desktop file in the applications directory even though it is a service type and why is it not using StartupNotify=false?

Seems like one would not want it in any menu (+ it is a service type) and no startup notification in any desktop, right? So why not move it to the serivces directory and remove the X-KDE- from the StartupNotify entry?

Woops, my fault, was looking at the wrong ls :) ... it is already in the services dir.

But I still think it should be using the regular StartupNotify.

I have the same problem on Ubuntu 9.04. I'ts a really annoying bug.

John Doe (webmastir) wrote :

Yup. same annoying problem in hardy 32bit with Ktorrent running in gnome

When I play games the bouncing cursor pops up from time to time and I'll see 'HTTP Cache Cleaner' on the taskbar when I exit. Could this be made to run in a less obtrusive way?

Phil Pemberton (philpem) wrote :

Same thing in 9.04 x64, Amarok 2.0.2.

Terry Zhou (zhouxc) wrote :

Same in 910 x32, Amarok 2.2.0

Tremaine Lea (tremaine) wrote :

Problem persists in Ubuntu Karmic x86_64

Jonathan Thomas (echidnaman) wrote :

Hi there!

Thanks for reporting this bug! Your bug seems to be a problem with the KDE program itself, and not with our KDE packages. But don't worry! This issue is being tracked by the KDE developers at: http://bugs.kde.org/show_bug.cgi?id=108809.
Once fixed in KDE, it will be included in Kubuntu once the KDE version the fix is in in reaches Kubuntu.

Thanks!

Changed in kde4libs (Ubuntu):
status: Triaged → Invalid
Xan Steel (xansteel) wrote :

Hello

I'm currently running Ubuntu 9.10, with current programs running anywhere between 90 to 100% of the time. Firefox 3.5.5, XChat 2.8.X, Choqok, Evolution Email, and Empathy. and this Launching HTTP Cache Cleaner, appears about once an hour. I use this laptop, for these needs as that's about all it's capable of doing.

If you folks could figure out whats causing it, and fix it, I would be very happy.

Thanks.

I have installed Kubuntu 9.04 and upgraded it to 9.10. I have never seen this annoying http-cache cleaner pop-up on KDE.

Now I switched to gnome (and use it with all my KDE applications) and this is popping once in a hour.

FrancesKo (francesko) wrote :

I have the same problem (Ubuntu 9.10 + Akregator, Kate, Krename, Kompare)

In my case this behavior began when I upgraded kdelibs5-plugins from 4.3 to 4.4, the strange thing is that this never happened to me before. As a side note, I use xfce in this computer, and all those hidden windows appear when I browse web pages in konqueror with the cache enabled.

Disabling TaskbarButton in the klaunchrc (as suggested in some blogs) does not work, and changing X-KDE-StartupNotify to StartupNotify in the services file didn't help either.

Besides that, the cache cleaner is not working, as it starts to grow well beyond the configured limit, even if I press the 'Clear Cache' button in konqueror's Preferences.

But if I start /usr/lib/kde4/libexec/kio_http_cache_cleaner & as a background process in a terminal, everything works nicelly, the cache works (without growing too much beyond its limit), and those annoying Launch notifications doesn't appear anymore...

So I guess the problem must be that konqueror or kio_http (I don't know) is not starting correctly the kio_http_cache_cleaner daemon. I've also tried making a wrapper for this application and it's ONLY run when the 'Clear Cache' button is pressed and with the '--clear-all' parameter.

I hope this helps in the understanding of the bug.

alopex (alopex) wrote :

Still persistent in Ubuntu 10.04 Lucid Lynx using Amarok 2.3.0. and KDE library in Version 4.4.2

henry (hzmisc) wrote :

Never had that issue before, but since the distro-upgrade to Meerkat two days ago, Konqueror launches dozens(!) of these windows whenever I open a new tab! And it takes 10-20 sec. to then load that window's content and for the task bar notifications to disappear.

Something has changed considerably here.

Any idea what?

henry (hzmisc) wrote :

In fact, even clicking on a single link just opened about 30 of those tasks... only they don't even show up in the ps-list?

Changed in kdelibs:
importance: Unknown → Medium

Removed my votes for this bug as I quit using KDE a while ago due to its bloat.

Can no longer reproduce on KDE 4.6.

Changed in kdelibs:
status: Confirmed → Unknown

This should already be resolved. Feel free to reopen if any of you see this on more recent version of KDE, v4.10 or higher.

Changed in kdelibs:
status: Unknown → Fix Released

(In reply to comment #24)
> This should already be resolved. Feel free to reopen if any of you see this
> on more recent version of KDE, v4.10 or higher.

Debian Testing
KDE 4.11.3
Qt 4.8.6

HTTP Cache Cleaner showed up as a taskbar icon I also got feedback it lasted about 5 minutes and then vanished, this is the first time I've seen it since using KDE 4.x.

Same here, kde frameworks 4.12.3, plasma workspaces 4.11.7, but it has been going on for a while now.

Reopening based on recent comments.

Changed in kdelibs:
status: Fix Released → Confirmed

I have it and I am running KDE 4.14.2

I personally have never been able to reproduce this problem.

Can anyone of you search for a file called "http_cache_cleaner.desktop" on your system and make sure if it has an entry called "X-KDE-StartupNotify = false"? If it does, can you then change that to say "StartupNotify = false" and see if the problem goes away?

I can see why X-KDE-StartupNotify will not work on non-KDE desktop environments, but a bunch of you are reporting that you are seeing this issue on a KDE desktop environment and that does not make any sense.

(In reply to Dawit Alemayehu from comment #29)
> Can anyone of you search for a file called "http_cache_cleaner.desktop" on
> your system and make sure if it has an entry called "X-KDE-StartupNotify =
> false"? If it does, can you then change that to say "StartupNotify = false"
> and see if the problem goes away?

I has having a bisect session yesterday so was able to test this at the same time. Prior to changing the entry, I was again seeing HTTP Cache Cleaner pop up in the task bar, afterwards, none of that.

Qt-4.8.6, KDE-Workspaces-4.11.17/4.14.3/4.14.6/KDE-Applications-14.12.3

Git commit a327b47c16e2a8167e90864aae11240b94dc3f05 by Dawit Alemayehu.
Committed on 23/03/2015 at 12:57.
Pushed by adawit into branch 'master'.

Renamed X-KDE-StartupNotify -> StartupNotify

M +1 -1 src/ioslaves/http/http_cache_cleaner.desktop

http://commits.kde.org/kio/a327b47c16e2a8167e90864aae11240b94dc3f05

Created attachment 91801
fix launch feedback - backport to kdelibs-4.14.6

How do you think about bringing the same patch to kdelibs-4.14?

Git commit f1796e97e5635fcb93a0bfc600b9da6ecce914a5 by Rex Dieter.
Committed on 30/03/2015 at 15:49.
Pushed by rdieter into branch 'KDE/4.14'.

Renamed X-KDE-StartupNotify -> StartupNotify
FIXED-IN: 4.14.7

M +1 -1 kioslave/http/http_cache_cleaner.desktop

http://commits.kde.org/kdelibs/f1796e97e5635fcb93a0bfc600b9da6ecce914a5

Changed in kdelibs:
status: Confirmed → Fix Released

(In reply to Dawit Alemayehu from comment #31)
> Renamed X-KDE-StartupNotify -> StartupNotify
> http://commits.kde.org/kio/a327b47c16e2a8167e90864aae11240b94dc3f05

This fix don't work for me. 'HTTP Cache Cleaner' process is still popping up from time to time.
KDE 4.14.2 (with Patch from comment #31 applied) on Debian 8.0 Jessie

My setting is correct yet I spent 10 minutes waiting for that to quit spinning in my task bar this AM. Could this have anything to do with delaying D-Bus starting?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.