kde debugging enabled by default

Bug #540944 reported by Jonathan Riddell
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kde4libs (Debian)
Fix Released
Medium
kde4libs (Ubuntu)
High
Unassigned
Lucid
High
Unassigned

Bug Description

Open up kdebugdialogue on a new install and lots of items are ticked. debugging should be disabled by default

Jonathan Riddell (jr)
Changed in kde4libs (Ubuntu):
milestone: none → ubuntu-10.04-beta-2
Revision history for this message
Scott Kitterman (kitterman) wrote :
Revision history for this message
Harald Sitter (apachelogger) wrote :

[12:33:03] <ScottK> apachelogger_: I'm curious for your opinion on reverting http://websvn.kde.org/?view=revision&revision=1025437 - It seems responsible for a lot of .Xsessions-errors spamming.
[12:51:26] <ScottK> Riddell: ^^^ same question for you?
[12:58:06] <Riddell> ScottK: if that's the cause of bug 540944 I'm all for it
[12:58:07] <ubottu> Launchpad bug 540944 in kde4libs "kde debugging enabled by default" [Undecided,New] https://launchpad.net/bugs/540944
[12:58:19] <Riddell> ScottK: worth asking dfaure what his intention was though
[12:58:25] <apachelogger_> yeah
[12:58:29] <apachelogger_> also
[12:58:40] <apachelogger_> we can regulate debuggingness via one config file
[12:58:52] <apachelogger_> that then can be changed on a per-user basis via kdebugdialog
[12:59:16] <apachelogger_> that would be what we had before, I think that was archived via some cmake option though
[12:59:21] <apachelogger_> or a patch to kdebase-runtime
[12:59:24] -*- apachelogger_ cant really remember ^^
[12:59:53] <apachelogger_> ScottK: debian sure would know since they made it not do debug spam
[13:00:32] <ScottK> apachelogger_: Debian has this problem now too. I found that commit from their IRC discussions.
[13:00:54] <apachelogger_> ScottK: well, I would go talk to dfaure about it
[13:01:03] <ScottK> Riddell: MoDaX already poked dfaure, so I'll ask him to let us know what he finds out.
[13:01:05] <ScottK> apachelogger_: ^^
[13:01:15] <apachelogger_> but from where I stand we simply need to drop a config in either /etc or kubuntu-default-settings
[13:02:31] <Riddell> 08_add_debian_build_type.diff in kde4libs is ment to turn off debugging by default
[13:03:26] <apachelogger_> Riddell: that is what dfaure worked around with that commit :)
[13:03:56] <ScottK> Riddell: You can see the discussion about 3 hours ago on #debian-qt-kde (I assume you have it in your backscroll)

Revision history for this message
Scott Kitterman (kitterman) wrote :

The linked KDE bug references commits intended to clean this up.

Changed in kde4libs (Ubuntu Lucid):
importance: Undecided → High
status: New → Confirmed
Changed in kde4libs (Debian):
status: Unknown → Fix Released
Changed in kde4libs (Ubuntu Lucid):
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde4libs - 4:4.4.1-0ubuntu3

---------------
kde4libs (4:4.4.1-0ubuntu3) lucid; urgency=low

  [ Jonathan Thomas ]
  * Add kubuntu_72_kpixmapcache_discard_fix.diff to fix various crashes while
    toggling compositing or changing Plasma themes (LP: #321281)
    - Can be dropped in KDE 4.4.2
  * Add kubuntu_73_silence_kdebug.diff to fix applications being verbose when
    KDebug isn't enabled (LP: #540944)
    - Can be dropped in KDE 4.4.2

  [ Scott Kitterman ]
  * Manually remove mimetypes/kde.xml.podir that somehow crept into the
    diff.gz
 -- Scott Kitterman <email address hidden> Thu, 25 Mar 2010 14:21:27 -0400

Changed in kde4libs (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in kde4libs (Debian):
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.