kopete does not connect through proxy

Bug #47429 reported by Jacob Popov on 2006-05-30
44
This bug affects 4 people
Affects Status Importance Assigned to Milestone
KDE Network
Fix Released
Wishlist
kde4libs (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kopete

kopete does not connect through proxy. which is more, it does not recognize kde's global proxy server settings

Abhinay Mukunthan (lexxonnet) wrote :

Same here. I believe this is a known problem as far as kopete goes, and the devs aren't going to fix it till KDE4 comes out. I do wish I could get it working though!

Tony (tonyric) wrote :

I have the exact same problem on edgy.

Jeff Anderson (jander99) wrote :

Has this issue been fixed with KDE4? If so, can this bug be closed?

Daniel T Chen (crimsun) on 2008-12-21
Changed in kdenetwork:
status: New → Incomplete
Javier Jardón (jjardon) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in kdenetwork:
status: Incomplete → Invalid
Tony (tonyric) wrote :

What information is required? I think the description is accurate. There is no way to configure kopete to connect through a network proxy, except in the main KDE configuration. Kopete does not honor the KDE proxy settings, nor will it honor environment variables for http_proxy whether specified in a users login profile (.profile/.bash_profile) or if manually exported and kopete launched from a command line.

NOTE: I can only confirm this in 3.5.x as I do not use KDE4.

Tony (tonyric) wrote :

What information is required? I think the description is accurate. There is no way to configure kopete to connect through a network proxy, except in the main KDE configuration. Kopete does not honor the KDE proxy settings, nor will it honor environment variables for http_proxy whether specified in a users login profile (.profile/.bash_profile) or if manually exported and kopete launched from a command line.

NOTE: I can only confirm this in 3.5.x as I do not use KDE4.

Changed in kdenetwork:
status: Invalid → New
Changed in kdenetwork:
status: Unknown → Confirmed
Terrax (tball-es) wrote :

I can confirm, proxysettings is not an options in kde 4.2 final in kopete.
Kopete should use the settings from kde kontrol panel, but it doesn't.

Richard Johnson (nixternal) wrote :

Confirming due to upstream. Can't believe this issue is almost 5 years old already. I don't use Kopete so I don't know if this is fixed or not, can anyone comment?

Changed in kdenetwork:
assignee: nobody → nixternal
status: New → Confirmed

No, this is NOT fixed.

--- On Sat, 2/21/09, Richard Johnson <email address hidden> wrote:

From: Richard Johnson <email address hidden>
Subject: [Bug 47429] Re: kopete does not connect through proxy
To: <email address hidden>
Date: Saturday, February 21, 2009, 2:54 PM

Confirming due to upstream. Can't believe this issue is almost 5 years
old already. I don't use Kopete so I don't know if this is fixed or not,
can anyone comment?

** Changed in: kdenetwork (Ubuntu)
     Assignee: (unassigned) => Richard Johnson (nixternal)
       Status: New => Confirmed

--
kopete does not connect through proxy
https://bugs.launchpad.net/bugs/47429
You received this bug notification because you are a direct subscriber
of the bug.

biddster (luke-biddell) wrote :

Totally and utterly not working. Trying to use Kubuntu at work behind a proxy and Kopete will NOT connect. This has got to be fixed after 5 years, very disappointing.

Happy to help test packages/fixes, hopefully so that this could possibly make 9.04?

Pidgin here I come :-(

capi /. (barraponto) on 2009-05-03
tags: added: kopete
bigbrovar (bigbrovar) wrote :

I can confirm here too that kopete does not work behind network proxy.. on kde 4.2 (kubuntu 9.04) or kde 4.3 .. it does not obey the kde systemwide proxy settings

Yevgen Antimirov (turist) wrote :

I tried new kde 4.3 and could not believe that this bug is still not fixed. Is it purely kopete's problem or kde's?

tonyric (tony-ournuthut) wrote :

I am not shocked as this problem has existed for over 3 years.

Hugo Palma (hpalma) wrote :

This bug is created on kde here (https://bugs.kde.org/show_bug.cgi?id=186872)
Please vote for its resolution.

Yevgen Antimirov (turist) wrote :

Added my maximum 20 votes there.

Harald Sitter (apachelogger) wrote :

Importance needs to be re-evaluated.

affects: kdenetwork (Ubuntu) → kde4libs (Ubuntu)
Changed in kde4libs (Ubuntu):
assignee: Richard Johnson (nixternal) → nobody
importance: Medium → Undecided
tags: removed: kopete
Jonathan Thomas (echidnaman) wrote :

Hi there!

Thanks for reporting this bug! Your bug seems to be a problem with the KDE program itself, and not with our KDE packages. But don't worry! This issue is being tracked by the KDE developers at: http://bugs.kde.org/show_bug.cgi?id=74832
Once fixed in KDE, it will be included in Kubuntu once the KDE version the fix is in in reaches Kubuntu.

Thanks!

Changed in kde4libs (Ubuntu):
status: Confirmed → Invalid
Ravi (ra-ravi-rav-gmail) wrote :

I am also facing the problem. Anyone hearing me!

Changed in kdenetwork:
status: Confirmed → Fix Released
Changed in kdenetwork:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.