KDE 4 Mouse Theme is reset to Oxygen on reboot

Bug #305201 reported by Nick Bridgwater on 2008-12-04
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
kde4libs (Ubuntu)
Low
Harald Sitter

Bug Description

Kubuntu 8.10 installed via Wubi, all updates applied.

Changed Mouse Theme from Oxygen White to KDE Classic. Cursor image changed OK.
Rebooted and mouse pointers were back to those in Oxygen White.
System settings still shows KDE Classic but cursor images are Oxygen White.

Maybe it is somehow related to bug https://bugs.launchpad.net/ubuntu/+source/kdebase-workspace/+bug/288502 "KDE 4 doesn't respect X11 cursor themes"

Changed in kdebase-kde4:
status: New → Confirmed
Andreas Berger (andi-berger) wrote :

The bug is still present in Kubuntu 9.04 Beta, and one more detail, i don't know if it's important: Although the cursor image changes OK before rebooting (as described), Dolphin File Manager keeps using the Oxygen Cursor theme (also before rebooting). This does not happen with the Redglass theme.

Terence Simpson (tsimpson) wrote :

Does this still happen in KDE 4.2 or 4.3?

affects: kdebase-kde4 (Ubuntu) → kde4libs (Ubuntu)
Changed in kde4libs (Ubuntu):
status: Confirmed → Incomplete
Nick Bridgwater (leamphil) wrote :

Bug still there in KDE 4.2.2

Changed in kde4libs (Ubuntu):
status: Incomplete → New
importance: Undecided → Low
Jonathan Thomas (echidnaman) wrote :

Would these be upgrades from Hardy + KDE4? Could be related to bug 324907/bug 327236 if there's an old ~/.kde4 directory lying around.

Changed in kde4libs (Ubuntu):
status: New → Incomplete
Nick Bridgwater (leamphil) wrote :

Just checked & no ~/.kde4 directory found.

Jonathan Thomas (echidnaman) wrote :

Hmm. Must be something else then.

Changed in kde4libs (Ubuntu):
status: Incomplete → New
Jonathan Thomas (echidnaman) wrote :

Is this still an issue in Kubuntu 9.10?

Changed in kde4libs (Ubuntu):
status: New → Incomplete
Nick Bridgwater (leamphil) wrote :

Yes - it still happens on Kubuntu 9.10

Problem is still there on Kubuntu 9.10

Sam Rog (samrog131) wrote :

Kubuntu Karmic Koala (9.10)
Qt: 4.5.2
KDE: 4.3.2 (KDE 4.3.2)

and

Kubuntu Lucid Lynx (10.04) Alpha 1
Qt: 4.6.0
KDE Development Platform: 4.3.85 (KDE 4.3.85 (KDE 4.4 Beta2))

Both have this bug.

A workaround is to rename (disable) the /usr/share/icons/default/index.theme. Then it is possible
to use the KDE Classic cursor theme. KDE Classic is then the default theme.

Also the Bluecurve icon theme is working. Bug - https://bugs.launchpad.net/ubuntu/+source/kdebase-workspace/+bug/288502

Dhaval Patel (dhuv) wrote :

I am using KDE 4.4 Beta 2 in Kubuntu 9.10 and the problem is still there. Every time I login (reboot) I have to go and select a different cursor theme, hit Apply and change to back to classic and hit Apply again.

a/o 2010-01-28, still a problem. If you change(mv) /etc/X11/cursors/oxy-white.theme to /etx/X11/cursors/oxy-white.theme.disable (or similar), the change will stick without being too intrusive as the oxy-white cursors won't be found.

Changed in kde4libs (Ubuntu):
assignee: nobody → Harald Sitter (apachelogger)
Changed in kde4libs (Ubuntu):
status: Incomplete → In Progress
Changed in kde4libs (Ubuntu):
status: In Progress → Invalid
chris (ign-christian) wrote :

I think this bug is different from bug #288502 since this bug reported against default cursor theme that is changed to Oxygen White after system reboot.

Perhaps the solution is adding index.theme in every cursor theme in /usr/share/icons/...

I had succeeded doing that (cursor theme not rechange to Oxygen White after rebooting) following these instructions:
http://www.kubuntuforums.net/showthread.php?49062-Change-system-default-X11-cursor-theme

chris (ign-christian) wrote :

Sorry I forgot to mention that this behavior still happen on latest Kubuntu 12.04.3 32bit (fresh install)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers