Dolphin can't open SMB folders whose name contains an accent

Bug #249073 reported by François Tissandier on 2008-07-16
16
Affects Status Importance Assigned to Milestone
KDE Base
Fix Released
Medium
kde4libs (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: dolphin

Ubuntu Hardy, KDE 4.1 RC1, Dolphin 1.00.99.

SMB folders containing a character with an accent (like the french é or à or è) can't be opened using Dolphin. They don't even appear as folder, but as unknown files. Local folders with an accent are working fine (even on NTFS partitions). So apparently, it's specific to SMB shares.

Jonathan Thomas (echidnaman) wrote :

Is this also an issue with the final 4.1 release, with Dolphin 1.1?

Changed in dolphin:
status: New → Incomplete
François Tissandier (baloo) wrote :

Yes Jonathan, still an issue. Using Hardy, Dolphin 1.1, on KDE 4.1.00

Jonathan Thomas (echidnaman) wrote :

Ok, thanks. Somebody needs to forward this upstream to bugs.kde.org.

Changed in kdebase:
status: Incomplete → New
Andreas Moog (ampelbein) wrote :

This is the bugs.kde.org Bugtracker for this bug.

Changed in kdebase:
status: New → Unknown
Changed in dolphin:
status: New → Confirmed
Changed in kdebase:
status: Unknown → New
François Tissandier (baloo) wrote :

Done: http://bugs.kde.org/show_bug.cgi?id=168481
But not reviewed apparently.

Jonathan Thomas (echidnaman) wrote :

Btw, dolphin is moving in to kdebase from Intrepid onward, so kdebase is the correct package for this bug. ;-)

Changed in kdebase:
importance: Undecided → Low
Changed in kdebase:
status: Confirmed → Triaged
Diego Collaziol (dcollaziol) wrote :

I can confirm this bug using kubuntu Intrepid, kde 4.1.2 and dolphin 1.1.
:o)

Changed in kdebase:
status: New → Invalid
Jonathan Thomas (echidnaman) wrote :

According to upstream this is a bug with the samba kio slave. Marking as affecting kde4libs.

Changed in kdebase:
status: Invalid → Unknown
Changed in kdebase:
status: Unknown → In Progress
Changed in kdebase:
status: In Progress → Fix Released
Jonathan Thomas (echidnaman) wrote :

This was fixed in KDE 4.2.

Changed in kde4libs:
status: Triaged → Fix Released
Changed in kdebase:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.