package kdelibs5-plugins (not installed) failed to install/upgrade: trying to overwrite '/usr/bin/ktelnetservice', which is also in package kdelibs4c2a 4:3.5.10.dfsg.1-3ubuntu2.10.04.1

Bug #1100622 reported by Julian Coetzee on 2013-01-17
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Kubuntu PPA
Undecided
Unassigned
kde4libs (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu Version 12.04 LTS.

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: kdelibs5-plugins (not installed)
ProcVersionSignature: Ubuntu 3.5.0-21.32~precise1-generic 3.5.7.1
Uname: Linux 3.5.0-21-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
Date: Sun Jan 13 08:50:09 2013
ErrorMessage: trying to overwrite '/usr/bin/ktelnetservice', which is also in package kdelibs4c2a 4:3.5.10.dfsg.1-3ubuntu2.10.04.1
InstallationMedia: Ubuntu-Server 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120817.3)
MarkForUpload: True
SourcePackage: kde4libs
Title: package kdelibs5-plugins (not installed) failed to install/upgrade: trying to overwrite '/usr/bin/ktelnetservice', which is also in package kdelibs4c2a 4:3.5.10.dfsg.1-3ubuntu2.10.04.1
UpgradeStatus: No upgrade log present (probably fresh install)

Julian Coetzee (juliancarl777) wrote :
Gabriel Jacobo (gabomdq) wrote :

I'm seeing the same problem, the only way to pull through the apt-get upgrade is with -o Dpkg::Options::="--force-overwrite", though this is not recommendable.

Martin Kohn (mtk001) wrote :

I also get this issue after the latest kde upgrade to 4.10 on 6th Feb 2013

ruedihofer (ruedihofer) wrote :

I also have the problem while installing 4.10.

hofer@rudix:~/digikam$ lsb_release -a
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal

hofer@rudix:~/digikam$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  kdelibs5-plugins
The following packages will be upgraded:
  kdelibs5-plugins
1 upgraded, 0 newly installed, 0 to remove and 84 not upgraded.
222 not fully installed or removed.
Need to get 0 B/969 kB of archives.
After this operation, 8,192 B of additional disk space will be used.
Do you want to continue [Y/n]?
(Reading database ... 292390 files and directories currently installed.)
Preparing to replace kdelibs5-plugins 4:4.9.5-0ubuntu0.1~ubuntu12.10~ppa3 (using .../kdelibs5-plugins_4%3a4.10.0-0ubuntu1~ubuntu12.10~ppa1_amd64.deb) ...
Unpacking replacement kdelibs5-plugins ...
dpkg: error processing /var/cache/apt/archives/kdelibs5-plugins_4%3a4.10.0-0ubuntu1~ubuntu12.10~ppa1_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/ktelnetservice', which is also in package kdelibs4c2a 4:3.5.10.dfsg.1-5ubuntu2
Errors were encountered while processing:
 /var/cache/apt/archives/kdelibs5-plugins_4%3a4.10.0-0ubuntu1~ubuntu12.10~ppa1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
hofer@rudix:~/digikam$

Philip Muškovac (yofel) on 2013-02-08
Changed in kubuntu-ppa:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde4libs - 4:4.10.0-0ubuntu2

---------------
kde4libs (4:4.10.0-0ubuntu2) raring; urgency=low

  * kdelibs5-plugins breaks/replaces kdelibs4c2a which is obsolete.
    Fixes overwrite conflict for /usr/bin/ktelnetservice
    (LP: #1100622)
 -- Philip Muskovac <email address hidden> Fri, 08 Feb 2013 00:34:08 +0100

Changed in kde4libs (Ubuntu):
status: New → Fix Released
robegue (r087r70) wrote :

I cannot upgrade since ksensors and ktranslator depends on kdelibs4c2a. I use them on daily basis...

$ sudo apt-get install kdelibs-bin
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  kdelibs5-data kdelibs5-dev kdelibs5-plugins kdoctools libkcmutils4 libkde3support4 libkdeclarative5 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4 libkhtml5
  libkidletime4 libkimproxy4 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4 libknewstuff2-4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4 libkprintutils4 libkpty4 libkrosscore4 libkrossui4
  libktexteditor4 libkunitconversion4 libkutils4 libnepomuk4 libnepomukquery4a libnepomukutils4 libplasma3 libsolid4 libthreadweaver4
Suggested packages:
  hspell media-player-info
Recommended packages:
  libqt4-opengl-dev
The following packages will be REMOVED:
  kdelibs4c2a ksensors ktranslator
The following packages will be upgraded:
  kdelibs-bin kdelibs5-data kdelibs5-dev kdelibs5-plugins kdoctools libkcmutils4 libkde3support4 libkdeclarative5 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4 libkhtml5
  libkidletime4 libkimproxy4 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4 libknewstuff2-4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4 libkprintutils4 libkpty4 libkrosscore4 libkrossui4
  libktexteditor4 libkunitconversion4 libkutils4 libnepomuk4 libnepomukquery4a libnepomukutils4 libplasma3 libsolid4 libthreadweaver4
40 upgraded, 0 newly installed, 3 to remove and 0 not upgraded.
Need to get 16.5 MB of archives.
After this operation, 33.9 MB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.

Martin Schläffer (mschlaeffer) wrote :

I have the same problem with kcpuload and knetload. I really like those old KDE 3 apps which are (unfortunately) still much better than the newer plasma widgets.

I'm running quantal and currently have kdelibs5-plugins version 4:4.10.0-0ubuntu2~ubuntu12.10~ppa1 and the lucid versions of kcpuload, knetload and kdelibs4c2a installed. Since kdelibs5-plugins breaks kdelibs4c2a I have a conflict:

$ sudo apt-get dist-upgrade -V
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 kdelibs5-plugins : Breaks: kdelibs4c2a but 4:3.5.10.dfsg.1-3ubuntu2.10.04.1 is installed
E: Unmet dependencies. Try using -f.

$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
  kcpuload kdelibs4c2a knetload
0 upgraded, 0 newly installed, 3 to remove and 1 not upgraded.
1 not fully installed or removed.
After this operation, 35.8 MB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.

I still would like to keep kdelibs5-plugins and kdelibs4c2a installed in parallel. Can kdelibs5-plugins be fixed that way? Otherwise, would it be better to set up a PPA with all those KDE3 apps and add new kdelibs4c2a version which does not conflict kdelibs5-plugins?

Philip Muškovac (yofel) wrote :

Considering that kdelibs4c2a isn't supported on anything except lucid (10.04) we're not going to change kdelibs5-plugins.
What I can do is change the breaks/replaces there so that someone can provide a compatible kdelibs4c2a without the conflicting files in a PPA.

It's now breaking kdelibs4c2a << 4:3.5.10.dfsg.1-6~ so feel free to provide a version >> -6~ somewhere that doesn't conflict with the current kde4libs.

ruedihofer (ruedihofer) wrote :

I had kdelibs4c2a-4:3.5.10 installed because I was still using kbiff. I have now moved to gnubiff, which works well under kde 4.10. Since kbiff isn't supported anymore I suggest to all to use gnubiff instead.

Thanks Philip, this is a good solution.

robegue (r087r70) wrote :

is there any workaround, even dirty, to bypass the problem in the meanwhile?

Philip Muškovac (yofel) wrote :

You can always install the package with "dpkg --force-overwrite -i <deb>"
That will break on any update, but it does at least get the package management working again.

My problem seems related but is even worse. Upgrading via muon in quantal from 4.9.4 to 4.10 worked like a charm but all my precious kde3-applications, which until this moment resided peacefully side by side with kde4, were deinstalled during the process. Only could get them back by playing back an image I fortunately had taken befor upgrading. Giving it a second try I can't find a way in muon to get kde4.10 installed without kde3-applications being deinstalled. So my question.

Is there a new kdelibs4c2a in some ppa wich I can update to, so that kde4.10 doesn't encounter a conflict? Where can I find it?

Or, how does this override-thing work. Neither muon nor muon-updater offer this option as far as I know.

robegue (r087r70) wrote :

The problem is that even if we modify the kdelibs4c2a in order to avoid the overwriting of ktelnetservice and kmailservice files (deb package attached), the kdelibs5-plugins breaks kdelibs4c2a. Therefore I cannot see a long-term solution here.

robegue (r087r70) wrote :

what a dumb I am.
kdelibs4c2a_3.5.10.dfsg.1-6 attached

thanks robegue for providing the new package.

Can I use it with an i386-installation as well?

robegue (r087r70) wrote :

Hi Knut,

no you can't. If/when I have time I may upload the i386 package as well. But you can easily do it yourself: just take the original package, then do

mkdir temp
cd temp
dpkg-deb -x ../package.deb . #note the final mark
dpkg-deb -e ../package.deb #without mark

Now edit the package content: remove ktelnetservice and kmailservice files (also man files), change version.

Rebuilding:

dpkg-deb -b . ../newpackage.deb #note the initial mark

dpkg -i ../newpackage.deb

enjoy!

Thanks robegue,

it worked like a charm. Got the new version installed and now the old kde3-apps won't be marked for deinstallation on upgrade to 4.10 anymore.

There are two more questions I've got.

1. shouldn't it be "pkg -I ../newpackage.deb" with capital I. The other option wasn't recognized.

2. wouldn't it be possible to get all the kde3-applications out of the way by editing their respective Debian packages. What I mean is in case of kdelibs4c2a for instance changing the directory tree like this:

/usr -> /kde3

Wouldn't that mean, that all applications, libraries and documentation files would be installed under /kde3 instead /usr? Adding the new paths should be enough to make them accessible. The only thing that worries me ist the file installed under /etc. But there it already has been installed into a kde3-subdirectory.

And here the updated package.

robegue (r087r70) wrote :

Hi Knut,

1. no it isn't. It's "sudo dpkg -i ../newpackage.deb".
"-i" is for installing, "-I" is for info, read the manual.

2. the kde3 applications are just fine, why you want to change installation root? I don't think it'is useful.

Hi robegue,

1. you are right, my fault.

Didn't copy your command into the terminal but simply chaged the last one and thus was invoking:

dpkg-deb -i ../newpackage.deb

The package I install with GDebi.

2. My idea was getting all the old stuff out of the way just in case later changes in newer packages would lead to more conflicts like this one. Moving the old libs and applications into another directory at least would prevent them from being overridden, I thought. In your post #14 you were mentioning that this fix isn't a long term solution. Hoped my idea could be one. But maybe I think the wrong way. Don't know nothing about packaging and even prefer tools like moun or synaptic to the command line.

Hi all,

I think the best way (for users) is to set up a PPA which provides a working kdelibs4c2a package and all those useful KDE3 apps.

The main problems are:

1. Users should be aware that there will not be any security updates for KDE3 apps, since they are in fact deprecated.

2. Repackaging and removing files from binary debs is much easier than building and uploading new source packages.

Anyway, I started this at https://launchpad.net/~kde3apps and everybody is welcome to contribute.

Hi Martin,

great idea. I'll join in. See you at the ppa.

Knut

Philip Muškovac (yofel) wrote :

"2. Repackaging and removing files from binary debs is much easier than building and uploading new source packages."

The files that are shipped in the .deb's are controlled by the debian/*.install files. So if you upload a package to a PPA just remove the conflicting files from the install files in the packaging

Hi Philip, thanks for the info. Another problem is the dependency on libavahi-qt3-1, which is not available in newer Ubuntu releases. Users of kdelibs4c2a probably still have an old (lucid) version installed. I wonder whether it's easier to rebuild libavahi-qt3-1 for precise, use libavahi-qt4-1 instead, or use any other solution?

Silver Moon (m00n-silv3r) wrote :

I need the kdelibs4c2a package to install quanta plus web editor on ubuntu 13.04
Please suggest some fix to install the package

kdelibs4c2a_3.5.10.dfsg.1-5ubuntu2_amd64

on ubunt 13.04

it conflicts with kdelibs5-plugins package and say

*********
dpkg: dependency problems prevent configuration of kdelibs4c2a:
 kdelibs5-plugins (4:4.10.2-0ubuntu2) breaks kdelibs4c2a (<< 4:3.5.10.dfsg.1-6~) and is installed.
  Version of kdelibs4c2a to be configured is 4:3.5.10.dfsg.1-5ubuntu2.

dpkg: error processing kdelibs4c2a (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db ...
Errors were encountered while processing:
 kdelibs4c2a

*********

unable to upgrade to ubuntu 13.04

Hi all,

want to come back to this thread since I ran again into the old problem when KDE 4.11 came out. I could avoid it by not upgrading KDE, but when it came to upgrading to Kubuntu 13.10 there was no way around it any more. And of course, during the upgrade process all my KDE3 applications should have been uninstalled. That is why I did some research to find an updated version of kdelibs4c2a, which did not conflict with KDE 4.11.

Eventually I stumbled upon this post http://www.binarytides.com/install-quanta-plus-ubuntu-13-04/ about installing Quanta plus under Raring. And it worked for me. The thus installed Quanta survived the upgrade from Raring to Saucy and runs under KDE 4.11.

Big drawback: all my other KDE3 application were gone, since the original kdelibs4c2a was uninstalled during the upgrade process. And for some reason they were not in the Trinity packages.

But I still could find them on lauchpad: https://launchpad.net/ubuntu/lucid/i386/ Here I searched for all the packages I needed and downloaded them. Then I edited them acording to the procedure proposed by @robegue in post #17. I basically did two things:

1. I moved all stuff whch was found under /usr to /opt/kde3, where the Trinity packeges are installed

2. I edited the control file to change the dependencies which basically means I added -kde3 to kdelibs4c2a, since the Trinity project renamed all packages by adding -kde3.

Last but not least I added /opt/kde3/bin to the PATH variable to make sure that the programs can be evoked by their name instead of the full path. Probalbly it would be wise to add something to the man path etc. too, but I couldn't be bothered.

@Silver Moon: as described above one gets Quanta plus running under 13.10. But you have to make sure to uninstall the kdelibs4c2a package as well as the old kdelibs-data.

@Martin Schläffer: with the kde3 maintainers repository already exists a PPA which holds a working kdelibs4c2a. The only thing, not all programs found their way into this repo. What about publishing the missing packages on your PPA? I could contribute hacked lucid packages for klamav, kleansweep, knmap, knoda, kstreamripper and ktranslator. But it would be a good idea if someone with more insight in packaging would have a look at my packages first.

Have fun.

Knut

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers