[intrepid] package libqt4-ruby1.8 4:4.1.0-0ubuntu2 failed to install/upgrade: trying to overwrite `/usr/bin/rbqtapi', which is also in package libqt0-ruby1.8

Bug #262869 reported by Alex Wauck on 2008-08-30
36
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kde4bindings (Ubuntu)
Medium
Scott Kitterman
kdebindings (Ubuntu)
Undecided
Unassigned

Bug Description

Here's the relevant part:
dpkg: error processing /var/cache/apt/archives/libqt4-ruby1.8_4%3a4.1.0-0ubuntu2_amd64.deb (--unpack):
 trying to overwrite `/usr/bin/rbqtapi', which is also in package libqt0-ruby1.8
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libqt4-ruby1.8_4%3a4.1.0-0ubuntu2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried removing libqt0-ruby1.8, and sure enough, libqt4-ruby1.8 successfully installed after that. I'm not terribly familiar with either package, so I don't know what the right solution would be, but I think renaming rbqtapi and using the alternatives system to select one or the other would be the way to go here. Either that or adding those packages to each others' conflicts lists.

ProblemType: Package
Architecture: amd64
DistroRelease: Ubuntu 8.10
ErrorMessage: trying to overwrite `/usr/bin/rbqtapi', which is also in package libqt0-ruby1.8
NonfreeKernelModules: nvidia
Package: libqt4-ruby1.8 4:4.1.0-0ubuntu2
SourcePackage: kde4bindings
Title: package libqt4-ruby1.8 4:4.1.0-0ubuntu2 failed to install/upgrade: trying to overwrite `/usr/bin/rbqtapi', which is also in package libqt0-ruby1.8
Uname: Linux 2.6.27-1-generic x86_64

Alex Wauck (awauck) wrote :
Changed in kde4bindings:
assignee: nobody → kitterman
importance: Undecided → Medium
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde4bindings - 4:4.1.1-0ubuntu3

---------------
kde4bindings (4:4.1.1-0ubuntu3) intrepid; urgency=low

  * Add conflicts/replaces libqt0-ruby1.8 to libqt4-ruby1.8 (LP: #262869)
  * Fix typo in qyoto-examples long description
  * Add libmono-dev to buid-dep to fix FTBFS on lpia
  * Don't try to build mono bindings for hppa (mono not built on hppa):
    - Add [!hppa] for all mono build-dep and arch any [!hppa] for all arch
      any qyoto packages
  * Move pykdeuic4 to python-kde4-dev (LP: #250285)
    - Change python-kde4.links to python-kde4-dev.links
    - python-kde4-dev conflict/replace python-kde4 (=< 4:4.1.1-0ubuntu2)

 -- Scott Kitterman <email address hidden> Fri, 12 Sep 2008 23:26:01 -0400

Changed in kde4bindings:
status: In Progress → Fix Released
Changed in kdebindings:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers