Blank, unselectable wallpaper listed in Desktop Settings

Bug #964046 reported by Tim Pederick
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
kde-workspace (Ubuntu)
Medium
Unassigned

Bug Description

Release: Kubuntu 12.04 Precise Pangolin Beta 1

Observed: When going into the Desktop Settings of a brand-new installation, I find the current wallpaper listed along with an odd blank entry; no preview, just "1920x1200". A screenshot is attached. Clicking on this mysterious entry makes it disappear, as does moving focus to it by keyboard. The Apply button is enabled when this entry is selected, but clicking it changes nothing (except by taking focus away from the blank entry and so making it visible again!)

If I then install another wallpaper (from Get New Wallpapers..., other methods haven't been tested), it too appears blank, with nothing but a name, and vanishes if I select it. However, if I click Apply while it's selected, it does become the new background. And if I close Desktop Settings and return to it, the new wallpaper's preview and details are now filled in. (The blank entry persists, however.)

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: plasma-desktop 4:4.8.0b-0ubuntu5
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.93-0ubuntu2
Architecture: amd64
Date: Sun Mar 25 02:13:16 2012
EcryptfsInUse: Yes
InstallationMedia: Kubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120228.1)
ProcEnviron:
 LANGUAGE=en_AU:en
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: kde-workspace
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Tim Pederick (pederick) wrote :
Revision history for this message
Tim Pederick (pederick) wrote :
Revision history for this message
Tim Pederick (pederick) wrote :
Revision history for this message
Philip Muškovac (yofel) wrote :

Hi, thank you for taking your time to report this bug and helping to make Kubuntu better.

This should be caused by a symlink to the kde default wallpaper that isn't shown properly. It should be either hidden or removed in the next release.

Changed in kde-workspace (Ubuntu):
importance: Undecided → Medium
milestone: none → ubuntu-13.10
status: New → Triaged
tags: added: kubuntu
Revision history for this message
Harald Sitter (apachelogger) wrote :

That should be fixed in >= 4:4.10.2-0ubuntu2

Changed in kde-workspace (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers