krandr-tray doesn't restore monitor arrangement on startup

Bug #898390 reported by Jordan Bradley on 2011-11-30
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
KDE Base Workspace
Fix Released
Medium
kde-workspace (Ubuntu)
Medium
Unassigned

Bug Description

1: put DVI-1 on the right of DVI-0
2: Click "Apply"
3: Click "Save as default"
4: Reboot

on reboot the settings are lost and the second monitor mirrors the first.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: kde-workspace 4:4.7.3a-0ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-2.5-generic 3.2.0-rc3
Uname: Linux 3.2.0-2-generic x86_64
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
Date: Wed Nov 30 17:24:33 2011
InstallationMedia: Kubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111121)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_CA:en
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: kde-workspace
UpgradeStatus: No upgrade log present (probably fresh install)

Version: (using KDE 4.2.0)
OS: Linux
Installed from: Unspecified Linux

With KDE 4.2, the Display Settings (Size & Refresh Rate) are lost after a Logout.

When using KDE to set your Display settings, [System > System Settings > Display], after logging out from the system, the settings you indicated are lost. The settings you chose aren't 'retained'.

The temporary fix is to set xorg.conf to the precise resolution and dpi you want. If this must be the case, then what's the sense of having the display settings option if it doesn't work.

Linux Distribution: Arch Linux
Graphics Card: Nvidia GeForce4 MX 440 AGP 8x

*** Bug 193139 has been marked as a duplicate of this bug. ***

*** Bug 190553 has been marked as a duplicate of this bug. ***

*** Bug 193473 has been marked as a duplicate of this bug. ***

The problem is still present in KDE 4.4.2

*** This bug has been confirmed by popular vote. ***

# patch
file location = $KDE_PREFIX/bin
--- startkde.orig
+++ startkde
@@ -81,7 +81,7 @@
 kcminputrc Mouse cursorSize ''
 ksplashrc KSplash Theme Default
 ksplashrc KSplash Engine KSplashX
-kcmrandrrc Display ApplyOnStartup false
+kcmrandrrc Display ApplyOnStartup true
 kcmrandrrc [Screen0]
 kcmrandrrc [Screen1]
 kcmrandrrc [Screen2]

# ~/.xinitrc
export kcmrandrrc_display_applyonstartup=true
export kcmrandrrc_screen0_width=1024
export kcmrandrrc_screen0_height=768
export kcmrandrrc_screen0_refresh=70
exec dbus-launch --exit-with-session startkde

startx applies width=1024, height=768, refresh=70 to screen

The suggestion is bugs in
kdebase-workspace-4.4.2/startkde.cmake
kdebase-workspace-4.4.2/kstartupconfig/kstartupconfig.cpp
kdebase-workspace-4.4.2/kstartupconfig/kdostartupconfig.cpp

Have not yet found a way to pass the variables via kdm.

(In reply to comment #6)
> export kcmrandrrc_display_applyonstartup=true
> export kcmrandrrc_screen0_width=1024
> export kcmrandrrc_screen0_height=768
> export kcmrandrrc_screen0_refresh=70

Those can be added to ~/.bash_profile and kdm will use.

*** Bug 235000 has been marked as a duplicate of this bug. ***

*** Bug 232500 has been marked as a duplicate of this bug. ***

*** Bug 220033 has been marked as a duplicate of this bug. ***

*** Bug 229385 has been marked as a duplicate of this bug. ***

*** Bug 228565 has been marked as a duplicate of this bug. ***

*** Bug 221136 has been marked as a duplicate of this bug. ***

*** Bug 232471 has been marked as a duplicate of this bug. ***

*** Bug 198834 has been marked as a duplicate of this bug. ***

*** Bug 228991 has been marked as a duplicate of this bug. ***

In kdebase-workspace/kstartupconfig, kdostartupconfig.cpp which compiles to kdostartupconfig4 is broken with regard to the "screen". In the first place, there is never any file named kcmrandrrc which is seen in startupconfigkeys. Even if krandrrc is copied to kcmrandrrc so that kdostartupconfig4 could read it, it fails to parse anything that could be used to set the size or refresh rate. As a result, the script ~/.kde/share/config/startupconfig it produces only contains comments, e.g., # kcmrandrrc [Screen0], and no actual settings.

Created attachment 43253
Patch to fix display settings being lost on logout

This seems to fix it for screen0 with one exception:
Krandrtray does not save an overriden refresh rate to krandrrc.

"System Settings" -> "Display" will save the refresh rate to krandrrc.
"kcmshell4 randr" also will save the refresh rate to krandrrc.

In startkde, changed kcmrandrrc to krandrrc because there is never any file named kcmrandrrc.

Linux Fan,

I guess I'm a fan as well.

Sorry to bother you and for the stupid question. I keep my systems closely up to date. How can I know when to start looking for this fix?

Regards and THANKS for your help!

George...

"It's not what you know that hurts you, It's what you know that ain't so." Wil Rogers

--- On Tue, 5/4/10, linux fan <email address hidden> wrote:

From: linux fan <email address hidden>
Subject: [Bug 183143] Display Settings are Lost on Logout
To: <email address hidden>
Date: Tuesday, May 4, 2010, 2:47 PM

https://bugs.kde.org/show_bug.cgi?id=183143

--- Comment #18 from linux fan <linuxscratch gmail com>  2010-05-04 23:46:58 ---
Created an attachment (id=43253)
 --> (http://bugs.kde.org/attachment.cgi?id=43253)
Patch to fix display settings being lost on logout

This seems to fix it for screen0 with one exception:
Krandrtray does not save an overriden refresh rate to krandrrc.

"System Settings" -> "Display" will save the refresh rate to krandrrc.
"kcmshell4 randr" also will save the refresh rate to krandrrc.

In startkde, changed kcmrandrrc to krandrrc because there is never any file
named kcmrandrrc.

Created attachment 43609
Patch to fix display settings being lost on logout (improved)

*** Bug 239832 has been marked as a duplicate of this bug. ***

*** Bug 239873 has been marked as a duplicate of this bug. ***

*** Bug 240988 has been marked as a duplicate of this bug. ***

*** Bug 242404 has been marked as a duplicate of this bug. ***

(to linuxfan mostly), I tried giving the supplied patch a try, and it doesn't seem to work. See downstream tracking bug,
https://bugzilla.redhat.com/show_bug.cgi?id=607180

Any suggestions?

(In reply to comment #25)
> (to linuxfan mostly), I tried giving the supplied patch a try, and it doesn't
> seem to work. See downstream tracking bug,
> https://bugzilla.redhat.com/show_bug.cgi?id=607180
>
> Any suggestions?

Er, umphhh, uh,

In the first place, startkde, which is a shell script that is generated by startkde.cmake, has: "kcmrandrrc Display ApplyOnStartup false" which caused (at least for me) no possibility to apply the settings on startup no matter what.

In the second place, there never is or was any file named kcmrandrrc in any subdirectory of ~/.kde and so it would never be read no matter what.

In the third place, even if the first two obstacles were magically overcome, kdostartupconfig4, which is generated from kdostartupconfig.cpp, has absolutely no method for parsing krandrrc in ~/.kde subdir and thus there is no magic key to unlock the magic black box.

Those are the facts with respect to my particular encounter.

Looking at comment #7 , I found that setting particular environment variables durin the "login" had the effect of utimately executing an xrandr command with the settings that I wanted to be applied.

Further tearing out hair led me to the patch which worked in my particular encounter.

I had only one screen which was named "Output default" by kde "display settings" which appeared in the krandrrc file in the subdir of ~/.kde.

So, for me, the patch altered the name kcmrandrrc to krandrrc which is a file that actually exists. It then plows through that file to parse out the display settings. It is possible that in other installations, the format of the entries in krandrrc may be vastly different than what I encountered.

Due to there being only 80 votes on this bug, I can only imaging that everybody else has a magic system, and I do not.

For posterity, my ~/.kde/share/config/krandrrc contains:

[Screen_0]
OutputsUnified=true
UnifiedRect=0,0,800,600
UnifiedRotation=1

[Screen_0_Output_LVDS1]
Active=true
Rect=0,0,1024,768
RefreshRate=60.0038414001465
Rotation=1

but my LVSD laptop display reverted to (default) 1280x800 in X session restart.

(In reply to comment #27)
my ~/.kde/share/config/krandrrc contained
[Screen_0]
OutputsUnified=false
UnifiedRect=0,0,0,0
UnifiedRotation=1

[Screen_0_Output_default]
Active=true
Rect=0,0,1024,768
RefreshRate=70
Rotation=1

I see "Screen_0_Output_" is common to both, but yours need to be "LVDS1" where mine was "default"

Programming kde is not something I know how to do, but I try to learn.

*** Bug 244438 has been marked as a duplicate of this bug. ***

probably the same bug (or not ?)

Hello,

in mandriva 2010.1 :
Description of problem:
I have got a two display configuration with a radeon/fglrx.
I have one display in absolute 0x0 and the second right of the first.
I can change the conf, but if i restart my computer, i have to re-go into the
systemsettings to reconfigure the display.
The settings are not saves.

I have had the same problem into the mdv 2010.0 with the same conf ( but don't have
made a bug report, sorry ... ).

( link to mdv bug report : https://qa.mandriva.com/show_bug.cgi?id=60473 )

thanks
hurdman

I've submitted this bug months ago and still not a descent resolution. How can I force this manually? Belows is the output from xrandr.

Screen 0: minimum 320 x 200, current 3360 x 1080, maximum 8192 x 8192
LVDS-1 connected 1440x900+1920+0 (normal left inverted right x axis y axis) 367mm x 230mm
   1440x900 60.0*+
   1152x864 60.0
   1024x768 59.9
   800x600 59.9
   640x480 59.4
   720x400 59.6
   640x400 60.0
   640x350 59.8
VGA-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080 59.9*+
   1600x1200 60.0
   1680x1050 60.0
   1280x1024 60.0
   1440x900 59.9
   1280x960 60.0
   1280x800 59.8
   1024x768 60.0
   800x600 60.3 56.2
   640x480 60.0
DVI-D-1 disconnected (normal left inverted right x axis y axis)

I wish to add my voto for an option to save the settings. I occasionally connect an extra display, and always need to configure it from scratch. I would like to be able to save a profile for each external monitor I connect, so that upon connecting it I get the correct desktop layout and resolution.

SVN commit 1170315 by lunakl:

- move the somewhat long krandr setup code from startkde
  into its own separate script that is called from startkde
- use properly krandrrc instead of kcmrandrrc in the script
- implement support for randr1.2 (non-legacy) setup, which
  is done by kcm_krandr simply saving a list of CLI xrandr commands
  and those are executed by the script
- add a buttom to kcm_krandr to save the current setup
  as the default to be used during desktop startup

FEATURE: 157839
FEATURE: 219704
FEATURE: 235883
FEATURE: 238278
FEATURE: 163707
FEATURE: 141999
FEATURE: 229529
BUG: 246298
FEATURE: 183143

 M +5 -0 kcontrol/randr/CMakeLists.txt
 AM kcontrol/randr/krandrstartup
 M +5 -1 kcontrol/randr/legacyrandrconfig.cpp
 M +22 -0 kcontrol/randr/legacyrandrscreen.cpp
 M +1 -0 kcontrol/randr/legacyrandrscreen.h
 M +46 -0 kcontrol/randr/randrconfig.cpp
 M +2 -0 kcontrol/randr/randrconfig.h
 M +8 -1 kcontrol/randr/randrconfigbase.ui
 M +31 -2 kcontrol/randr/randrdisplay.cpp
 M +3 -1 kcontrol/randr/randrdisplay.h
 M +31 -0 kcontrol/randr/randroutput.cpp
 M +1 -0 kcontrol/randr/randroutput.h
 M +11 -0 kcontrol/randr/randrscreen.cpp
 M +1 -0 kcontrol/randr/randrscreen.h
 M +7 -48 startkde.cmake

WebSVN link: http://websvn.kde.org/?view=rev&revision=1170315

*** Bug 245416 has been marked as a duplicate of this bug. ***

38 comments hidden view all 176 comments
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kde-workspace (Ubuntu):
status: New → Confirmed
Dale Trombley (buzzmandt) wrote :

same here cept on laptop I set LVDS1 as primary at 1366x768 and secondary at 1024x768. Doesn't save and after restart both displays are mirrored at 1024x768. Works perfectly in oneiric. Definitely a regression.

FriedChicken (domlyons) wrote :

Confirmed for KDE 4.8 (from ppa:kubuntu-ppa/backports) on Kubuntu 11.10

More details: https://bugs.kde.org/show_bug.cgi?id=292419

Changed in kdebase-workspace:
importance: Unknown → Medium
status: Unknown → New
FriedChicken (domlyons) wrote :

Seems to be a packaging (or cinfiguration) problem: See comment #93 and comment #96 on https://bugs.kde.org/show_bug.cgi?id=183143

Changed in kdebase-workspace:
importance: Medium → Unknown
status: New → Unknown
Changed in kdebase-workspace:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in kde-workspace (Ubuntu):
importance: Undecided → Medium
tags: added: regression
131 comments hidden view all 176 comments

The bug is for multiple monitors
(In reply to comment #129)
> I still don't quite understand how it works for me and not for other people.
> It must be that my particular options don't fail?
>
> I have only one monitor... I set the display size to max... it always seems
> to work.
>
> George...

Here is everything fine now. But i could not say with which Version it is fixed. The only thing i could say, is:

Don't use the proprietary driver. Don't have a /etc/X11/xorg.conf file. If you are using a proprietary driver, it would be better to adjust the Screensettings within xorg.conf.

My System:
$ lspci -nnk | grep -i -A2 vga
02:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Cedar PRO [Radeon HD 5450] [1002:68f9]
        Subsystem: ASUSTeK Computer Inc. Device [1043:03ca]
        Kernel driver in use: radeon

Working with two Monitors with this graphicscard, one left, one right.:

$ xrandr
Screen 0: minimum 320 x 200, current 3360 x 1050, maximum 8192 x 8192
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-0 connected 1680x1050+1680+0 (normal left inverted right x axis y axis) 473mm x 296mm
   1680x1050 59.9*+
 [...]
VGA-0 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 474mm x 296mm
   1680x1050 59.9*+
 [...]

The left is VGA-0, the right one is DVI-0. The resolution is on both Screen 1680x1050. The DVI-0 position is: Absolute, 1680x0 The VGA-0 position is Left from DVI-0.

You have to save your settings explicitly with the Button "Save as Default" beneath the " Identify Outputs"-Button.

Sorry, but for me this Bug is solved.

On Friday 12 October 2012 13:13 you wrote:
> https://bugs.kde.org/show_bug.cgi?id=183143
>
> --- Comment #131 from Franky <email address hidden> ---
> Here is everything fine now. But i could not say with which Version it
> is fixed. The only thing i could say, is:
>
> Don't use the proprietary driver. Don't have a /etc/X11/xorg.conf
> file. If you are using a proprietary driver, it would be better to
> adjust the Screensettings within xorg.conf.
>
> My System:
> $ lspci -nnk | grep -i -A2 vga
> 02:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD]
> nee ATI Cedar PRO [Radeon HD 5450] [1002:68f9]
> Subsystem: ASUSTeK Computer Inc. Device [1043:03ca]
> Kernel driver in use: radeon
>
> Working with two Monitors with this graphicscard, one left, one
> right.:
>
> $ xrandr
> Screen 0: minimum 320 x 200, current 3360 x 1050, maximum 8192 x 8192
> HDMI-0 disconnected (normal left inverted right x axis y axis)
> DVI-0 connected 1680x1050+1680+0 (normal left inverted right x axis y
> axis) 473mm x 296mm
> 1680x1050 59.9*+
> [...]
> VGA-0 connected 1680x1050+0+0 (normal left inverted right x axis y
> axis) 474mm x 296mm
> 1680x1050 59.9*+
> [...]
>
> The left is VGA-0, the right one is DVI-0. The resolution is on both
> Screen 1680x1050. The DVI-0 position is: Absolute, 1680x0 The VGA-0
> position is Left from DVI-0.
>
> You have to save your settings explicitly with the Button "Save as
> Default" beneath the " Identify Outputs"-Button.
>
> Sorry, but for me this Bug is solved.

For me this bug isn't solved. Pressing the button "Save as Default" indeed does save the settings, but this is no solution for me. At work I use a docking station and connect my laptop to an external monitor. The laptop's lid is closed, so I want the laptop screen switched off and the external monitor set to its maximum resolution. At home and when travelling I use the laptop screen. If I save the work configuration as default, I get a black screen when I start the laptop at home. With Unity, Gnome Shell and XFCE, the system automatically checks whether an external monitor is connected or not, and adjusts the display settings accordingly. Only KDE (4.9.2 on Kubuntu 12.04.1) does not do that. However, you could argue that that is a different bug from the one reported here, I suppose.

@ Gita Benadi: Yes, ithink your Bug is different from the one reported here, because you want to switch between two Monitorsettings.

I forgot to report, which Distirbution i use: Its Kubuntu 12.04 with actual KDE 4.9.2. But this issue was allways fixed for me before April 2012. Don't know which KDE-Version it was. Maybe KDE 4.7.xx

@ Frans: Seems that your Post was truncated. I trie to put missing here:
Is this output after reboot, or after you set the Settings in KDE?
>xrandr
>Screen 0: minimum 320 x 200, current 3360 x 1050, maximum 4096 x 4096
>VGA-1 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 474mm x 296mm
 > 1680x1050 60.0*+
>DVI-I-1 connected 1680x1050+1680+0 (normal left inverted right x axis y
axis) 474mm x 296mm
> 1680x1050 60.0*+

> How do you actually save the "Display Settings in System
Settings/Display and Monitor/Seize and Orientation after you have
corrected them.
> What I actually do is:
>1 Correct the settings
>2 Press the "Save as default button"
>3 Press the "Apply button"
>4 Press the "Accept Configuration button in the pop up window"
Yes, i do it in this way. But actually i do not have to do this ;)

You use the KDE-Version 4.7.2 As described in https://bugs.kde.org/show_bug.cgi?id=183143#c87 i used in January the KDE-Version 4.7.97.

Hello Franky,
In openSUSE 12.1 the problem is solved as you follow the following steps to save the
corrected settings in System Settings/Display and Monitor/Seize & Orientation:
1 Press the "Save as default button"
2 Press the "Apply button"
3 Press the "Accept Configuration button in the pop up window"

After this the xrandr command displayed the following:
Screen 0: minimum 320 x 200, current 3360 x 1050, maximum 4096 x 4096
VGA-1 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 474mm x 296mm
   1680x1050 60.0*+
   1280x1024 75.0 60.0
   1440x900 75.0 59.9
   1280x960 60.0
   1152x864 75.0
   1024x768 75.1 70.1 60.0
   832x624 74.6
   800x600 72.2 75.0 60.3 56.2
   640x480 72.8 75.0 66.7 60.0
   720x400 70.1
DVI-I-1 connected 1680x1050+1680+0 (normal left inverted right x axis y axis) 474mm x 296mm
   1680x1050 60.0*+
   1280x1024 75.0 60.0
   1440x900 75.0 59.9
   1280x960 60.0
   1360x768 60.0
   1152x864 75.0
   1024x768 75.1 70.1 60.0
   832x624 74.6
   800x600 72.2 75.0 60.3 56.2
   640x480 72.8 75.0 66.7 60.0
   720x400 70.1

In openSUSE 12.2 KDE LiveCD x86-64.iso the situation is different. The corrected Seize & Orientation settings, saved as described above, generate the same xrandr display. However logging out of KDE and logging back in does not use the corrected settings while the xrandr command display is still the same as described above. To correct the situation you have to reexecute the Seize & Orientation settings and save them as described.

Regards, Frans

The behavior of a Live-Sessio is maybe different? So i do not know, if the directory /home/user in a Live-Session on logout still exists.

Hello Franky,

I have now installed openSUSE 12.2 / KDE from the LiveCD x86-64.iso, but unfortunately the display settings are not saved, so the problem still exists in:
OS Information
OS: Linux 3.4.11-2.16-desktop x86_64
  Current user: frans@MD8800-openSUSE-12-2
  System: openSUSE 12.2 (x86_64)
  KDE: 4.8.5 (4.8.5) "release 2"
  Display Info
Vendor: nVidia Corporation
  Model: GeForce 6700 XL
  2D driver: nouveau
  3D driver: nouveau Gallium (8.0.4)

After correcting the display settings and saving as described earlier, the command xrandr shows the following:
frans@MD8800-openSUSE-12-2:~> xrandr
Screen 0: minimum 320 x 200, current 3360 x 1050, maximum 4096 x 4096
VGA-1 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 474mm x 296mm
   1680x1050 60.0*+
   1280x1024 75.0 60.0
   1440x900 75.0 59.9
   1280x960 60.0
   1152x864 75.0
   1024x768 75.1 70.1 60.0
   832x624 74.6
   800x600 72.2 75.0 60.3 56.2
   640x480 72.8 75.0 66.7 60.0
   720x400 70.1
DVI-I-1 connected 1680x1050+1680+0 (normal left inverted right x axis y axis) 474mm x 296mm
   1680x1050 60.0*+
   1280x1024 75.0 60.0
   1440x900 75.0 59.9
   1280x960 60.0
   1360x768 60.0
   1152x864 75.0
   1024x768 75.1 70.1 60.0
   832x624 74.6
   800x600 72.2 75.0 60.3 56.2
   640x480 72.8 75.0 66.7 60.0
   720x400 70.1
frans@MD8800-openSUSE-12-2:~>

I have forgotten to run xrandr command before I made the display settings but I will do that after I save this additional commend and send it as an additional comment.

Regards, Frans

Hello Franky,

This is xrandr output before making the correction to the display settings:
frans@MD8800-openSUSE-12-2:~> xrandr
Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 4096 x 4096
VGA-1 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 474mm x 296mm
   1680x1050 60.0*+
   1280x1024 75.0 60.0
   1440x900 75.0 59.9
   1280x960 60.0
   1152x864 75.0
   1024x768 75.1 70.1 60.0
   832x624 74.6
   800x600 72.2 75.0 60.3 56.2
   640x480 72.8 75.0 66.7 60.0
   720x400 70.1
DVI-I-1 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 474mm x 296mm
   1680x1050 60.0*+
   1280x1024 75.0 60.0
   1440x900 75.0 59.9
   1280x960 60.0
   1360x768 60.0
   1152x864 75.0
   1024x768 75.1 70.1 60.0
   832x624 74.6
   800x600 72.2 75.0 60.3 56.2
   640x480 72.8 75.0 66.7 60.0
   720x400 70.1
frans@MD8800-openSUSE-12-2:~>

For me the before and after xrandr output are exactly the same so there must be an other reason why they are not picked up.

The problem stayed the same after running the system updates currently available.

Regard, Frans

(In reply to comment #138)
> This is xrandr output before making the correction to the display settings:
> frans@MD8800-openSUSE-12-2:~> xrandr
> Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 4096 x 4096
> VGA-1 connected 1680x1050+0+0 (normal left inverted right x axis y axis)
> 474mm x 296mm
> DVI-I-1 connected 1680x1050+0+0 (normal left inverted right x axis y axis)
> 474mm x 296mm
> For me the before and after xrandr output are exactly the same so there must
> be an other reason why they are not picked up.
No, its not the same: Look at the "current"-Resolution for "Screen 0:" Screen defines the Overall-Resolution wich expands over all Monitors.

The next differnce is the third Value of "DVI-1". The Meaning of this Values are:

> DVI-I-1 connected WIDTHxHEIGHT+BEGINNINGfromLEFTof SCREEN+BEGINNINGfromTOPofSCREEN

I don't know, if SUSE or Kubuntu changes some of config-files, because in Kubuntu it works.

You could adjust the Settings in a Terminal with the Command xrandr. So this is the commandline for my Settings:

> xrandr --output DVI-0 --pos 1680x0 --mode 1680x1050 --refresh 59.8518 --output VGA-0 --pos 0x0 --mode 1680x1050 --refresh 59.8833 --output DVI-0 --primary

As a workaraound you could write a script with the correct xargs commands and place it in the autostartfolder. Or create a file /etc/X11/Xsession.d/45custom_xrandr-settings. If you could understand german, look at the wiki-page http://wiki.ubuntuusers.de/RandR

I am only a user, not a KDE maintainer so i could not say whats wrong.

Sorry, it has to be xrandr commands:

"As a workaraound you could write a script with the correct xrandr commands"

Hello,

This is to correct my statement in comment 137.

In openSUSE 12.2 / KDE installed from the LiveCD x86-64.iso the display settings are now saved.

I tried to save the corrected display settings in System Settings/Display and Monitor/Seize & Orientation with the following steps:
1 Set Primary Output to VGA-1
2 Press the "Save as default button"
3 Press the "Apply button"
4 Press the "Accept Configuration button in the pop up window"

I just found out that the system saves the display setting if I select by step 1 "None" in stead of "VGA-1" and execute step 2,3 and 4 as described.

Lucky me

Regards, Frans

On Friday 19 October 2012, you wrote:
> In openSUSE 12.2 / KDE installed from the LiveCD x86-64.iso the display
> settings are now saved.
>
> I tried to save the corrected display settings in System
> Settings/Display and Monitor/Seize & Orientation with the following
> steps:
> 1 Set Primary Output to VGA-1
> 2 Press the "Save as default button"
> 3 Press the "Apply button"
> 4 Press the "Accept Configuration button in the pop up window"
>
> I just found out that the system saves the display setting if I select
> by step 1 "None" in stead of "VGA-1" and execute step 2,3 and 4 as
> described.

Doesn't work for me. I'm using KDE 4.9.2 on openSUSE 12.2 (x86-64).

I too experience this on openSUSE 12.2 :-( And it is every time which means I need to configure the screen each time I log in..
And its on KDE 4.9.80 release 2

Hello all! I have a solution to autostart a screen rwsolution;

1.make a autostart laucher opening gedit and adding these codes:

Name=Screen Resolution
Categories=Application;System
Comment=Screen Resolution
Encoding=UTF-8 Exec=xrandr --output VGA1 --mode 1280x1024 --pos 0x0 --rotate normal Hidden=false Terminal=true T
ype=Application
Version=1.0
Icon=

2.then save this bach as a Screen-Resolution.desktop
3.goto user(your name or anyone you user's name have)press ctrl + h simultaniusly to show hidden files
4.goto /User/.config and put the launcher there, then reboot

"Remember you must to be logged as root to copy to that directory!" to do that you can type in Terminal gksudo nautilus and browse directory or you can use the copy command in Terminal.

Good Luck!

Problem still exists with KDE 4.10.1 (openSUSE 12.3).

Here's the URL of the openSUSE bug report mentioned in Comment #128: https://bugzilla.novell.com/show_bug.cgi?id=757273

This bugs is finally fixed for me using KScreen.

My dual display config is remembered as soon as i connect my display and without the display it only uses the single display.

This needs a real fix.

The fix is that KScreen will replace kcm_randr in 4.11.

This bug has been in kcm_randr since at least 4.2, so I wouldn't hold my breath for it getting fixed there. :-(

Nice. Now, what is KScreen and how do I use it? I'm afraid I'm just a user who just installed KDE 4.10 with openSuSE 12.3, obliterating the work I had done to make my right-hand screen be to the right of the main screen. (Long story) I think I fiddled the /etc/X11/xorg.conf.d files, but my backup (previous/12.2) file system got clobbered.

Never mind. I went back to the nvidia driver and it configures it permanently and correctly. Thanks.

Bug still persist as of KDE 4.10 in Fedora 19 pre-beta TC3 17:th of May 2013.

(In reply to comment #152)
Thank you. It's sparsity of documentation leads me to believe it is incomplete.
> https://fedoraproject.org/wiki/Features/KScreen
That's the real description of what it is. Thanks! The how to use it can wait until it is prime time ready. (If it is not documented pretty fully, then it is not ready yet.)

So the answer is that one must still edit /etc/X11 config files.

> Bug still persist as of KDE 4.10 in Fedora 19 pre-beta TC3 17:th of May 2013.

That's not normal. Fedora 19 uses KScreen, which should be saving settings just fine. Please file a new bug against KScreen.

The problem was still reproducible for me on KDE 4.10.2 through 4.10.5 on openSUSE 12.3. However, yesterday I upgraded to KDE 4.11.1 and now the display settings are (eventually) correctly applied on login. However, the process is a bit annoying in that immediately after logging in, the display settings are incorrect (that is, the relative position of my two monitors is wrong). It's only after several seconds (and after several applications already get loaded, and display in the wrong places) that the orientation gets switched to my preferred settings. So it's still buggy, but much less buggy than before.

@Tristan Miller: Since KDE 4.11, display settings are managed by KScreen instead of kcm_randr.
If you still have issues with restoring your display settings, please file a new bug report for KScreen, that the KScreen maintainers can fix them.

*** Bug 325518 has been marked as a duplicate of this bug. ***

https://bugs.kde.org/show_bug.cgi
Finally found a workaround!
* Remove the krandrrc file
cd ~/.kde/share/config/
mv krandrrc krandrrc _bakup
* Comment out nvidia-config resolution lines from /etc/X11/xorg.conf
# Option "nvidiaXineramaInfoOrder" "CRT-0"
# Option "metamodes" "CRT-0: nvidia-auto-select +0+0, CRT-1: nvidia-auto-select +1680+0"

Reboot, and the autoconfig will configure it in default "one desktop spanning two displays with independant widget sets per screen" -mode.

And stay away from nvidia-config or the kde display-settings panel as it will undo the changes above.

Congratulations, JK! Unfortunately, on my Debian system, the /etc/X11 tree has been improved and "xorg.conf" and "xorg.conf.d" have been conveniently melded into a different collection of files. I don't want to go experimenting as I know what happens when the X configuration gets frummitzed.

Is this really and truly rocket science? I mean, DANG! Just how hard *can* it be to leave my frigging configuration alone anyway? Every single time I boot up, I have to go find "Display and Monitor" in "system settings", change "clone" to be "to the right of" and then confirm that what I want to do every day always is, in fact, what I want to do this time, too.

I am on 4.8.4 and *FOUR* years have passed. Please, guys. Fix it. (And, yes, I understand that my freshly downloaded, new distribution contains a version of KDE so old that you won't maintain it anymore.)

This particular ticket probably will only be closed as 'UNMAINTAINED" instead of "FIXED", because this component is unmaintained and kscreen is the new and better replacement.

(In reply to comment #160)
> Congratulations, JK! Unfortunately, on my Debian system, the /etc/X11 tree
> has been improved and "xorg.conf" and "xorg.conf.d" have been conveniently
> melded into a different collection of files. I don't want to go
> experimenting as I know what happens when the X configuration gets
> frummitzed.

You can still use the legacy xorg.conf file if desired. The newer separated config files in the /etc/X11/ xorg.conf.d/ directory, essentially represent the corresponding sections in the legacy config file.

> I am on 4.8.4 and *FOUR* years have passed. Please, guys. Fix it. (And,
> yes, I understand that my freshly downloaded, new distribution contains a
> version of KDE so old that you won't maintain it anymore.)

Consider upgrading to 4.11 and you can leave kcm_randr issues behind. (I'm glad that KScreen has finally been implemented.)

    $ sudo find /etc/X11 -type d
    /etc/X11
    /etc/X11/Xresources
    /etc/X11/cursors
    /etc/X11/fonts
    /etc/X11/fonts/misc
    /etc/X11/fonts/75dpi
    /etc/X11/fonts/Type1
    /etc/X11/fonts/100dpi
    /etc/X11/app-defaults
    /etc/X11/Xreset.d
    /etc/X11/xinit
    /etc/X11/xkb
    /etc/X11/Xsession.d

I was able to cope with the xorg.conf -> xorg.conf.d change a couple of years ago. There are 103 files in that tree.

Anyway, "Consider upgrading to 4.11". Aren't the odd numbered minor releases experimental? I have enough problems just using the "stable releases". These problems don't exactly encourage me to go traipsing down the experimental installation path all on my own. Instead, can I encourage a stable 4.12 release sooner rather than later? Then I can grab a distro that uses it and install that. Then I only have to download all the apps that are not default and reconfigure my system again. Please forgive me for being so crotchety. This stuff gets old.

(In reply to comment #163)

> I was able to cope with the xorg.conf -> xorg.conf.d change a couple of
> years ago. There are 103 files in that tree.

You're mistaken. The config files are in /etc/X11/xorg.conf.d (only a handful).

> Anyway, "Consider upgrading to 4.11". Aren't the odd numbered minor
> releases experimental?

No, not the case at all. KDE 4.11 is current stable release:

http://www.kde.org/announcements/4.11/

Closing this bug. PLEASE KEEP IT CLOSED! This is fixed in 4.11 by the switch to KScreen. (I close it as "fixed in 4.11.0" rather than "unmaintained" so that it shows up in the list of fixed bugs in 4.11.0.) If you are still seeing related issues WITH 4.11.0 OR NEWER, please file a new bug against KScreen. If you are still using kde-workspace 4.10.x or older, YOUR ANCIENT KDE WORKSPACE IS NOT SUPPORTED ANYMORE, bugs will not and cannot be fixed in it.

Changed in kdebase-workspace:
status: Confirmed → Fix Released

(In reply to comment #166)
> Here's the related bug in Kscreen:
> https://bugs.kde.org/show_bug.cgi?id=325277

After spending heaps of time on this thing I finally realized I didn't have Kscreen installed in KDE 4.11.3 (it's not installed by default in the Arch Linux KDE-packages), actually installing the package solved the problem for good! Looks like KDE is falling back to the old way of doing things if kscreen is not installed...

Fedora 19 x86_64:

I have experienced a similar problem where switching from a quasi dual display mode to single display causes the desktop manager to loose it's mind. I see that it's suggested that kscreen resolves this problem but my system DOES have kscreen installed and I still have the problem.

George...

Rohan Garg (rohangarg) wrote :

Fixed in KDE SC 4.11 which is available for Precise via Kubuntu Backports PPA.

Changed in kde-workspace (Ubuntu):
status: Confirmed → Fix Released
Displaying first 40 and last 40 comments. View all 176 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.