Plasma workspace appears to crash when trying to add a default panel

Bug #875792 reported by Chris Sykes on 2011-10-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KDE Base Workspace
Unknown
Unknown
kde-workspace (Ubuntu)
Low
Unassigned

Bug Description

When I pick Add New Panel > Default Panel from the plasma menu in Oneiric, A new panel appears, and then the screen goes black for a few seconds, then everything comes back, with the panel gone. The first time I did this, I got a message box telling me a segfault had occurred, but not on other times.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: plasma-desktop 4:4.7.1-0ubuntu5
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Sun Oct 16 16:35:37 2011
InstallationMedia: Kubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: kde-workspace
UpgradeStatus: Upgraded to oneiric on 2011-10-10 (5 days ago)

Chris Sykes (jcgs) wrote :
Dave Gilbert (ubuntu-treblig) wrote :

Medium -> Moderate impact on core (Kubuntu) application

Changed in kde-workspace (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Dave Gilbert (ubuntu-treblig) wrote :

Oh, confirmed because I can repeat it.

Chris Sykes (jcgs) wrote :

Apparently this is a known thing when you try and have two systrays. Therefore would a good fix be to just hide the "default panel" option until we can have two systrays safely? How would one go about adding that to the code? I'm happpy to do it, but I'm just short on experience, and will need a bit of training

Changed in kde-workspace (Ubuntu):
importance: Medium → Low
Chris Sykes (jcgs) wrote :

Hmmm, Why did it get downgraded? and what exactly do the categories mean? Is there somewhere I can find out?

Chris Sykes (jcgs) wrote :

Don't worry about that... I found out

Chris Sykes (jcgs) wrote :

There is also an upstream Bug: https://bugs.kde.org/show_bug.cgi?id=264750

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.