"[: 227: =: unexpected operator" reported in ~/.xsession-errors

Bug #784241 reported by Peter Wu on 2011-05-17
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
kde-workspace (Ubuntu)
Low
Harald Sitter

Bug Description

Binary package hint: kdebase-workspace-bin

The startup script /usr/bin/startkde does not expect empty strings as first argument when checking for netbooks. Furthermore, the code puts two commands between backticks within an if-condition, namely `laptop-detect` and `grep -q Hidden=false ~/.config/autostart/plasma-netbook.desktop`, which is unnecessary since it only cares about the exit code. If this should suppress error messages, `2>/dev/null` should be used instead of backticks.

Installed version of kdebase-workspace-bin: 4.6.2a-0ubuntu5.1
Distro: Kubuntu 11.04 Natty 64b

Changed in kdebase-workspace (Ubuntu):
assignee: nobody → Harald Sitter (apachelogger)
importance: Undecided → Low
status: New → Confirmed
affects: kdebase-workspace (Ubuntu) → kde-workspace (Ubuntu)
Changed in kde-workspace (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde-workspace - 4:4.7.1-0ubuntu2

---------------
kde-workspace (4:4.7.1-0ubuntu2) oneiric; urgency=low

  [ Scott Kitterman ]
  * kde-window-manager-gles should provide kde-window-manager (will, among
    other things, allow kde-window-manager-gles to be installed without
    removing kubuntu-desktop) (LP: #848552)
  * Remove obsolete kdm recommends on kdebase

  [ Harald Sitter ]
  * Do not install kdewallpapers and kde-wallpapers when requesting default
    wallpaper installation. Only kde-wallpapers should be considered default
    as kdewallpapers is legacy wallpapers (now living in kdeartwork)
  * Fix warnings due to bogus shell code in the netbook detection (LP: #784241)

  [ Jonathan Kolberg ]
  * Include an upstream performance fix (kubuntu_125_fix_kwin.diff)

  [ Felix Geyer ]
  * kubuntu_52_gtk2_engines_oxygen_config.diff: use a more efficient way to
    check if packages are installed.
  * Replace kubuntu_11_fix_root_only_kcms.diff with
    kubuntu_krun_externalapps.diff and
    kubuntu_treat_uid_subst_as_externalapp.diff from upstream KDE/4.7 branch.
    This unbreaks systemsettings after launching root kcms.
 -- Felix Geyer <email address hidden> Thu, 15 Sep 2011 12:47:49 +0200

Changed in kde-workspace (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers