Ubuntu

Duplicate System Settings & System Monitor in Gnome/Unity

Reported by Jeremy Bicha on 2011-03-14
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
gnome-control-center (Ubuntu)
Low
Unassigned
kde-workspace (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: kdebase-workspace

With today's rename of gnome-control-center to "System Settings" (LP: #733234), Unity users who install Kubuntu will have a difficult time opening the Settings app from the Unity Dash as there will be two applications using the same icon and with the same System Settings name. See the attached screenshot. It is the second (out of 3 actually) icon that is the "real" gnome-control-center.

I believe the fix for this is to add a OnlyShowIn=KDE; line to systemsettings.desktop. This has the disadvantage of making it more difficult for Ubuntu users of KDE apps to configure KDE-wide configurations.

An alternative is to rename KDE's app as "KDE System Settings" or "Kubuntu System Settings".

This problem also exists for System Monitor except that the Gnome System Monitor is the first choice, not the second one.

ProblemType: BugDistroRelease: Ubuntu 11.04
Package: systemsettings 4:4.6.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
Uname: Linux 2.6.38-6-generic x86_64
Architecture: amd64
Date: Mon Mar 14 18:19:34 2011InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_GB.utf8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bashSourcePackage: kdebase-workspaceUpgradeStatus: Upgraded to natty on 2011-01-01 (72 days ago)

Jeremy Bicha (jbicha) wrote :
summary: - Hide KDE System Settings
+ Hide KDE System Settings in Ubuntu

Never mind, not a Ubuntu design bug. I'm working on getting this change into KDE directly.

Changed in ayatana-design:
status: New → Invalid
Changed in kdebase-workspace (Ubuntu):
assignee: nobody → Jeremy Bicha (jbicha)
status: New → In Progress
importance: Undecided → Low
Jeremy Bicha (jbicha) wrote :

Here's a current Gnome Shell screenshot.

Changed in kdebase-workspace (Ubuntu):
assignee: Jeremy Bicha (jbicha) → nobody
description: updated
Scott Kitterman (kitterman) wrote :
Changed in kdebase-workspace (Ubuntu):
status: In Progress → Invalid
Scott Kitterman (kitterman) wrote :

Also wrong package.

affects: kdebase-workspace (Ubuntu) → kde-workspace (Ubuntu)
Jeremy Bicha (jbicha) wrote :

Scott, I disagree that this bug is invalid. It is definitely a bug that there are two indistinguishable System Settings and two System Monitors if somebody happens to install kde-workspace to their Ubuntu install. The question is not whether this is a problem (the systemsettings maintainer sure thinks it is), but how to correct it.

My initial suggestion was to hide the KDE app in GNOME & Unity. This was in good faith because gnome-control-center has OnlyShowIn:Gnome, Unity. I however recognized when filing this bug that it would make it more challenging for user of KDE apps in Gnome to configure some settings. The systemsettings maintainer quite strongly believes that this suggestion is the wrong answer.

My other initial idea was to rename the KDE version slightly since Gnome is far more used than KDE by Ubuntu users. I don't think KDE users & devs would be thrilled with this decision but it could work.

A third option is to get Gnome to rename their app to something like "System Preferences". This is the same name Mac uses and supposedly Gnome is similar to OS X. It also has ties to Gnome 2 where the panel had System>Preferences and System>Administration. I think this is the best choice, but I'm not sure whether the gnome-control-center developers would agree.

Some other solutions: KDE would like to have the ability to extend Gnome's System Settings but Gnome is exercising very tight control over that so that won't happen. A different icon could be used for the Gnome or KDE version which is easy but would go against the freedesktop standardization. We could just tell people not to mix their desktops but that's a lousy idea too.

By the way, I was the one that brought this issue to KDE's attention several hours ago. I believe I did the right thing by talking to upstream (along with a patch for solution #1) instead of just trying to solve this for Ubuntu/Kubuntu alone.

Changed in kde-workspace (Ubuntu):
status: Invalid → New
summary: - Hide KDE System Settings in Ubuntu
+ Duplicate System Settings & System Monitor in Gnome/Unity
Scott Kitterman (kitterman) wrote :

I agree it's a bug in something. It is quite unfortunate that Gnome knowingly chose to stomp on a namespace that was already in use. The something that it is a bug in is not KDE. Please leave it as invalid for kde-workspace.

We've discussed this among the Kubuntu developers and I've discussed it with the Ubuntu release team. The place to fix this is not in KDE. If you believe this is incorrect, the place to resolve this conflict within Ubuntu is with the Ubuntu Technical Board.

I definitely agree that upstream is the right place to solve this and I appreciate you bringing it to the KDE systemsettings maintainer's attention. In the meantime, I'm not sure how best to solve this, but having Kubuntu introduce a divergence from upstream is not the way.

Changed in kde-workspace (Ubuntu):
status: New → Invalid
Harald Sitter (apachelogger) wrote :

Kubuntu maintains a very upstream friendly policy. Meaning if the systemsettings upstream maintainer is not cool with either of the changes proposed then they simply won't happen.

At any rate, from what I understand this is an issue created by a renaming of the gnome-control-center, which makes this very much an issue of GNOME and not the KDE workspace. From a KDE POV nothing changed, except that another source distributor decided it would be a good idea to use a well established and long standing name for their product without taking into account the resulting problems for the eco system at large. So as an upstream developer I see no reason for action on the KDE side of things but rather on the GNOME side.

FWIW the onlyshowin: kde option is fundamentally wrong because, as you already pointed out, it would remove all ability to configure KDE technology wide settings in a shell (you could run unity in an KDE software environment) that is not a KDE one. Now the reason this works for GNOME is because their entries are regular desktop files in the applications folder, thus listed in the menu. So even without gnome-control-center you could access the configuration apps for example via the Plasma start menu. KCMs on the other hand are in a KDE own folder and thus require systemsettings to be present.

Renaming System Settings to have some sort of prefix because GNOME wants to claim this name is, I hope, obviously wrong on so incredibly many levels that I'd not even want to start think about discussing that upstream, downstream, or sidestream.

Anyhow, this is not an issue limited to Kubuntu, so as per our bug triage policy [1] it needs to be tacked and addressed upstream. Also since the established importance is low there is no reason for tracking it here.

[1] https://wiki.kubuntu.org/Kubuntu/Specs/LucidBugTriagePolicy

Matthew Paul Thomas (mpt) wrote :

This bug report led to a lively discussion in desktop-devel-list@gnome and kde-core-devel@kde.

Shaun McCance proposed a clever solution:
http://mail.gnome.org/archives/desktop-devel-list/2011-July/msg00024.html

The KDE System Settings maintainer agreed to adopt that solution after KDE 4.7:
http://mail.gnome.org/archives/desktop-devel-list/2011-July/msg00040.html
Would we need to patch it in advance of KDE 4.7 to solve it for Ubuntu 11.10?

It would make sense to apply the equivalent change to gnome-control-center as well.

xapienz (xapienz) wrote :

Maybe rename KDE System Settings to Kontrol Center?

Shiki (shiki) wrote :

Easy. KDE had this app (name) first. So what's the question?
Gnome chooses a new name, done.

Matthew Paul Thomas (mpt) wrote :

The question is why you are proposing a different solution from the one already agreed by the upstream developers.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
dokc (darkokv) wrote :

The fact that we all use both GNOME and KDE Applications and we need to have setting for both of them. Maybe both can change the name to GNOME Settings and KDE Settings?

Jeremy Bicha (jbicha) wrote :

@mpt, yes, I'm rather surprised at all the attention this got now, months after Gnome 3 shipped.

gnome-control-center already has the OnlyShowIn:Gnome,Unity key set.

I think KDE will use shaunm's solution in KDE 4.7.1 which is plenty early enough to make it into Ubuntu 11.10. However, because it's a string change, a freeze exception will need to be requested and approved first.

The secondary issue is that this same problem affects gnome-system-monitor and ksysguard. Neither have an OnlyShowIn key set so those will need to be updated also.

Harald Sitter (apachelogger) wrote :

11.10 will ship with KDE 4.7.2, so no patching necessary.

komputes (komputes) on 2011-09-04
tags: added: ugjqc-11.09
Sebastien Bacher (seb128) wrote :

it's not really a GNOME bug

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers