udevd warnings during system startup: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device

Bug #673308 reported by HugoHirsch on 2010-11-10
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
kde-workspace (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: udev

Since having updated to 10.10 I do see lots of udevd warnings during bootup:

udevd[323]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /etc/udev/rules.d/45-libnjb5.rules:22

udevd[323]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /etc/udev/rules.d/025_logitechmouse.rules:21

For a complete list see attached /var/log/messages/boot.log

I'm not sure if these files are still needed in 10.10 since the system has had lots of ubuntu-upgrades. Maybe these files are remains of older versions?

If not so, configuration rules should be provided in correct formats.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: udev 162-2.1
ProcVersionSignature: Ubuntu 2.6.35-22.35-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
CheckboxSubmission: d7d9b16e9b357bb24336acc7d752d6c5
CheckboxSystem: edda5d4f616ca792bf437989cb597002
CustomUdevRuleFiles: 025_logitechmouse.rules 45-libmtp7.rules 65-libmtp.rules.dpkg-bak 45-libnjb5.rules
Date: Wed Nov 10 01:46:13 2010
MachineType: System Manufacturer System Name
ProcCmdLine: root=/dev/md0 ro vga=791 quiet splash
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=de_DE.utf8
 SHELL=/bin/bash
SourcePackage: udev
dmi.bios.date: 06/23/2005
dmi.bios.vendor: Award Software, Inc.
dmi.bios.version: ASUS A7V8X-X ACPI BIOS Revision 1014 Beta 002
dmi.board.name: A7V8X-X
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: REV 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 7
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAwardSoftware,Inc.:bvrASUSA7V8X-XACPIBIOSRevision1014Beta002:bd06/23/2005:svnSystemManufacturer:pnSystemName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnA7V8X-X:rvrREV1.xx:cvnChassisManufacture:ct7:cvrChassisVersion:
dmi.product.name: System Name
dmi.product.version: System Version
dmi.sys.vendor: System Manufacturer

HugoHirsch (ubuntubugs-aiki-it) wrote :
HugoHirsch (ubuntubugs-aiki-it) wrote :
HugoHirsch (ubuntubugs-aiki-it) wrote :

Attached rules that create above warnings.

Logitechmouse.rules is a symlink:
root@box:/etc/udev/rules.d# dlocate 025_logitechmouse.rules
root@box:/etc/udev/rules.d# dlocate ../logitechmouse.rules
kcontrol: /etc/udev/logitechmouse.rules

While libnjb.rules' original package is unknown
root@box:/etc/udev/rules.d# dlocate 45-libnjb5.rules

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in udev (Ubuntu):
status: New → Confirmed
Thomas Schweikle (tps) wrote :

-> #5: YOu didn't check against older releases of Ubuntu? Didn't you?

These files where installed with Ubuntu 8.04 and never removed, because removing them made keyboard and mouse unusable.
Maybe they belong to some outdated package never upgraded? --- for me it looks a lot like this being the case! But what package did they belong to??

Thomas Schweikle (tps) wrote :

And --- why did they stay without ever being changed? Looks like they got generated, but never registered belonging to a package.

Martin Pitt (pitti) wrote :

Ah, sorry, I missed comment 3.

affects: udev (Ubuntu) → kde-workspace (Ubuntu)
Changed in kde-workspace (Ubuntu):
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers