boot hangs on splash screen, does not show kdm

Bug #578732 reported by Leon Weber on 2010-05-11
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
kde-workspace (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: plymouth

On a machine running Kubuntu 10.04, I am experiencing the exact same problem as Bug #538524, which is marked as fixed, so I am reporting a new one.

During bootup, at the point when plymouth should stop and switch to kdm, kdm does not show up, but instead the splash screen stays there forever, only the blue/white dots stop blinking.

By SSHing into the machine, I was able to find out that the following processes are running:

root 1291 0.0 0.0 19188 1704 ? S 12:05 0:00 /bin/bash /etc/gdm/failsafeXServer
root 1396 0.0 0.0 15648 832 ? S 12:05 0:00 xinit /etc/gdm/failsafeXinit /etc/X11/xorg.conf.failsafe -- /usr/bin/X -br -once -config /etc/X11/xorg.conf.failsafe -logfile /var/log/Xorg.failsafe.log
root 1397 0.0 0.0 43472 2012 tty1 S<s+ 12:05 0:00 /usr/bin/X :0 -br -once -config /etc/X11/xorg.conf.failsafe -logfile /var/log/Xorg.failsafe.log
root 1207 0.0 0.0 28796 1212 ? Ss 12:05 0:00 kdm

Plymouth is not running anymore at this point.

Neither Xorg.0.log nor Xorg.failsafe.log contain any error message.

The plymouth version is 0.8.2-2ubuntu2, attached is the upstart plymouth.conf file.

Interestingly, the problem only occurs on every second or third boot, sometimes kdm shows up just fine.

Please let me know if you need any additional information.

Leon Weber (leonn) wrote :
Leon Weber (leonn) on 2010-05-11
description: updated
Steve Langasek (vorlon) on 2010-05-11
affects: plymouth (Ubuntu) → kdebase-workspace (Ubuntu)
Rolf Bensch (rolfbensch) wrote :

It seems that this (https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/459639/comments/53) solved both problems (1) X server starts randomly in failsafe when starting from cold boot and (2) boot hangs on splash screen.

Mark Fraser (launchpad-mfraz) wrote :

I'm seeing this too, it took 3 reboots to get a working computer this morning. In /var/log/syslog:
Sep 19 09:15:28 Rachael init: plymouth-stop pre-start process (2104) terminated with status 1
Sep 19 09:15:29 Rachael kernel: [ 25.284009] eth0: no IPv6 routers present
Sep 19 09:15:40 Rachael kdm[1188]: X server startup timeout, terminating
Sep 19 09:15:40 Rachael kdm[1188]: X server died during startup
Sep 19 09:15:40 Rachael kdm[1188]: Failed to start X server. Starting failsafe X server.

The first boot only showed this though:
Sep 19 09:14:24 Rachael init: plymouth-stop pre-start process (2126) terminated with status 1

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
affects: kdebase-workspace (Ubuntu) → xorg (Ubuntu)
Timo Aaltonen (tjaalton) wrote :

moving back to kde, seems like kdm doesn't interact correctly with plymouth.

Changed in kdebase-workspace (Ubuntu):
status: New → Confirmed
Timo Aaltonen (tjaalton) on 2011-10-03
affects: xorg (Ubuntu) → kdebase-workspace (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kde-workspace (Ubuntu):
status: New → Confirmed
affects: kdebase-workspace (Ubuntu) → kde-workspace (Ubuntu)
Changed in kde-workspace (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde-workspace - 4:4.9.95-0ubuntu1

---------------
kde-workspace (4:4.9.95-0ubuntu1) raring; urgency=low

  [ Jonathan Riddell ]
  * New upstream RC release

  [ Harald Sitter ]
  * Drop kubuntu_kdm_plymouth_transition.diff as discussed on the mailing
    list. Since we do not use KDM by default anymore and since the patch
    introduces issues that are not present with a vanilla KDM.
    LP: #886946, #578732, #553567
  * Update kdm.upstart script to quit-wait-sleep on plymouth regardless of
    the runlevel.

  [ Rohan Garg ]
  * Update install files
 -- Jonathan Riddell <email address hidden> Tue, 18 Dec 2012 23:22:32 +0000

Changed in kde-workspace (Ubuntu):
status: Confirmed → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/578732

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments