[trusty] Frequently no clean shutdown or reboot

Bug #1421429 reported by Bernhard on 2015-02-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
acpid (Ubuntu)
Undecided
Bernhard
kde-workspace (Ubuntu)
High
Bernhard
upstart (Ubuntu)
Undecided
Bernhard

Bug Description

Hello,

on all of my installations of Kubuntu 14.04.x (3 PCs), frequently on a shutdown or reboot the PC powers off or reboots without umounting the filesystems and terminating the processes.

There is no message like "Terminating or killing all processes within x seconds, umounting filesystems, etc", but immediately the shutdown (power off) or reboot of the system, all via KDE. => No clean shutdown.
(No network shares are mounted.)

Next boot the fsck is recovering the filesystem/journal, etc

This behaviour occurred after the upgrade from 12.04.x to 14.04.x , this was not in 12.04.

Maybe it is a bug in upstart/systemd init scripts at reboot/shutdown.

- Reproducible with:
Download the iso image kubuntu-14.04.2-desktop-amd64.iso and install it, for instance as a Virtual Machine.

There logon in KDE and use the keyboard shortcut "ctl+alt+shift+pageup" (=Reboot) to reboot the machine several times until you can see that on the reboot/shutdown process there is no clean reboot, but an immediate reboot.

On the next boot you will see that fsck is recovering the journal (inodes cleared/recovered), etc.

Thank you for your support!

Best regards, Bernhard

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: upstart 1.12.1-0ubuntu4.2
ProcVersionSignature: Ubuntu 3.16.0-31.41~14.04.1-generic 3.16.7-ckt5
Uname: Linux 3.16.0-31-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.6
Architecture: amd64
CurrentDesktop: KDE
Date: Thu Feb 12 22:40:45 2015
EcryptfsInUse: Yes
InstallationDate: Installed on 2010-06-02 (1716 days ago)
InstallationMedia: Kubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100427)
SourcePackage: upstart
UpgradeStatus: Upgraded to trusty on 2015-01-18 (25 days ago)
UpstartBugCategory: Session
UpstartRunningSessionCount: 1
UpstartRunningSessionVersion: init (upstart 1.12.1)
UpstartRunningSystemVersion: init (upstart 1.12.1)

Bernhard (baumber) wrote :
Bernhard (baumber) wrote :

And there are no error messages in the logs (syslog and upstart logs).

Bernhard (baumber) on 2015-02-13
summary: - [trusty] Occasionally no clean shutdown or reboot
+ [trusty] Frequently no clean shutdown or reboot
description: updated
Bernhard (baumber) wrote :

The unclean shutdown/reboot is more often now, because I use the nouveau driver instead of the nvidia driver.
But the nouveau driver does not support hibernate (suspend to disk) with my graphics card, so I have to shutdown/reboot normally.

Bernhard (baumber) wrote :

Frequency ~ every 5 - 10th shutdown/reboot

Bernhard (baumber) wrote :

I have tested this also with a fresh installation of 14.04

Bernhard (baumber) on 2015-02-21
description: updated
Bernhard (baumber) on 2015-02-21
tags: added: regression-release
removed: third-party-packages
tags: added: systemd upstart
tags: added: precise2trusty
Martin Pitt (pitti) on 2015-02-23
no longer affects: systemd (Ubuntu)
tags: added: kubuntu
Changed in kde-workspace (Ubuntu):
importance: Undecided → High
Bernhard (baumber) wrote :

The problem did not occur anymore, so I set this bug report to fixed.
I don't know, which updates have solved this problem, but there were many updates regarding systemd, upstart, kernel updates, udev, etc .

Changed in kde-workspace (Ubuntu):
status: New → Fix Released
Changed in upstart (Ubuntu):
status: New → Fix Released
Changed in acpid (Ubuntu):
status: New → Fix Released
Changed in upstart (Ubuntu):
assignee: nobody → Bernhard (baumber)
Changed in kde-workspace (Ubuntu):
assignee: nobody → Bernhard (baumber)
Changed in acpid (Ubuntu):
assignee: nobody → Bernhard (baumber)
Bernhard (baumber) wrote :

Unfortunately the problem is not gone completely , only not so frequent.

Changed in acpid (Ubuntu):
status: Fix Released → Confirmed
Changed in kde-workspace (Ubuntu):
status: Fix Released → Confirmed
Changed in upstart (Ubuntu):
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers