KDE freezes when clicking start menu

Bug #1335678 reported by Jan W on 2014-06-29
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
kde-workspace (Ubuntu)
Undecided
Unassigned

Bug Description

Normally, when I press the KDE start menu using the mouse cursor, I expect the launcher menu to pop up. However, sometimes all the graphics freeze. I am able to move the mouse cursor, but nothing responds to left or right click input from the mouse. Only a restart of the Xorg server (ctrl-alt-backspace) recovers the situation, after which I am able to continue using the computer.
The occurrences of this freeze are not very regular. Sometimes it happens 3-4 times a week, sometimes it does not happen for a month. I'm currently using kubuntu 14.04, but I have seen this happen on earlier kubuntu releases. It is not reliably reproducible as far as I can see. However, it always occurs when I want to open the start menu.
As said, when the graphics freeze, the mouse cursor is still able to move. I'm also able to switch to another terminal (e.g. tty4) for a command line login.
I'm using the proprietary nvidia drivers. The desktop effects are disabled.

I cannot find anything in the logs that I've checked. I have attached a Xorg log that was running during the freeze, and finishes with the restart of the x server. The only line that stood out to me was:
[2526140.102] setversion 1.4 failed: Permission denied
This happens just around the time that the freeze occured. Googling for this message did not help me any further

Around the time of freeze, dmesg shows:
[2523802.675887] audit_printk_skb: 6 callbacks suppressed
[2524530.823516] audit_printk_skb: 9 callbacks suppressed
[2526426.394799] init: tty4 main process ended, respawning
Restart of the server is at 2526426, the freeze occured about 3-4 minutes earlier.

I don't know which other logs or settings to check.

Further information:
-Hardware: Dell C521, AMD Athlon 64 X2, 3 GB RAM, Nvidia Geforce 9500GT
-I'm using Ubuntu 14.04 LTS
-Version of kde-workspace is 4:4.11.9-0ubuntu0.2
-Version of the nvidia drivers is 331.38

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: kde-window-manager 4:4.11.9-0ubuntu0.2
ProcVersionSignature: Ubuntu 3.13.0-27.50-generic 3.13.11
Uname: Linux 3.13.0-27-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
CurrentDesktop: KDE
Date: Sun Jun 29 21:34:19 2014
InstallationDate: Installed on 2010-05-08 (1513 days ago)
InstallationMedia: Kubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100427)
SourcePackage: kde-workspace
UpgradeStatus: Upgraded to trusty on 2014-05-31 (29 days ago)

Jan W (ubuntu-kiekerjan) wrote :
tags: added: kde nvidia
Jan W (ubuntu-kiekerjan) on 2014-06-30
description: updated
Jan W (ubuntu-kiekerjan) wrote :

It just happened again. What might be of interest is that I was playing a video (using VLC media player) at the time. Besides the mouse cursor moving, the movie also remained in motion, including the sound. I could still watch the movie, but no mouse or keyboard controls had any control over the UI anymore.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kde-workspace (Ubuntu):
status: New → Confirmed
Ludek (lusmo) wrote :

Same here. I want to use KDE for presentation mode, but I can not. Ubuntu 14.04 64 bit. Same on all my computers :-(

Jan W (ubuntu-kiekerjan) wrote :

Actually, I was just thinking last week that I should update this bug report. Since I've updated to 14.10 I have no longer experienced the bug. I just tried triggering it, and the freeze did not occur. It seems to me that somewhere in the 14.10 release it has been fixed.
@Ludek, can you try 14.10? It would be good to see if it is solved for you as well in that release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers