Dead keys stop working fine in KDE apps after navigating through menu bar

Bug #1167455 reported by Jorge Rodríguez López on 2013-04-10
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
kde-workspace (Ubuntu)
Undecided
Unassigned

Bug Description

Accented letters (dead keys) stop working fine in KDE apps after navigating through menu bar's.

When typing in the text area of KDE applications, the keyboard (with dead keys) work fine, but if you access the (classic) menu bar in the application window, dead keys may stop working fine.

e.g. with English (US, international with dead keys) keyboard layout
  Press key "´" and "A", expected output= "á"
  output with ibus= "" (nothing)
  output with xim= "´a" (Dead keys are alive)

Exceptions:

- With widget Window Menubar no problem.
- In Rekonk, with menu system like Chrome, no problem.

Steps to follow:

In KDE desktop...

1º Check that you are using a keyboard layout with dead keys, if not, install and use one.
    System Settings > Input devices > keyboard > Layout > Configure layouts
    e.g. English (US, international with dead keys)

2º Open a kde app, (e.g. kate)

3º Write something to check that dead keys work well.
    In English, e.g. press "´" and "A" results in "á"

4º Access of the menu bar in the application window and scroll through the options.
Click "File" menu.
Scan down the File menu.
Scan up back to "File" nenu.
Move to "Edit" menu.
Scan down "Edit" menu.
and leave the menu on the side.
click in the text area.

http://i.imgur.com/sGUDyiC.png

5º Write something to check that dead keys work well.
    In English, e.g. press "´" and "A" results in "á"

6º If dead keys fail, change the focus (e.g. another window) and return to kate, dead keys work again.

Testing:

Tested in different computers.
Tested in Debian, kubuntu (13.04, 12.10, 12.04), OpenSuse.
Tested with desktop effects enabled and disabled
Tested in Kate, Dolphin, Kontact, Amarok, Agregator...
Tested in KDE 4.10, 4.9, 4.8 and... 4.4.5
Tested with free and privative drivers
Tested with Spanish, Portuguese and English keyboard layouts
Tested in installed system and live-cd.
Tested navigating menus with mouse and keyboard
Tested with IBus and XIM input method

Comment:

If this bug is not resolved, please, the Kubuntu 13.04 release with widget Window Menubar be default.
I apologize for my English.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: plasma-desktop 4:4.10.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-17.27-generic 3.8.6
Uname: Linux 3.8.0-17-generic x86_64
ApportVersion: 2.9.2-0ubuntu5
Architecture: amd64
Date: Wed Apr 10 18:59:45 2013
ExecutablePath: /usr/bin/plasma-desktop
InstallationDate: Installed on 2013-04-03 (6 days ago)
InstallationMedia: Kubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130402.1)
MarkForUpload: True
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
SourcePackage: kde-workspace
UpgradeStatus: No upgrade log present (probably fresh install)

tags: added: accents dead keyboard keys menubar
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kde-workspace (Ubuntu):
status: New → Confirmed
YAFU (yafu) wrote :

I can reproduce this bug, for example in Kate (KDE 4.10.2 - Kubuntu 13.04 64 bits)

This is the report by Jorge in KDE:
https://bugs.kde.org/show_bug.cgi?id=318151

description: updated

Another way (with keyboard) to cause the failure.

1- Open Kate editor
2- write something to check that dead keys work
3- Press alt+F (to open File menu)
4- Press right arrow key (to open Edit menu)
5- Press esc (to closse menu)
6- write something to check that dead keys work

tags: added: kde kubuntu
removed: apport-bug

I had the same problem on Kubuntu 14.04.

Installing scim and removing ibus seemed to fix it. Still testing.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.