Kubuntu 12.04 doesn't logout/reboot/shutdown

Bug #1000690 reported by estolle on 2012-05-17
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
kde-workspace (Ubuntu)
Undecided
Unassigned

Bug Description

I did a fresh install of Kubuntu 12.04 on my computer (having had a smoothly running 11.10 before). I have two user accounts. Accidentally, with one I added a second default panel (New Activity - Add Panel - Default Panel) which appeared on the top of the screen.

I immediately removed it clicking with the right mouse button on the panel (Remove this Task Manager - Remove this Panel).

From then on, I can't logout, reboot or shutdown the system using the Leave menu button. Lock and Switch user works. However, sudo shutdown -r now etc.on cli works as well. The other user account is not affected.

Reinstalling a new default panel doesn't help.

Thanks for your comments.

affects: ubuntu → kde-workspace (Ubuntu)
Pelle ten Cate (pelleke) wrote :

I am having exactly the same issue, although it doesn't seem to be related to any panel-stuff in my case. It appeared yesterday, probably after installing updates from the last two weeks.

When attempting to shut down, nothing appears in /var/log/syslog, and no new output is added to dmesg.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kde-workspace (Ubuntu):
status: New → Confirmed
Elmar Roberg (roberg) wrote :

I too have this problem.

When using <kdesudo halt> it shuts down, takes me the grey panel, the dots change until the last one is highlighted, but the machine does not switch off. I then have to hold down the power off hard button to switch off.

This problem seems to come and go. This time I cannot find a solution to it.

summary: - Kubuntu 12.04 doesn't logout/reboot/shutdown after accidentally adding
- new default panel
+ Kubuntu 12.04 doesn't logout/reboot/shutdown
Harald Sitter (apachelogger) wrote :

Please run kdebugdialog and tick everything, then reboot, then try to trigger the issue and attach the file .xsession-errors from your home directory to this report.
Also useful logs:
/var/log/kdm.log
/var/logl/Xorg.0.log

If your session remains fully functional after trying to shutdown/reboot/logout you can simply do that, if not you'll have to switch to a virtual terminal ALT-shift-f1 and copy the files somewhere while your session is stuck trying to shutdown. Point being that the logs get overwritten once you start a new session.

Also a note on comment #3: quite literally you cannot/should not expect halt to do anything more than halt the system (i.e. stop the CPU from doing anything). What you probably want to use is shutdown, which brings down the OS and then stops power supply. for convenience/safety reasons halt also brings down the OS first but it will not actually stop the power supply. halt very much directly relates to the fact that most CPUs have a dedicated instruction to stop them from doing anything, that instruction is mostly called halt (or a shorter version of it like 'hlt'), and that is actually what is called at the end of the program called 'halt'. Strictly speaking not every computer can actually shutdown and/or reboot as those features depend on additional low-level magic such as ACPI to allow power management control and consequently allow software to tell the computer to shut down power supply or shut it down and then fire it up again. With that in mind you almost never want to use halt but shutdown (even though just about all linux/bsd/whatever versions will have halt either do exactly what shutdown does or what you experience on Ubuntu - a OS shutdown combined with halting the CPU).

Changed in kde-workspace (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for kde-workspace (Ubuntu) because there has been no activity for 60 days.]

Changed in kde-workspace (Ubuntu):
status: Incomplete → Expired
Changed in kde-workspace (Ubuntu):
status: Expired → Confirmed
Harald Sitter (apachelogger) wrote :

Data requested still not present.

Changed in kde-workspace (Ubuntu):
status: Confirmed → Invalid

Good morning!

I'm very sorry but I can't deliver any data anymore because I'm already
with kubuntu 12.10.

Cheers.

On 01/09/2013 11:46 AM, Harald Sitter wrote:
> Data requested still not present.
>
> ** Changed in: kde-workspace (Ubuntu)
> Status: Confirmed => Invalid
>

Risto H. Kurppa (risto.kurppa) wrote :

Will provide requested debug info on next message.

Changed in kde-workspace (Ubuntu):
status: Invalid → Confirmed
Risto H. Kurppa (risto.kurppa) wrote :

Distributor ID: Ubuntu
Description: Ubuntu 12.04.3 LTS
Release: 12.04
Codename: precise

2 users.

Debug enabled in kdedebugdialog, rebooted.

Can't log out, can't shut down.

Attached is the .xsession-errors.

From what I understand, these are the interesting parts:

kded(2089)/khotkeys KHotKeys::Gesture::grab_mouse: Gesture ungrab
plasma-desktop(2277)/plasma Kickoff::UrlItemLauncher::Private::openUrl: Opening item with URL "leave:/logoutonly"
kwin(2269) KWin::Workspace::updateClientArea: screens: 1 desktops: 2
kwin(2269) KWin::Workspace::updateClientArea: Done.

kded(2089)/khotkeys KHotKeys::Gesture::grab_mouse: false
kded(2089)/khotkeys KHotKeys::Gesture::grab_mouse: Gesture ungrab
plasma-desktop(2277)/plasma Kickoff::UrlItemLauncher::Private::openUrl: Opening item with URL "leave:/shutdown"
kwin(2269) KWin::Workspace::updateClientArea: screens: 1 desktops: 2
kwin(2269) KWin::Workspace::updateClientArea: Done.
kded(2089)/khotkeys KHotKeys::Gesture::update_grab: Enabled: false
knotify(2274) KNotify::event: 69 ref= 0
kded(2089)/khotkeys KHotKeys::Gesture::update_grab: Handler: 0

Risto H. Kurppa (risto.kurppa) wrote :

kdm.log

Risto H. Kurppa (risto.kurppa) wrote :
Risto H. Kurppa (risto.kurppa) wrote :

Also
qdbus org.kde.ksmserver /KSMServer org.kde.KSMServerInterface.logout -1 -1 -1
does nothing. No new lines to .xsession-errors.

Florido Paganelli (bjaast) wrote :

Having the same problem with Ubuntu 12.04.4 and kde-standard package installed. User switching works, lock screen works but nothing happens on logout.

sleep works.

Logout, restart, shutdown do not work.

Can it simply be that some dependency is missing in the kde-standard package? I didn't try the kde-full package though.

Using opensource drivers for the videocard (NVIDIA GT218 (GeForce 210)).

 Unity and gnome can logout/restart/shutdown without problems.

Rohan Garg (rohangarg) wrote :

Subscribing Harald since he clearly forgot to follow up.

I'm having this problem with Kubuntu 14.04. It only happens sometimes. Other times when clicking the log out button it works fine.

ruoxi (rjiang) wrote :

Have the same problem with Ubuntu 12.04.4 with kde-full installed.
Logout doesn't work, shutdown dosen't work, reboot doesn't work.
Had ubuntu 12.04.2(?) before on a different computer, all of the above works fine.
Do you guys still need logs?

axel (axel334) wrote :

I have this bug after upgrading from Kubuntu 12.04 to 14.04. If you need logs let me know how to collect them. I removed ksmserverrc but this didn't help.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers