Ubuntu

Improve organization of KDE System Settings

Reported by Frank Siegert on 2006-01-25
8
Affects Status Importance Assigned to Milestone
kde-systemsettings (Ubuntu)
Wishlist
Kubuntu Bugs

Bug Description

I like seeing KDE's messy kcontrol being reorganized in Kubuntu (I hope it can serve as playground for upstream improvements).

Here are some IMHO further improvements:

(0. It should start and stay at a size (maximized?), instead of jumping size for each module; and finally get rid of the known too-big-for-screen and scrollbar-missing problems)

1. Personal::Sound & Multimedia should be placed in Hardware instead of Personal.

2. Personal::Panel and Personal::Desktop are in a sense sub-items to Personal::Appearance. I believe their options should be merged into that, otherwise you never know where to look for a specific appearance setting.

3. Internet & Network::Network Settings asks, which distribution we use... should be obvious, shouldn't it? ;-)

4. System Administration::Regional & Accessibility belongs to Personal in my opinion.

5. There is a point System Administration::Display and a point Hardware::Display, which should be merged into Hardware::Display, should they not?

I know that it might be a little too much to ask of Kubuntu to fix all these shortcomings of KDE's kcontrol, but since you started... ;-)

assigning to kubuntu bugs, changing to wishlist

Changed in kde-systemsettings:
assignee: nobody → kubuntu-team
sebas (sebasje) wrote :

The System Administration::Display one should actually move to Hardware, and the Hardware one should go away. The latter is the 'old' module which is replaced by guidance's displayconfig (which is System Administration::Display). The latter replaces all of the old one's functionality and adds interesting features such as setting up the driver, the hardware and even basic support for dual head configuration. The old module is also unsupported, while displayconfig is actively being developed.

Anthony Mercatante (tonio) wrote :
Changed in kde-systemsettings:
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers