Kubuntu missing someKDE API 4.6 include files

Bug #928009 reported by Happy on 2012-02-07
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
KDE Base Runtime
New
Medium
kde-runtime (Ubuntu)
Low
Philip Muškovac

Bug Description

Specifically, Kubuntu seems to be missing some /usr/include/nepomuk files.

I'm using Kubuntu (KDE 4.8, based on Kubuntu Oneiric with Kubuntu PPAs added - apt sources.list attached)
I have what I think are all the relevant development packages installed (kdelibs5-dev, kdesdk, etc)

When trying to compile code to use Nepomuk queries, I get this error:
  fatal error: nepomuk/simpleresource.h: No such file or directory

'simpleresource.h' is part of the KDE API as at version 4.6 as can be seen here:
  http://api.kde.org/4.6-api/kdebase-runtime-apidocs/nepomuk/html/simpleresource_8h.html

Example code that uses this KDE API would be such as:
  http://trueg.wordpress.com/2012/01/28/something-way-less-dry-tv-shows/

This would seem to be a packaging bug?

Apt sources.list (with irrelevant stuff removed)

deb http://au.archive.ubuntu.com/ubuntu/ oneiric main restricted
deb-src http://au.archive.ubuntu.com/ubuntu/ oneiric main restricted

deb http://au.archive.ubuntu.com/ubuntu/ oneiric-updates main restricted
deb-src http://au.archive.ubuntu.com/ubuntu/ oneiric-updates main restricted

deb http://au.archive.ubuntu.com/ubuntu/ oneiric universe
deb-src http://au.archive.ubuntu.com/ubuntu/ oneiric universe
deb http://au.archive.ubuntu.com/ubuntu/ oneiric-updates universe
deb-src http://au.archive.ubuntu.com/ubuntu/ oneiric-updates universe

deb http://au.archive.ubuntu.com/ubuntu/ oneiric multiverse
deb-src http://au.archive.ubuntu.com/ubuntu/ oneiric multiverse
deb http://au.archive.ubuntu.com/ubuntu/ oneiric-updates multiverse
deb-src http://au.archive.ubuntu.com/ubuntu/ oneiric-updates multiverse

deb http://au.archive.ubuntu.com/ubuntu/ oneiric-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu oneiric-security main restricted
deb-src http://security.ubuntu.com/ubuntu oneiric-security main restricted
deb http://security.ubuntu.com/ubuntu oneiric-security universe
deb-src http://security.ubuntu.com/ubuntu oneiric-security universe
deb http://security.ubuntu.com/ubuntu oneiric-security multiverse
deb-src http://security.ubuntu.com/ubuntu oneiric-security multiverse

deb http://archive.canonical.com/ubuntu oneiric partner

deb http://extras.ubuntu.com/ubuntu oneiric main
deb http://au.archive.ubuntu.com/ubuntu/ oneiric-proposed restricted main multiverse universe
deb-src http://extras.ubuntu.com/ubuntu oneiric main

deb-src http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu oneiric main # disabled on upgrade to oneiric

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kubuntu-meta (Ubuntu):
status: New → Confirmed
Jonathan Thomas (echidnaman) wrote :

Those headers/that library are not part of any public Nepomuk API. The Nepomuk build itself doesn't install the files at all, so it's not a packaging issue.

affects: kubuntu-meta (Ubuntu) → kdebase-runtime (Ubuntu)
Changed in kdebase-runtime (Ubuntu):
status: Confirmed → Invalid
Happy (happy-heyoka) wrote :

Well, to quote one of the authors of Nepomuk (see http://trueg.wordpress.com/2012/01/28/something-way-less-dry-tv-shows/)

Sebastian Trüg on February 5, 2012 at 12:18 said:

These headers were introduced in KDE 4.7 and were always a part of kde-runtime due to the freeze of kdelibs. They are also part of nepomuk-core but installing that along-side kdelibs is a bit ugly at the moment.

Philip Muškovac (yofel) wrote :

Acknowledged, I'll add a kde-runtime-dev package that ships them.

affects: kdebase-runtime (Ubuntu) → kde-runtime (Ubuntu)
Changed in kde-runtime (Ubuntu):
assignee: nobody → Philip Muškovac (yofel)
importance: Undecided → Low
status: Invalid → In Progress
Philip Muškovac (yofel) wrote :

Turns out nepomuk is horrible at library management, needs more discussion.

Changed in kde-runtime (Ubuntu):
assignee: Philip Muškovac (yofel) → nobody
status: In Progress → Triaged
Changed in kde-runtime:
importance: Unknown → Medium
status: Unknown → New
Philip Muškovac (yofel) wrote :

The library version management was fixed, but it seems only for 4.8.2.

Changed in kde-runtime (Ubuntu):
assignee: nobody → Philip Muškovac (yofel)
Philip Muškovac (yofel) wrote :

This just barely made it into 4.8.1 after all.

Changed in kde-runtime (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde-runtime - 4:4.8.1-0ubuntu1

---------------
kde-runtime (4:4.8.1-0ubuntu1) precise; urgency=low

  [ Philip Muskovac ]
  * New upstream release
  * Add a kde-runtime-dev package with the nepomuk headers
    (LP: #928009, #947498)
  * Add separate packages for libnepomukdatamanagement4 and libnepomuksync4
    and add symbol files
  * libnepomuksync4 breaks/replaces kde-runtime << 4:4.8.1~
  * kde-runtime-dev breaks/replaces kde-runtime << 4:4.8.1~
  * Refresh kde-runtime-data.install

  [ Felix Geyer ]
  * Drop broken /usr/bin/trash4 symlink.
  * Switch kde-runtime-dev to arch:any and make it depend on libnepomuksync4 and
    libnepomukdatamanagement4 instead of kde-runtime.
  * Move /usr/bin/nepomuk-simpleresource-rcgen from kde-runtime to
    kde-runtime-dev and add appropriate dependencies to kde-runtime-dev.
  * kde-runtime: drop unused lintian override shlib-without-versioned-soname
    libnepomukdatamanagement.so.
 -- Felix Geyer <email address hidden> Wed, 07 Mar 2012 17:38:39 +0100

Changed in kde-runtime (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.