Dolphin doesn't store samba share password

Bug #1071453 reported by Pascal Korz on 2012-10-25
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
KDE Base Runtime
Fix Released
Medium
kde-runtime (Ubuntu)
High
Unassigned
Precise
High
Unassigned
Quantal
Undecided
Unassigned
Raring
High
Unassigned

Bug Description

When connecting to a Samba server and checking the option to remember the password, the password won't actually be stored after accepting the dialog.

This bug has recently been fixed by Gordian Klein for KDE SC 4.9.3. The patch consists of merely four lines of code and can be found here: https://projects.kde.org/projects/kde/kde-runtime/repository/diff?rev=177ce2a7b5b69c1f9ef1355d1d158cacb60cd555&type=sbs

Would it be possible to apply this patch and update the package for Kubuntu 12.04 (KDE SC 4.8.5)?

The corresponding bug report at the KDE bugtracker: https://bugs.kde.org/show_bug.cgi?id=295906

User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.21 (KHTML, like Gecko) Chrome/19.0.1046.0 Safari/535.21 SUSE/19.0.1046.0
Build Identifier:

Every time I log into KDE and enter my Samba server, Dolphin asks for smb password, altough I always check the box for it to remember the password.

Reproducible: Always

Steps to Reproduce:
1. Log into KDE
2. Start Dolphin
3. Go to some smb:/ server
4. When logging in, check the "Remember password" box
5. Log out of KDE
6. Perform steps 1-3
Actual Results:
Logging in dialog is prompted

Expected Results:
Username and password should be taken as the ones having been saved

I can verify that the same problem exists on my system with KDE 4.8.5.

It also happens in 4.9.0.

Same problem here with the 4.9.1 release, running on gentoo.
I noticed that the password is not stored on kwallet which is already unlocked
(and used successfully by other applications).

I have the same problem on 4.9.2 with Kubuntu.
Always when opening Dolphin and browsing to an SMB share, it is asked for username and password, even if I check thie "Remember" checkbox. This is extremly annoying - I am not playing with KDE, I use it in my business for work. As I see there are tickets for this problem since 2004!!

I would be really happy if somebody could fix this issue.
Thanks!

*** Bug 293158 has been marked as a duplicate of this bug. ***

*** Bug 271018 has been marked as a duplicate of this bug. ***

Git commit 9c0021e98c0c6a808ffa82449d355a64ecef4552 by Dawit Alemayehu.
Committed on 18/10/2012 at 02:40.
Pushed by adawit into branch 'KDE/4.9'.

Store passwords in wallet when the "Remember password" checkbox is checked in
the authorization dialog.

Patch by Gordian Klein.
FIXED-IN:4.9.3
REVIEW:106909
CCMAIL:<email address hidden>

M +7 -0 kioslave/smb/kio_smb_auth.cpp

http://commits.kde.org/kde-runtime/9c0021e98c0c6a808ffa82449d355a64ecef4552

Git commit 177ce2a7b5b69c1f9ef1355d1d158cacb60cd555 by Dawit Alemayehu.
Committed on 18/10/2012 at 02:40.
Pushed by adawit into branch 'master'.

Store passwords in wallet when the "Remember password" checkbox is checked in
the authorization dialog.

Patch by Gordian Klein.
FIXED-IN:4.9.3
REVIEW:106909
CCMAIL:<email address hidden>
(cherry picked from commit 9c0021e98c0c6a808ffa82449d355a64ecef4552)

M +7 -0 kioslave/smb/kio_smb_auth.cpp

http://commits.kde.org/kde-runtime/177ce2a7b5b69c1f9ef1355d1d158cacb60cd555

Thanks for fixing the issue Dawit :)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kde-runtime (Ubuntu):
status: New → Confirmed
Rohan Garg (rohangarg) on 2012-10-25
Changed in kde-runtime (Ubuntu):
assignee: nobody → Rohan Garg (rohangarg)
importance: Undecided → High
milestone: none → ubuntu-12.04.2
status: Confirmed → In Progress
Changed in kde-runtime:
importance: Unknown → Medium
status: Unknown → Fix Released
Rohan Garg (rohangarg) wrote :

Package uploaded to https://launchpad.net/~rohangarg/+archive/kde-extra

Please test before I upload to -proposed

Changed in kde-runtime (Ubuntu Raring):
milestone: ubuntu-12.04.2 → none
Changed in kde-runtime (Ubuntu Precise):
milestone: none → ubuntu-12.04.2
Changed in kde-runtime (Ubuntu Quantal):
assignee: nobody → Rohan Garg (rohangarg)
Changed in kde-runtime (Ubuntu Precise):
assignee: nobody → Rohan Garg (rohangarg)
status: New → In Progress
importance: Undecided → High
assignee: Rohan Garg (rohangarg) → nobody

*** Bug 309488 has been marked as a duplicate of this bug. ***

Rohan Garg (rohangarg) wrote :

Ping? Would be nice to get some testing before I completely forget about this :)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kde-runtime (Ubuntu Quantal):
status: New → Confirmed
Rohan Garg (rohangarg) wrote :

Quantal and Raring already have the fix, precise package still needs testing. Any takers?

Changed in kde-runtime (Ubuntu Quantal):
status: Confirmed → Fix Released
Changed in kde-runtime (Ubuntu Raring):
status: In Progress → Fix Released
Changed in kde-runtime (Ubuntu Quantal):
assignee: Rohan Garg (rohangarg) → nobody
Changed in kde-runtime (Ubuntu Raring):
assignee: Rohan Garg (rohangarg) → nobody
Colin Watson (cjwatson) on 2013-02-13
Changed in kde-runtime (Ubuntu Precise):
milestone: ubuntu-12.04.2 → ubuntu-12.04.3

*** Bug 91749 has been marked as a duplicate of this bug. ***

*** Bug 101307 has been marked as a duplicate of this bug. ***

sn0b (sn0b-wanderer) wrote :

@Rohan Garg (rohangarg) if you still need testers for 12.04, I could do it. Just tell me what to do :-)

Hello Pascal, or anyone else affected,

Accepted kde-runtime into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/kde-runtime/4:4.8.5-0ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in kde-runtime (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
David Dimovski (q-david-r) wrote :

Tested on my Kubuntu 12.04.3 64Bit with KDE 4.8.5 and Dolphin 2.1 with activated kwallet. It's working like s charm!

My test scenario:
1.) Packages has been installed from the build of Jonathan. I was using the amd64 packages.
2.) Opened Dolphin and clicked on my samba entry. Kwallet was asking for a password then the dolphin window for password appeared. So I typed my credentials and checked the remember password box.
3.) I closed kwallet and repeated Step 2. This time the dolhin window for password appeared with my saved credentials so I just have to click ok.
4.) Restart computer, result the same as Step 3.

No other problems/issues where find till yet.

Jonathan Riddell (jr) on 2013-11-14
tags: added: verification-done
removed: verification-needed
David Dimovski (q-david-r) wrote :

Tested with precise-proposed repository.

Only got problem with kde-runtime-dbg:
kde-runtime-dbg : Depends: kdelibs5-dbg but it is not going to be installed

After skipping the kde-runtime-dbg package, everything works fine. All tests were made like in my post #22.

Jonathan Riddell (jr) wrote :

kde-runtime-dbg from precise-proposed installs fine for me in a chroot

David can you confirm that the behaviour is fixed using the packages from precise-proposed?

Jonathan Riddell (jr) wrote :

David says "everything works fine"

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde-runtime - 4:4.8.5-0ubuntu0.2

---------------
kde-runtime (4:4.8.5-0ubuntu0.2) precise; urgency=low

  * Add kubuntu_samba_password.diff from upstream fix LP: #1071453
    Dolphin doesn't store samba share password
 -- Jonathan Riddell <email address hidden> Mon, 11 Nov 2013 09:32:03 +0000

Changed in kde-runtime (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.