kde l10n packages depend on libkdecore5 which doesn't exist

Bug #696675 reported by dmuir on 2011-01-03
90
This bug affects 17 people
Affects Status Importance Assigned to Milestone
kde-l10n-engb (Ubuntu)
High
Unassigned
Lucid
High
Unassigned

Bug Description

Binary package hint: kde-l10n-engb

Just upgraded to Lucid and I'm getting errors with the kde l10n packages.
eg:
kde-l10n-engb:
 Depends: libkdecore5 (>=4:4.5.0) but it is not installable

I searched for libkdecore5 in synaptic, but finds nothing.
I have main, universe, restricted, and multiverse checked, as well as all the update channels (proposed, etc).

It seems that this is the case with all kde l10n packages.

Related branches

I can confirm that this problem exists for at least these packages:

- kde-l10n-de (4.4.2-0ubuntu6 => 4.4.5-0ubuntu1~lucid1)
- kde-l10n-engb (4.4.2-0ubuntu6 => 4.4.5-0ubuntu1~lucid1)
- kde-l10n-fr (4.4.2-0ubuntu6 => 4.4.5-0ubuntu1~lucid1)
- kde-l10n-ja (4.4.2-0ubuntu6 => 4.4.5-0ubuntu1~lucid1)
- kde-l10n-nl (4.4.2-0ubuntu6 => 4.4.5-0ubuntu1~lucid1)
- kde-l10n-ru (4.4.2-0ubuntu6 => 4.4.5-0ubuntu1~lucid1)
- kde-l10n-zhcn (4.4.2-0ubuntu6 => 4.4.5-0ubuntu1~lucid1)
- kde-l10n-zhtw (4.4.2-0ubuntu6 => 4.4.5-0ubuntu1~lucid1)

pelm (pelle-ekh) wrote :

Confirm same problem for:

kde-l10n-sv 4.4.2-0ubuntu7 => 4.4.5-0ubuntu1~lucid1

Alberto (albertop) wrote :

I can confirm that version 4:4.4.5-0ubuntu1~lucid1 depends upon libkdecore5, that in turn in not available, breaking "kde-l10n-engb" and "kde-l10n-it".

----- 8< -----
$ cat /etc/apt/sources.list
deb http://it.archive.ubuntu.com/ubuntu/ lucid main restricted universe multiverse
#deb-src http://it.archive.ubuntu.com/ubuntu/ lucid main restricted universe multiverse

deb http://it.archive.ubuntu.com/ubuntu/ lucid-updates main restricted universe multiverse
#deb-src http://it.archive.ubuntu.com/ubuntu/ lucid-updates main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu lucid-security main restricted universe multiverse
#deb-src http://security.ubuntu.com/ubuntu lucid-security main restricted universe multiverse
----- >8 -----

----- 8< -----
$ sudo aptitude full-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initialising package states... Done
The following packages are BROKEN:
  kde-l10n-engb kde-l10n-it
2 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 10,2MB of archives. After unpacking 160kB will be used.
The following packages have unmet dependencies:
  kde-l10n-it: Depends: libkdecore5 (>= 4:4.5.0) which is a virtual package.
  kde-l10n-engb: Depends: libkdecore5 (>= 4:4.5.0) which is a virtual package.
The following actions will resolve these dependencies:

Remove the following packages:
kde-l10n-it

Keep the following packages at their current version:
kde-l10n-engb [4:4.4.2-0ubuntu6 (lucid, now)]

Score is 189

Accept this solution? [Y/n/q/?]
----- >8 -----

----- 8< -----
$ apt-cache policy libkdecore5
libkdecore5:
  Installed: (none)
  Candidate: (none)
  Version table:
----- >8 -----

----- 8< -----
$ apt-cache policy kde-l10n-it kde-l10n-engb
kde-l10n-it:
  Installed: 4:4.4.2-0ubuntu6
  Candidate: 4:4.4.5-0ubuntu1~lucid1
  Version table:
     4:4.4.5-0ubuntu1~lucid1 0
        500 http://it.archive.ubuntu.com/ubuntu/ lucid-updates/main Packages
 *** 4:4.4.2-0ubuntu6 0
        500 http://it.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
kde-l10n-engb:
  Installed: 4:4.4.2-0ubuntu6
  Candidate: 4:4.4.5-0ubuntu1~lucid1
  Version table:
     4:4.4.5-0ubuntu1~lucid1 0
        500 http://it.archive.ubuntu.com/ubuntu/ lucid-updates/main Packages
 *** 4:4.4.2-0ubuntu6 0
        500 http://it.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
----- >8 -----

Jonathan Riddell (jr) on 2011-01-05
Changed in kde-l10n-engb (Ubuntu):
status: New → Confirmed
importance: Undecided → High
milestone: none → lucid-updates
tags: added: kubuntu
Jonathan Riddell (jr) on 2011-01-05
Changed in kde-l10n-engb (Ubuntu Lucid):
importance: Undecided → High
Changed in kde-l10n-engb (Ubuntu):
status: Confirmed → Invalid
Changed in kde-l10n-engb (Ubuntu Lucid):
status: New → Confirmed
Jonathan Riddell (jr) wrote :
Jonathan Riddell (jr) wrote :

Fix uploaded to lucid-proposed, awaiting approval

Accepted kde-l10n-engb into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in kde-l10n-engb (Ubuntu Lucid):
status: Confirmed → Fix Committed
tags: added: verification-needed

I have performed a test-upgrade and can confirm that the following packages now can be upgraded correctly:

- kde-l10n-de (4.4.2-0ubuntu6 => 4.4.5-0ubuntu1~lucid2)
- kde-l10n-engb (4.4.2-0ubuntu6 => 4.4.5-0ubuntu1~lucid2)
- kde-l10n-fr (4.4.2-0ubuntu6 => 4.4.5-0ubuntu1~lucid2)
- kde-l10n-ja (4.4.2-0ubuntu6 => 4.4.5-0ubuntu1~lucid2)
- kde-l10n-nl (4.4.2-0ubuntu6 => 4.4.5-0ubuntu1~lucid2)
- kde-l10n-ru (4.4.2-0ubuntu6 => 4.4.5-0ubuntu1~lucid2)
- kde-l10n-zhcn (4.4.2-0ubuntu6 => 4.4.5-0ubuntu1~lucid2)
- kde-l10n-zhtw (4.4.2-0ubuntu6 => 4.4.5-0ubuntu1~lucid2)

Martin Pitt (pitti) on 2011-01-06
tags: added: verification-done
removed: verification-needed
Oliver Joos (oliver-joos) wrote :

I was also affected and can confirm: after enabling proposed kde-l10n-engb and kde-l10n-de were updateable again. Thanks for the quick fix!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde-l10n-engb - 4:4.4.5-0ubuntu1~lucid2

---------------
kde-l10n-engb (4:4.4.5-0ubuntu1~lucid2) lucid-proposed; urgency=low

  * Fix dependency on kdelibs5, LP: #696675
 -- Jonathan Riddell <email address hidden> Wed, 05 Jan 2011 17:59:52 +0000

Changed in kde-l10n-engb (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers