duplicated language on kde systemsettings

Bug #446739 reported by mmbossoni on 2009-10-08
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
kde-l10n-ca-valencia (Ubuntu)
Low
Harald Sitter

Bug Description

Binary package hint: kdebase-workspace

Hi,
When I click option to add a new language in karmic the entries appear duplicated
See attached image
I have the newest 4.3.2 KDE

Related branches

mmbossoni (mmbossoni-gmail) wrote :
affects: kdebase-workspace (Ubuntu) → kdebase-runtime (Ubuntu)
Changed in kdebase-runtime (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
mmbossoni (mmbossoni-gmail) wrote :

Hi,
after the bug https://bugs.launchpad.net/bugs/442742 be solved, I noticed that the duplicated entries have different languages.
One entry is in default language (english) while the duplicated one has another language (in my case pt_BR)

Harald Sitter (apachelogger) wrote :

Turns out this is in fact duplication of entry.desktop, but caused by our very own kde-l10n packages. Solution is to drop those files from the kde-l10n packages since they are duplications of the langpacks anyway + mangled by ubuntu's pkgbinarymangler.

affects: kdebase-runtime (Ubuntu) → kde-l10n-ca-valencia (Ubuntu)
Changed in kde-l10n-ca-valencia (Ubuntu):
assignee: nobody → Harald Sitter (apachelogger)
status: Confirmed → In Progress
Changed in kde-l10n-ca-valencia (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde-l10n-ca-valencia - 4:4.4.2-0ubuntu6

---------------
kde-l10n-ca-valencia (4:4.4.2-0ubuntu6) lucid; urgency=low

  * Strip entry.desktop file to prevent duplication in KDE's various
    locale listings, most importantly the locale selection button LP: #446739
  * Reupload so that ca@valencia gets imported properly, now that it is in
    main LP: #563755
 -- Harald Sitter <email address hidden> Thu, 15 Apr 2010 13:51:02 +0200

Changed in kde-l10n-ca-valencia (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers