Ubuntu

wrong dependency on language-pack-kde-zh

Reported by Aron Xu on 2009-10-29
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Medium
Unassigned
kde-i18n-zhcn (Ubuntu)
Undecided
Jonathan Riddell
Nominated for Lucid by Arne Goetje
Karmic
Undecided
Unassigned
kde-i18n-zhtw (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by Arne Goetje
Karmic
Undecided
Unassigned

Bug Description

Binary package hint: kde-i18n-zhcn

kde-i18n-zhcn and kde-i18n-zhtw depends on language-pack-kde-zh,
which cause zh-hans users need to install following useless packages:
1.language-pack-kde-zh
2.language-pack-kde-zh-hant
3.language-pack-kde-zh-hant-base
4.language-pack-zh-hant
5.language-pack-zh-hant-base

and zh-hant users install following useless packages:
1.language-pack-kde-zh
2.language-pack-kde-zh-hans
3.language-pack-kde-zh-hans-base
4.language-pack-zh-hans
5.language-pack-zh-hans-base

Aron Xu (happyaron) on 2009-10-29
Changed in ubuntu-translations:
assignee: nobody → Aron Xu (happyaron)
importance: Undecided → Wishlist
status: New → Confirmed
Aron Xu (happyaron) on 2009-10-29
description: updated
Tom K. C. Chiu (tomchiukc) wrote :

can't we simply split the package into two?

Tom K. C. Chiu wrote:
> can't we simply split the package into two?
>
it has been split into two already. The correct packages are now
language-pack-kde-zh-hans (Simplified Chinese) and
language-pack-kde-zh-hant (Traditional Chinese). All what's needed is
that change to be reflected in the dependencies.

Aron Xu (happyaron) on 2009-12-18
Changed in ubuntu-translations:
assignee: Aron Xu (happyaron) → nobody
importance: Wishlist → Medium
Jimhu (huyiwei) wrote :

I can confirm this.
Chinese language pacakges are extremely large, so downloading either Simplified Chinese or Traditional Chinese language packages can make users spend much less time on system configuration after a flash installation.

Changed in kde-i18n-zhcn (Ubuntu):
status: New → Confirmed
Changed in kde-i18n-zhtw (Ubuntu):
status: New → Confirmed
Arne Goetje (arnegoetje) on 2009-12-18
Changed in ubuntu-translations:
assignee: nobody → Arne Goetje (arnegoetje)
Changed in kde-i18n-zhcn (Ubuntu):
assignee: nobody → Arne Goetje (arnegoetje)
Changed in kde-i18n-zhtw (Ubuntu):
assignee: nobody → Arne Goetje (arnegoetje)
Changed in ubuntu-translations:
status: Confirmed → In Progress
Changed in kde-i18n-zhtw (Ubuntu):
status: Confirmed → In Progress
Changed in kde-i18n-zhcn (Ubuntu):
status: Confirmed → In Progress
Arne Goetje (arnegoetje) on 2009-12-18
Changed in kde-i18n-zhcn (Ubuntu):
status: In Progress → Fix Committed
Arne Goetje (arnegoetje) on 2009-12-18
Changed in kde-i18n-zhtw (Ubuntu):
status: In Progress → Fix Committed
Changed in ubuntu-translations:
status: In Progress → Fix Committed
Arne Goetje (arnegoetje) wrote :

@jr:
Can you please check, sponsor and do the SRU for Karmic? Thanks a lot.

Wylmer Wang (wantinghard) wrote :

Sorry, I'm not familiar with bug issues, and I don't know exactly the
procedure of packaging. I only do the translation work on the Launchpad. I
don't understand what do you mean by "chek,sponsor and do the SRU"... Please
contact Aron Xu or somebody else for these things.

--
失去创新,我们也失去了自由
Freedom comes from our creation...

Changed in kde-i18n-zhtw (Ubuntu):
status: Fix Committed → Incomplete
Aron Xu (happyaron) wrote :

@陈炜鑫:
Please don't change it to Incomplete because the fix has been committed to branch, if you think it's not proper please leave a comment or ask around before you change the status.

Changed in kde-i18n-zhtw (Ubuntu):
status: Incomplete → Fix Committed
Arne Goetje (arnegoetje) wrote :

@王英华:
The comment was not meant for you, but for Jonathan Riddell.

@ 陈炜鑫:
Why are you changing the bug status to Incomplete? I have fixed the issue already and am just waiting for Jonathan to take it from here. Changing back to Fix Committed.

Changed in ubuntu-translations:
assignee: Arne Goetje (arnegoetje) → nobody
Changed in kde-i18n-zhcn (Ubuntu):
assignee: Arne Goetje (arnegoetje) → Jonathan Riddell (jr)
Changed in kde-i18n-zhtw (Ubuntu):
assignee: Arne Goetje (arnegoetje) → nobody
Jonathan Riddell (jr) wrote :

diff -u kde-i18n-zhcn-3.5.9/debian/changelog kde-i18n-zhcn-3.5.9/debian/changelog
--- kde-i18n-zhcn-3.5.9/debian/changelog
+++ kde-i18n-zhcn-3.5.9/debian/changelog
@@ -1,3 +1,10 @@
+kde-i18n-zhcn (4:3.5.9-0ubuntu4.1) karmic-proposed; urgency=low
+
+ * Depend on language-pack-kde-zh-hans instead of language-pack-kde-zh,
+ LP: #463181
+
+ -- Jonathan Riddell <email address hidden> Mon, 08 Mar 2010 16:11:57 +0000
+
 kde-i18n-zhcn (4:3.5.9-0ubuntu4) jaunty; urgency=low

   * Remove docs from SUBDIRS in Makefile.am. The docs should not be installed
diff -u kde-i18n-zhcn-3.5.9/debian/control kde-i18n-zhcn-3.5.9/debian/control
--- kde-i18n-zhcn-3.5.9/debian/control
+++ kde-i18n-zhcn-3.5.9/debian/control
@@ -8,7 +8,7 @@
 Package: kde-i18n-zhcn
 Architecture: all
 Section: kde
-Depends: language-pack-kde-zh, kdelibs4c2a (>= 4:3.5.4)
+Depends: language-pack-kde-zh-hans, kdelibs4c2a (>= 4:3.5.4)
 Replaces: kdebase-i18n, kde-i18n, koffice-i18n-zhcn (<< 1.6.1-1ubuntu2)
 Suggests: kde
 Conflicts: kdebase-i18n, koffice (<< 1.3.0-2), juk (<<4:3.2.1-1), kcachegrind (<<4:3.2.1-1)

Jonathan Riddell (jr) wrote :

Uploaded to karmic-proposed

Accepted kde-i18n-zhcn into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in kde-i18n-zhcn (Ubuntu Karmic):
status: New → Fix Committed
tags: added: verification-needed
Changed in kde-i18n-zhtw (Ubuntu Karmic):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted kde-i18n-zhtw into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Anyone who can test the proposed package? If not, the proposed update will be removed again. Thanks!

SRU Verification for Karmic:

I have reproduced the problem with kde-i18n-zhcn and kde-i18n-zhtw / 4:3.5.9-0ubuntu4 and have verified that the version of kde-i18n-zhcn and kde-i18n-zhtw / 4:3.5.9-0ubuntu4.1 in proposed fixes the issue.
Installing kde-i18n-zhcn only installs the 'Simplified chinese' packages: language-pack-kde-zh-hans language-pack-kde-zh-hans-base
  language-pack-zh-hans language-pack-zh-hans-base
Installing kde-i18n-zhtw only installs the 'Traditional chinese' packages: language-pack-kde-zh-hant language-pack-kde-zh-hant-base
  language-pack-zh-hant language-pack-zh-hant-base

Marking as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde-i18n-zhtw - 4:3.5.9-0ubuntu4.1

---------------
kde-i18n-zhtw (4:3.5.9-0ubuntu4.1) karmic-proposed; urgency=low

  * Depend on language-pack-zh-hant instead of language-pack-zh, LP: #463181
 -- Jonathan Riddell <email address hidden> Mon, 08 Mar 2010 16:12:37 +0000

Changed in kde-i18n-zhtw (Ubuntu Karmic):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Dependencies are fixed in lucid/maverick.

Changed in kde-i18n-zhcn (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde-i18n-zhcn - 4:3.5.9-0ubuntu4.1

---------------
kde-i18n-zhcn (4:3.5.9-0ubuntu4.1) karmic-proposed; urgency=low

  * Depend on language-pack-kde-zh-hans instead of language-pack-kde-zh,
    LP: #463181
 -- Jonathan Riddell <email address hidden> Mon, 08 Mar 2010 16:11:57 +0000

Changed in kde-i18n-zhcn (Ubuntu Karmic):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2010-06-21
Changed in kde-i18n-zhtw (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-translations:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers