[apport] displayconfig-restore.py crashed with ImportError in <module>() - ixf86misc

Bug #97507 reported by Robert Wohleb on 2007-03-28
484
Affects Status Importance Assigned to Milestone
guidance-power-manager (Ubuntu)
Undecided
Unassigned
kde-guidance (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: kde-guidance

I am running Feisty -> AIGLX -> Beryl -> Aquamarine -> KDE on an i915 chipset. Attempting suspend-to-ram and suspend-to-disk both cause crash.

ProblemType: Crash
Architecture: i386
Date: Wed Mar 28 10:43:57 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/share/python-support/kde-guidance/displayconfig-restore.py
InterpreterPath: /usr/bin/python2.5
Package: kde-guidance 0.7.1~svn20070205-0ubuntu1
PackageArchitecture: i386
ProcCmdline: /usr/bin/python /usr/bin/displayconfig-restore
ProcCwd: /home/rwohleb
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=en_US.UTF-8
PythonArgs: ['/usr/bin/displayconfig-restore']
SourcePackage: kde-guidance
Traceback:
 Traceback (most recent call last):
   File "/usr/bin/displayconfig-restore", line 20, in <module>
     import ixf86misc
 ImportError: No module named ixf86misc
Uname: Linux meson 2.6.20-13-generic #2 SMP Sun Mar 25 00:21:25 UTC 2007 i686 GNU/Linux

Robert Wohleb (rwohleb) wrote :
Marco Maini (maini10) on 2007-04-01
Changed in kde-guidance:
status: Unconfirmed → Confirmed
Daniel Hahler (blueyed) wrote :

Related to or dupe of bug 55361?

Robert Wohleb (rwohleb) wrote :

Within an interactive python session, 'import ixf86misc' works, but 'ixf86misc.GetGamma(0,0)' segfaults. This is consistent with bug 55361, but does not explain the ImportError.

Scott Kitterman (kitterman) wrote :

Setting to high based on the large number of duplicates.

Changed in kde-guidance:
importance: Undecided → High
Scott Kitterman (kitterman) wrote :

The comment about GetGamma (3) is unrelated to this bug. displyconfig-restore.py does not use that ixf86misc function. It is only called from xf86misc.py.

Scott Kitterman (kitterman) wrote :

If this problem recurs (or if it just happened to you and you are reading about this bug on LP), please try the following:

Open a Konsole window (K menu -> System -> Konsole)
In the window that opens, type:

python

That will show you something like this:

Python 2.5.1c1 (release25-maint, Apr 12 2007, 21:00:25)
[GCC 4.1.2 (Ubuntu 4.1.2-0ubuntu4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>>

After the >>> type the following lines:

import sys
print sys.path

The output will look something like this:

['', '/usr/lib/python25.zip', '/usr/lib/python2.5', '/usr/lib/python2.5/plat-linux2',
'/usr/lib/python2.5/lib-tk', '/usr/lib/python2.5/lib-dynload', '/usr/local/lib/python2.5/site-packages',
'/usr/lib/python2.5/site-packages', '/usr/lib/python2.5/site-packages/Numeric',
'/usr/lib/python2.5/site-packages/PIL', '/var/lib/python-support/python2.5',
 '/var/lib/python-support/python2.5/gtk-2.0', '/usr/lib/python2.5/site-packages/wx-2.6-gtk2-unicode']

Please copy and paste the entire thing (starting with Python 2.5.1c1 (release25-maint, Apr 12 2007, 21:00:25) - or whatever version you have) into a response to this bug.

Robert Wohleb (rwohleb) wrote :

Python 2.5.1c1 (release25-maint, Apr 12 2007, 21:00:25)
[GCC 4.1.2 (Ubuntu 4.1.2-0ubuntu4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import sys
>>> print sys.path
['', '/usr/lib/python25.zip', '/usr/lib/python2.5', '/usr/lib/python2.5/plat-linux2', '/usr/lib/python2.5/lib-tk', '/usr/lib/python2.5/lib-dynload', '/usr/local/lib/python2.5/site-packages', '/usr/lib/python2.5/site-packages', '/usr/lib/python2.5/site-packages/Numeric', '/var/lib/python-support/python2.5', '/usr/lib/python2.5/site-packages/gtk-2.0', '/var/lib/python-support/python2.5/gtk-2.0']
>>>

dp (dp-de) wrote :

Python 2.5.1c1 (release25-maint, Apr 12 2007, 21:00:25)
[GCC 4.1.2 (Ubuntu 4.1.2-0ubuntu4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import sys
>>> print sys.path
['', '/usr/lib/python25.zip', '/usr/lib/python2.5', '/usr/lib/python2.5/plat-linux2', '/usr/lib/python2.5/lib-tk', '/usr/lib/python2.5/lib-dynload', '/usr/local/lib/python2.5/site-packages', '/usr/lib/python2.5/site-packages', '/usr/lib/python2.5/site-packages/Numeric', '/usr/lib/python2.5/site-packages/gst-0.10', '/var/lib/python-support/python2.5', '/usr/lib/python2.5/site-packages/gtk-2.0', '/var/lib/python-support/python2.5/gtk-2.0']
>>>

Scott Kitterman (kitterman) wrote :

Thanks for the inputs. I don't think we need any more.

Scott Kitterman (kitterman) wrote :

I don't need a zillion me too responses, but is anyone who experienced this problem before running Hardy and if so are you still experiencing this problem?

Scott Kitterman (kitterman) wrote :

Marking incomplete due to lack of confirmations in Hardy.

Changed in kde-guidance:
status: Confirmed → Incomplete
Scott Kitterman (kitterman) wrote :

Apparently so (given additional dupes).

Changed in kde-guidance:
status: Incomplete → Confirmed
Timo Jyrinki (timo-jyrinki) wrote :

Does this happen in 8.04.1 anymore? No new bugs seem to be filed after 8.04 launch.

Since apport automatic crash reporting is disabled after release, I
wouldn't make to much of the lack of post-release reports. The frequncy
seem to be way down, but I don't think this is fully resolved.

Scott Kitterman (kitterman) wrote :

Marking won't fix for kde-guidance since it's been removed from Intrepid.

Changed in kde-guidance:
status: Confirmed → Won't Fix
Adam Niedling (krychek) wrote :

I'm closing this bug as the information requested by Timo has not been provided.

Changed in guidance-power-manager:
status: New → Invalid
Adam Niedling (krychek) wrote :

Hmm.. based on the large number of duplicates, this should be set to incomplete instead. Please reopen if you still encounter this issue.

Changed in guidance-power-manager:
status: Invalid → Incomplete
Jonathan Thomas (echidnaman) wrote :

Displayconfig isn't part of guidance-power-manager, so closing as invalid.

Changed in guidance-power-manager:
status: Incomplete → Invalid
To post a comment you must log in.