wineconfig doesn't work

Bug #82723 reported by Guillaume Martres on 2007-02-01
8
Affects Status Importance Assigned to Milestone
kde-guidance (Ubuntu)
High
Yuriy Kozlov

Bug Description

Binary package hint: kde-guidance

"Windows Applications" button in system settings doesn't work, if i launch wineconfig from a terminal i get:

sh: wineprefixcreate: not found
Traceback (most recent call last):
  File "/usr/bin/wineconfig", line 3487, in <module>
    wineconfigapp = WineConfigApp()
  File "/usr/bin/wineconfig", line 103, in __init__
    self.CreateWindowsInstall()
  File "/usr/bin/wineconfig", line 253, in CreateWindowsInstall
    drives = wineread.LoadDrives()
  File "/usr/share/python-support/kde-guidance/wineread.py", line 75, in LoadDrives
    driveletters = os.listdir(winepath + "/dosdevices")
OSError: [Errno 2] Aucun fichier ou répertoire de ce type: '/home/smarter/.wine/dosdevices'

After installing wine I get this:
regedit: Can't export. Registry key 'HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ThemeManager' does not exist!
Succ�

Traceback (most recent call last):
  File "/usr/bin/wineconfig", line 3487, in <module>
    wineconfigapp = WineConfigApp()
  File "/usr/bin/wineconfig", line 105, in __init__
    self._buildGUI()
  File "/usr/bin/wineconfig", line 195, in _buildGUI
    self.appearancepage = AppearancePage(appearance1page)
  File "/usr/bin/wineconfig", line 1756, in __init__
    self.reset()
  File "/usr/bin/wineconfig", line 1870, in reset
    self.__selectColorScheme(i)
  File "/usr/bin/wineconfig", line 2181, in __selectColorScheme
    self.__selectItem(unicode(i18n("Desktop")))
  File "/usr/bin/wineconfig", line 2361, in __selectItem
    self.customizableitems[item][0][key][0])
KeyError: u'Bureau'

Related branches

Luka Renko (lure) wrote :

Yes, wineconfig should do something sensible if wine is not installed.

Changed in kde-guidance:
status: Unconfirmed → Confirmed
Changed in kde-guidance:
assignee: nobody → yuriy-kozlov
importance: Undecided → High
Yuriy Kozlov (yuriy-kozlov) wrote :

I fixed the behavior when wine is not installed (just need to change to using software-properties-kde when that is uploaded).

You can ignore the regedit errors, those are optional keys that are created as needed.

The last one I'm not sure on right now. Can you check if it happens with a us_en locale?

Luka Renko (lure) wrote :

Works here, even though we still need software-properties installed. Maybe kde-guidance (or kde-guidance-wine) should depend on adept/software-properties package.

Changed in kde-guidance:
status: Confirmed → Fix Committed
Luka Renko (lure) on 2007-02-05
Changed in kde-guidance:
status: Fix Committed → Fix Released
Guillaume Martres (smarter) wrote :

Now with kde-guidance 0.7.1~svn20070205-0ubuntu1, the wineconfig module tries to install wine with the commande: "software-properties --enable-component=universe && adept_batch install wine" but the binary of the software-properties-kde packages is software-properties-kde, not software-properties.

Guillaume Martres (smarter) wrote :

>The last one I'm not sure on right now. Can you check if it happens with a
>us_en locale?
17:20 smarter@ubuntu ~% LANG=en_US.UTF-8 LANGUAGE=en_US wineconfig
regedit: Can't export. Registry key 'HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ThemeManager' does not exist!
Success

Traceback (most recent call last):
  File "/usr/bin/wineconfig", line 3541, in <module>
    wineconfigapp = WineConfigApp()
  File "/usr/bin/wineconfig", line 118, in __init__
    self._buildGUI()
  File "/usr/bin/wineconfig", line 211, in _buildGUI
    self.appearancepage = AppearancePage(appearance1page)
  File "/usr/bin/wineconfig", line 1806, in __init__
    self.reset()
  File "/usr/bin/wineconfig", line 1920, in reset
    self.__selectColorScheme(i)
  File "/usr/bin/wineconfig", line 2231, in __selectColorScheme
    self.__selectItem(unicode(i18n("Desktop")))
  File "/usr/bin/wineconfig", line 2411, in __selectItem
    self.customizableitems[item][0][key][0])
KeyError: u'Bureau'
Error in sys.excepthook:
Traceback (most recent call last):
  File "/var/lib/python-support/python2.5/apport/python_hook.py", line 44, in apport_excepthook
    binary = os.path.normpath(os.path.join(os.getcwdu(), sys.argv[0]))
IndexError: list index out of range

Original exception was:
Traceback (most recent call last):
  File "/usr/bin/wineconfig", line 3541, in <module>
    wineconfigapp = WineConfigApp()
  File "/usr/bin/wineconfig", line 118, in __init__
    self._buildGUI()
  File "/usr/bin/wineconfig", line 211, in _buildGUI
    self.appearancepage = AppearancePage(appearance1page)
  File "/usr/bin/wineconfig", line 1806, in __init__
    self.reset()
  File "/usr/bin/wineconfig", line 1920, in reset
    self.__selectColorScheme(i)
  File "/usr/bin/wineconfig", line 2231, in __selectColorScheme
    self.__selectItem(unicode(i18n("Desktop")))
  File "/usr/bin/wineconfig", line 2411, in __selectItem
    self.customizableitems[item][0][key][0])
KeyError: u'Bureau'

Anyway the "Windows Application" module of kde-systemsettings now works.

Lionel Tricon (lionel-tricon) wrote :

If you change : self.__selectItem(unicode(i18n("Desktop")))
into self.__selectItem(unicode("Desktop"))
it works.

I'm pretty sure that would only work if your using English.

It will only work if we are using english, yes.

Using unicode(i18n("Desktop")) is not entirely correctly IIRC at looking at another similar bug. I can look into this in a few days.

Scott Kitterman (kitterman) wrote :

I'm offline until next Wed, so please do.

Yuriy Kozlov (yuriy-kozlov) wrote :

awen: I'll look at it myself, thanks. This is due to a poor decision of how to store the values that I think should break only if you change locales, but that may not be the case and it's a really bad way to do it anyway. It'll require some reworking and might be tricky to get it to keep working with existing configurations, but I'll look into it over the weekend.

While I'm looking at that, the built in color schemes probably need some updates. I never got around to including the orange/human scheme and it would be nice to have one that matches oxygen as well.
ScottK: does that require an FFe and is it too late?

Changed in kde-guidance:
status: Fix Released → In Progress
Scott Kitterman (kitterman) wrote :

I think it's to late for anything except fixing broken stuff, but ask
Riddell.

Yuriy Kozlov (yuriy-kozlov) wrote :

I was thinking of a different potential bug, this one wasn't so bad. A fix is in svn revision 796117.

Yuriy Kozlov (yuriy-kozlov) wrote :

I was going through and fixing some spacing and noticed something I missed in fixing this bug. It's now fixed in revision 796276 but the diff is a bit messy.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde-guidance - 0.8.0svn20080103-0ubuntu15

---------------
kde-guidance (0.8.0svn20080103-0ubuntu15) hardy; urgency=low

  [ Andreas Wenning ]
  * Added kubuntu_29_kde-powermanager_display_consumption_rate.patch to
    display current consumption rate. (LP: #214774).
  * Readded kubuntu_30_displayconfig_no_xorg_correct_detection.patch
    which doesn't break the api. displayconfig will detect the hardware
    automatically and write a xorg.conf if none is present on startup.
    (LP: #203378).

  [ Yuriy Kozlov ]
  * Added kubuntu_31_wineconfig_no_i18_on_keys.patch to remove i18n from
    dictionary keys, which caused crashes on non en_US locales. Should be
    removed if synced with upstream. (LP: #82723)

 -- Yuriy Kozlov <email address hidden> Sun, 13 Apr 2008 12:49:35 -0400

Changed in kde-guidance:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers