displayconfig resolution change bug

Bug #82279 reported by GPLed on 2007-01-30
88
Affects Status Importance Assigned to Milestone
kde-guidance (Ubuntu)
Low
Andreas Wenning
Hardy
Medium
Andreas Wenning

Bug Description

Binary package hint: kde-guidance

When I try to change the resolution in displayconfig, the resolution is not changed unless I click on the refresh rate list. In short the refresh rate value is in the list and selected by default but for some reason I have to click on it to make it work. When I click on the default value in the refresh rate list, it works and does it's job well.

Brian Murray (brian-murray) wrote :

Thanks for your bug report. Which version of Kubuntu are you using where you see this problem?

Changed in kde-guidance:
assignee: nobody → brian-murray
status: Unconfirmed → Needs Info

Feisty 7.04

On 2/2/07, Brian Murray <email address hidden> wrote:
> Thanks for your bug report. Which version of Kubuntu are you using
> where you see this problem?
>
> ** Changed in: kde-guidance (Ubuntu)
> Assignee: (unassigned) => Brian Murray
> Status: Unconfirmed => Needs Info
>
> --
> displayconfig resolution change bug
> https://launchpad.net/bugs/82279
>

--
Sunny Sachanandani.
Capri/B/203,
Hiranandani Estate,
Thane(West),
Maharashtra,
INDIA.

+91-022-25308509
+91-9870489418

GPLed (sunnysachanandani) wrote :

I got some more info on this: When I don't click on the refresh rate
list even once I get the following output on the console I am running
displayconfig from :

X Error: BadValue (integer parameter out of range for operation) 2
  Major opcode: 155
  Minor opcode: 2
  Resource id: 0x37
/usr/bin/xset dpms 1800 1800 1800

Otherwise when I click on the refresh rate list I only get:

/usr/bin/xset dpms 1800 1800 1800

--
Sunny Sachanandani.
Capri/B/203,
Hiranandani Estate,
Thane(West),
Maharashtra,
INDIA.

+91-022-25308509
+91-9870489418

Changed in kde-guidance:
assignee: brian-murray → nobody
importance: Undecided → Low
status: Needs Info → Confirmed
Sebastian Kügler (sebasje) wrote :

Looks fishy, you do *not* apply the settings, but you get the 'xset' output in the console?

GPLed (sunnysachanandani) wrote :

No it happens when I click Apply. The difference is in touching the resolution list before applying.

GPLed (sunnysachanandani) wrote :

The bug still exists in Gutsy. It even affects displayconfig-gtk.

In Hardy the bug doesn't exist apparently but I have Hardy installed on a different machine that the one this bug was reported on.

Scott Kitterman (kitterman) wrote :

Many of these bugs are very hardware specific, so if you could test on the same machine (maybe via Live CD) it would be very helpful.

Changed in kde-guidance:
status: Confirmed → Incomplete
Anthony Fok (foka) on 2008-05-15
Changed in kde-guidance:
status: Incomplete → Confirmed
Anthony Fok (foka) wrote :
Download full text (4.5 KiB)

Hello,

I am personally affected by this bug, and so did my colleagues and clients, in feisty, gutsy and hardy. So, we finally found some time to look into it more deeply.

This bug is not very hardware specific. Our observation is that often tools like krandrtray, displayconfig-gtk, xrandr work, but displayconfig in kde-guidance does not. That hints at a software bug.

Our test configuration:

* Kubuntu 8.04 (i386)
* Intel Q35 chipset (display)
* SONY Trintron Multiscan E230 CRT Monitor

Test: Changing screen resolution using displayconfig from kde-guidance in non-administrator mode.

With that configuration, displayconfig shows the following available resolutions: 640x480, 720x400, 800x600, 832x624, 1024x768, 1280x960, 1280x1024, 1600x1200

However, we could only change to 640x480, 800x600 and 1024x768 directly.

Other resolutions didn't really work. Or did they? After changing from 1024x768 to, say, 1600x1200 (without manually setting the refresh rate), the screen stays at 1024x768 with the 15-second timeout pop-up box, but with the following error message in the console:

  X Error: BadValue (integer parameter out of range for operation) 2
    Major opcode: 156
    Minor opcode: 2
    Resource id: 0x4b

If I accept the resolution change, then kill X by Ctrl-Alt-Backspace, and re-login, X is in 1600x1200!

Indeed, a quick check of ~/.kde/share/config/displayconfigrc reviews that it has stored the setting of 1600x1200, and apparently /usr/bin/displayconfig-restore (called by /etc/X11/Xsession.d/40guidance-displayconfig_restore) is working!

Since both displayconfig and displayconfig-gtk use guidance-backend, and yet one works and another does not, we became convinced the bug is *not* in the backend, but somewhere in /usr/bin/displayconfig the frontend itself.

Running xf86misc.py shows the following:

=================================================================
Number of screens: 1
Idle seconds: 0.059

Gamma:(1.0, 1.0, 1.0)

SizeID:0
Size:(1024, 768, 312, 234)
Available Sizes:[(1024, 768, 312, 234), (1600, 1200, 312, 234), (1280, 1024, 312, 234), (1280, 960, 312, 234), (1152, 864, 312, 234), (832, 624, 312, 234), (800, 600, 312, 234), (640, 480, 312, 234), (720, 400, 312, 234)]

Rotation:1
Available Rotations:63

Refresh rate:75
Refresh rates for the current screen:[85, 75, 70, 60, 43]
All Refresh Rates:[85, 75, 70, 60, 43]
All Refresh Rates:[60]
All Refresh Rates:[75]
All Refresh Rates:[75]
All Refresh Rates:[85, 75]
All Refresh Rates:[75]
All Refresh Rates:[85, 72, 75, 60, 56]
All Refresh Rates:[85, 75, 73, 67, 60]
All Refresh Rates:[88, 70]
SizeID:0
Size:(1024, 768, 312, 234)
Available Sizes:[(1024, 768, 312, 234), (1600, 1200, 312, 234), (1280, 1024, 312, 234), (1280, 960, 312, 234), (1152, 864, 312, 234), (832, 624, 312, 234), (800, 600, 312, 234), (640, 480, 312, 234), (720, 400, 312, 234)]
=================================================================

The default resolution is 1024x768 @ 85 Hz.

After some debugging, it turns out that: when trying to change to 1600x1200, even though displayconfig shows "60 Hz" (the only valid refresh rate) selected in the combo box, upon clicking "Apply", displayconfig actually tried...

Read more...

Anthony Fok (foka) wrote :

I have uploaded a test package in my PPA:

    https://launchpad.net/~foka/+archive

as kde-guidance (0.8.0svn20080103-0ubuntu16thiz1).

This is my first upload to PPA, so please forgive me and let me know if I did anything wrong. :-)

ChangeLog:

  kde-guidance (0.8.0svn20080103-0ubuntu16thiz1) hardy; urgency=low

    * kubuntu_32_displayconfig_update_refresh_rate.patch:
      - The refresh rate was not actually updated for the selected resolution,
        so resolution change may fail at times. Fixed.
    * kubuntu_33_displayconfig_add_new_video_cards.patch:
      - Added 8086:29b2 for "Intel Q35";
      - Renamed "i810" to "intel".
    * debian/copyright: s/FDL/GFDL/;

   -- Anthony Fok <email address hidden> Sun, 04 May 2008 04:45:19 +0800

Cheers,

Anthony Fok
ThizLinux Software Co., Ltd.

Anthony Fok (foka) wrote :

A proposed fix for hardy is uploaded as kde-guidance (0.8.0svn20080103-0ubuntu16thiz1) to my PPA at https://launchpad.net/~foka/+archive .

Changed in kde-guidance:
status: Confirmed → Fix Committed

You shouldn't mark it as fix committed until it is committed to ubuntu and not just a PPA. I'll have a look at the patch when time permits.

Changed in kde-guidance:
status: Fix Committed → Confirmed
Anthony Fok (foka) wrote :

Hello Andreas,

On Fri, May 16, 2008 at 5:26 AM, awen <email address hidden> wrote:
> You shouldn't mark it as fix committed until it is committed to ubuntu
> and not just a PPA. I'll have a look at the patch when time permits.
>
> ** Changed in: kde-guidance (Ubuntu)
> Status: Fix Committed => Confirmed

I misunderstood the meaning of "Fix committed". My apologies,
and thank you for your correction. :-)

Cheers,

Anthony

Changed in kde-guidance:
assignee: nobody → andreas-wenning
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde-guidance - 0.8.0svn20080103-0ubuntu18

---------------
kde-guidance (0.8.0svn20080103-0ubuntu18) intrepid; urgency=low

  [ Anthony Fok ]
  * kubuntu_32_displayconfig_update_refresh_rate.patch:
    - The refresh rate was not updated for the selected resolution, so
      resolution change could fail. (LP: #82279)
  * kubuntu_33_displayconfig_add_new_video_cards.patch:
    - Added 8086:29b2 for "Intel Q35";
  * debian/copyright: s/FDL/GFDL/;

  [ Andreas Wenning ]
  * kubuntu_34_kde-powermanager_no_lid_special_behaviour_disable.patch:
    - No need to call power plugged/unplugged in init if no lid is
      found; this just make us crash. (LP: #231163)

 -- Andreas Wenning <email address hidden> Mon, 02 Jun 2008 22:20:45 +0200

Changed in kde-guidance:
status: In Progress → Fix Released

This is an SRU request for the fix of this an two other bugs. Changelog from the SRU i'm requesting:

kde-guidance (0.8.0svn20080103-0ubuntu16.1) hardy-proposed; urgency=low

  [ Anthony Fok ]
  * kubuntu_32_displayconfig_update_refresh_rate.patch:
    - The refresh rate was not updated for the selected resolution, so
      resolution change could fail. (LP: #82279)
  * kubuntu_33_displayconfig_add_new_video_cards.patch:
    - Added 8086:29b2 for "Intel Q35";
  * debian/copyright: s/FDL/GFDL/;

  [ Andreas Wenning ]
  * kubuntu_34_kde-powermanager_no_lid_special_behaviour_disable.patch:
    - No need to call power plugged/unplugged in init if no lid is
      found; this just make us crash. (LP: #231163)
  * Edited kubuntu_23_kde-powermanager_gpmhelper.patch to prevent
    multiple brightness- or hibernate-calls happening on certain
    machines. Already implemented for sleep-calls. (LP: #207473)

 -- Andreas Wenning <email address hidden> Thu, 05 Jun 2008 16:24:38 +0200

=== Testcase for the individual bugs: ===
#82279:
In the displaymanager choose a new resolution. The new resolution should support a lower refresh rate than the one you are currently using. If you do not touch the refrash-rate field, your current refresh rate will be used; in some cases resulting in garbage on screen / empty screen. After the update a correct refresh rate will be used.

#231163:
On affected laptops guidance no longer crashes upon starting.

#207473:
On affected laptops brightness should now stop making multiple steps; or at least it should reduce the number of steps (this bug either originates in kde-guidance or in hal or in both; this of course only fixes the kde-guidance part).

Scott Kitterman (kitterman) wrote :

Marking Medium for the proposed SRU as a whole.

Changed in kde-guidance:
assignee: nobody → andreas-wenning
importance: Undecided → Medium
milestone: none → ubuntu-8.04.1
status: New → In Progress
Scott Kitterman (kitterman) wrote :

I've used these patches the last few days on Hardy with no regressions evident. The brightness patch appears to have resolved issues I've been having with brightness being incorrect after switching to AC mode. Plus one from me for SRU.

Scott Kitterman (kitterman) wrote :

JFTR, the brightness issue is a regression from Gutsy, AFAICT.

Jonathan Riddell (jr) wrote :

accepted into hardy-proposed, please test.

Steve Beattie (sbeattie) wrote :

Scott Kitterman or anyone else, care to re-verify based on the packages uploaded in proposed?

Thanks!

Scott Kitterman (kitterman) wrote :

I can verify no regressions. Brightness is improved for me, so I think I can verify that change. I don't have the hardware for the other two.

@Anthony Fok
Are you able to verify that the package from hardy-proposed fixes the refresh rate problem?

Steve Langasek (vorlon) wrote :

kde-guidance copied to hardy-updates.

Changed in kde-guidance:
status: In Progress → Fix Released
Anthony Fok (foka) wrote :

@Andreas Wenning

Yes, I verified that kde-guidance (0.8.0svn20080103-0ubuntu16.1) in hardy-proposed (and now in hardy-updates) fixes the refresh rate problem.

Thank you all for your help!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers