Ubuntu

display options stuck in low resolution

Reported by Lars Noodén on 2006-12-30
4
Affects Status Importance Assigned to Milestone
kde-guidance (Ubuntu)
Medium
Unassigned

Bug Description

In kubuntu (6.10) the system settings tool "Monitor & Display - System Settings", if I choose one of lower resolutions, then KDE gets stuck in that mode regardless of what I change or try to restore. Setting the slider back to 1024x768 in both user and administrator mode makes no change nor does restartingthe X server or even rebooting.

Also, sometimes the settings tool "Monitor & Display - System Settings" does not show any choices for refresh rate and currently only shows a maximum resolution of 1024 x 768 instead of the card's maximum which is 1600 x 1200

The hardware is an older macmini.

uname:
Linux lars 2.6.17-10-powerpc #2 Fri Oct 13 16:37:41 UTC 2006 ppc GNU/Linux

/etc/lsb-release:
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=6.10
DISTRIB_CODENAME=edgy
DISTRIB_DESCRIPTION="Ubuntu 6.10

It's definitely seems to be set off by entering administrator mode, but doesn't manifest until reboot. One way to get the effect is to change gamma in administrator mode. Changing it as a user doesn't produce the effect.

It seems that xorg.conf is related to the problem. If I use "Monitor & Display - System Settings" in the system settings tool in administrator mode, the next time I start X (usually on reboot) the resolution is all wrong.

Restoring the old xorg.conf restores the resolution. In the attached file

I haven't seen the problem since moving to 7.04. It seems to be fixed.

Changed in kde-guidance:
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers