Please include Dell UltraSharp 2405FPW 24-inch Wide Aspect Flat Panel LCD Monitor in hardware database

Bug #43276 reported by Bruce Miller on 2006-05-06
22
Affects Status Importance Assigned to Milestone
kde-guidance (Ubuntu)
Wishlist
Unassigned

Bug Description

Please include the Dell UltraSharp 2405FPW 24-inch Wide Aspect Flat Panel LCD Monitor in the hardware database.

IIRC, and my memory may be wrong, this monitor was not detected by dpkg-reconfigure xserver-xorg, but it could be chosen through KDE System Settings graphical dialogs.

Bruce Miller (brm0423) wrote :

My error. Previous comment about earlier availability in KDE System Settings was meant to refer to Kubuntu Breezy Badger. I miss it in Dapper development releases.

There is no such thing as hw database. All the probing of devices (including monitors) is done at install/reconfigure time dynamically. If there are no info coming back from your monitor, there is nothing i can do.

fabio

Changed in xorg:
status: Unconfirmed → Rejected
Bruce Miller (brm0423) wrote :

Fabio, It is less than the whole story to say that "there is no such thing as [a] hw database". True, the analysis at install time is done dynamically, but graphical X config managers do provide databases. Case in point: The KDE Control Centre (much improved by Kubuntu and renamed "System Settings") has a database of monitors which root users can choose from if their monitor is not automatically detected. This may indeed not be in your package, but it is on the hard disk of everyone who installs Kubuntu. The Dell 2405FPW is a popular high-end monitor but it is not yet in that database, although its immediate predecessor, the 2005FPW, is.. Can you help me find which package it is in so that I may contact the maintainer and arrange its inclusion?

Changed in xorg:
status: Rejected → Unconfirmed
Simon Edwards (simon-simonzone) wrote :

We might be able to add these monitors to the DB if someone can supply this info for each monitor:

* model name/number.
* horizontal and vertical frequency ranges it accepts.
* its EDID ID.

The frequencies should be listed in the manual and the command "sudo ddcprobe" might be able to tell you the edid code of the monitor you are using.

Model name/number (short): Dell 2405FPW
Model name/number (long ): Dell UltraSharp 2405FPW 24-inch Wide
Aspect Flat Panel LCD

Horizontal scan range 30 kHz to 81 kHz (automatic)
  Vertical scan range 56 Hz to 76 Hz, exception 1680 x 1200 &
1920 x 1200 at 60 Hz only
  Optimal preset resolution
  Analog : 1920 x 1200 at 60 Hz(VESA CVT-R Mode)
 Digital : 1920 x 1200 at 60 Hz(VESA CVT-R Mode)
  Highest preset resolution
  Analog : 1920 x 1200 at 60 Hz(VESA CVT-R Mode)
 Digital : 1920 x 1200 at 60 Hz(VESA CVT-R Mode)
  Dell™ guarantees image size and centering for all preset
modes listed in the following table.
  Preset Display Modes
Display Mode Horizontal Frequency (kHz) Vertical Frequency
(Hz) Pixel Clock (MHz) Sync Polarity (Horizontal/Vertical)
  VGA, 720 x 400 31.5 70.1 28.3 -/+
  VGA, 640 x 480 31.5 59.9 25.2 -/-
  VESA, 640 x 480 37.5 75.0 31.5 -/-
  VESA, 800 x 600 37.9 60.3 40.0 +/+
  VESA, 800 x 600 46.9 75.0 49.5 +/+
  VESA, 1024 x 768 48.4 60.0 65.0 -/-
  VESA, 1024 x 768 60.0 75.0 78.8 +/+
  VESA, 1152 x 864 67.5 75.0 108.0 +/+
  VESA, 1280 x 1024 64.0 60.0 108.0 +/+
  VESA, 1280 x 1024 80.0 75.0 135.0 +/+
  VESA, 1600 x 1200 75.0 60.0 162.0 +/+
  VESA, 1920 x 1200 74.0 60.0 154.0 +/-

bruce@Herodotus:~$ sudo ddcprobe
Password:
vbe: VESA 3.0 detected.
oem: NVIDIA
vendor: NVIDIA Corporation
product: NV36 Board - p191-4n Chip Rev
memory: 262144kb
mode: 640x400x256
mode: 640x480x256
mode: 800x600x16
mode: 800x600x256
mode: 1024x768x16
mode: 1024x768x256
mode: 1280x1024x16
mode: 1280x1024x256
mode: 320x200x64k
mode: 320x200x16m
mode: 640x480x64k
mode: 640x480x16m
mode: 800x600x64k
mode: 800x600x16m
mode: 1024x768x64k
mode: 1024x768x16m
mode: 1280x1024x64k
mode: 1280x1024x16m
edid:
edidfail
bruce@Herodotus:~$

I have written to Dell about the failure to return an EDID. This
might explain some other problems that I have been having with
the monitor.

This message is sent from a webmail login and not from my regular mail system. It does not have my customary digital signature.

Dylan (dylang) wrote :

Here is a set of modelines that works:
Section "Monitor"

    Identifier "Dell2405FPW"
        VendorName "Dell"
        ModelName "2405FPW"
        DisplaySize 488 305

        Modeline "DELL1920" 154.128 1920 1968 2000 2080 1200 1203 1209 1235 -hsync -vsync
        Modeline "DELL1600" 160.96 1600 1704 1880 2160 1200 1201 1204 1242 -HSync +Vsync
        Modeline "DELL1280" 138.54 1280 1368 1504 1728 1024 1025 1028 1069 -HSync +Vsync
        Modeline "DELL1152" 104.99 1152 1224 1352 1552 864 865 868 902 -HSync +Vsync
        Modeline "DELL1024" 81.80 1024 1080 1192 1360 768 769 772 802 -HSync +Vsync
        Modeline "DELL800" 48.91 800 840 920 1040 600 601 604 627 -HSync +Vsync
        Modeline "DELL640" 30.72 640 664 728 816 480 481 484 502 -HSync +Vsync
EndSection

Andreas Schildbach (schildbach) wrote :

Just for the record, I do get an edid on my Dell 2405FPW: "1 3"

$ sudo ddcprobe
vbe: VESA 3.0 detected.
oem: Intel(r)915GM/910ML/915MS Graphics Chip Accelerated VGA BIOS
vendor: Intel Corporation
product: Intel(r)915GM/910ML/915MS Graphics Controller Hardware Version 0.0
memory: 12224kb
mode: 1280x1024x256
mode: 1280x1024x64k
mode: 1280x1024x16m
mode: 1024x768x256
mode: 1024x768x64k
mode: 1024x768x16m
mode: 640x480x16m
mode: 800x600x64k
mode: 800x600x16m
mode: 640x480x256
mode: 800x600x256
mode: 640x480x64k
edid:
edid: 1 3
id: a00f
eisa: DELa00f
serial: 30523753
manufacture: 12 2005
input: separate sync, composite sync, sync on green, analog signal.
screensize: 52 33
gamma: 2.200000
dpms: RGB, active off, suspend, standby
timing: 720x400@70 Hz (VGA 640x400, IBM)
timing: 640x480@60 Hz (VGA)
timing: 640x480@75 Hz (VESA)
timing: 800x600@60 Hz (VESA)
timing: 800x600@72 Hz (VESA)
timing: 800x600@75 Hz (VESA)
timing: 1024x768@87 Hz Interlaced (8514A)
timing: 1024x768@75 Hz (VESA)
ctiming: 1280x1024@60
ctiming: 1600x1200@60
ctiming: 1152x864@75
ctiming: 1680x1680@60
dtiming: 1920x1200@59
monitorserial: XXX
monitorname: DELL 2405FPW
monitorrange: 30-81, 56-76

Bruce Miller (brm0423) wrote :

Thanks for alerting me to the existence of the ddcprobe command. I found it in the xresprobe package.

Andreas had better luck than I. Admittedly, my Dell 2405 FPW is connected through a KVM switch. I will take out the switch and report back whether the results are any different.

bruce@Herodotus:~$ sudo ddcprobe
vbe: VESA 3.0 detected.
oem: NVIDIA
vendor: NVIDIA Corporation
product: NV36 Board - p191-4n Chip Rev
memory: 262144kb
mode: 640x400x256
mode: 640x480x256
mode: 800x600x16
mode: 800x600x256
mode: 1024x768x16
mode: 1024x768x256
mode: 1280x1024x16
mode: 1280x1024x256
mode: 320x200x64k
mode: 320x200x16m
mode: 640x480x64k
mode: 640x480x16m
mode: 800x600x64k
mode: 800x600x16m
mode: 1024x768x64k
mode: 1024x768x16m
mode: 1280x1024x64k
mode: 1280x1024x16m
edid:
edidfail
bruce@Herodotus:~$

Bruce Miller (brm0423) wrote :

Since my earlier message, I have had an opportunity to shut down my computer and to shift the Dell monitor cable from the KVM switch directly to the computer.

The ddcprobe failed in exactly the same way as in my last message. My monitor is somewhat older than Andreas Schildbach's.

I shall be taking up the matter with Dell.

Thanks for providing this extra information. I shall close the bug report.

Bruce Miller (brm0423) wrote :

problem has been demonstrated to arise from a hardware defect in the hardware of the original submitter.

Changed in kde-guidance:
status: Unconfirmed → Rejected
rngadam (rngadam) wrote :

Bruce Miller: have you had any luck when you contacted Dell about this?

Also; should this really be closed? Isn't there a way to set decent defaults even if the edidfail errors occurs?What kind of magic do the Windows drivers have to make this work?

Bryce Harrington (bryce) wrote :

Andreas seems to actually be seeing bug 27667 (fixed).

The others who are seeing edidfail results, are actually seeing 94994, which I'm making this a dupe of.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers