Battery Monitor cannot read battery level

Bug #235535 reported by wub on 2008-05-28
4
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Undecided
Unassigned
kde-guidance (Ubuntu)
Undecided
Andreas Wenning

Bug Description

1. Ubuntu 8.04 release 8.04

2. Well, if I had any idea what package powers the battery monitor/charging apparatus I'd let you know. As for updates, I just applied all available updates 5/28/2008 approximately 04:00 GMT.

3 and 4. Using prior versions of Ubuntu (7.04, 7.10) the battery monitor read the serial number, model number and last charge for my battery. Based on only a few days experience with 8.04, something has changed. The monitor only shows charging when charging is under way, but it no longer displays a percentage of charge. I am attaching the output of cat /proc/acpi/battery/BAT1/*
The monitory indicator only appears at the top of the screen during charging, which is as expected. I tried running the Hardware Test, since I had hoped it might shed some light. It did not appear to consider the battery as hardware, and I was unable to return the report due to a bug which was already posted elsewhere.

wub (wub) wrote :

Hi Wub

Please attach the output of running the following command:
hal-device `hal-find-by-capability --capability "battery"`

Changed in kde-guidance:
assignee: nobody → andreas-wenning
status: New → Incomplete
wub (wub) wrote :

When I run:
hal-find-by-capability --capability "battery"
it just returns:

/org/freedesktop/Hal/devices/computer_power_supply_battery_BAT1

I was expecting details of some kind.

It should have been:
hal-device `hal-find-by-capability --capability "battery"`

This should give some more info.

wub (wub) wrote :

Sorry, it was tired and I was getting late :)
The correct output is attached:

Was this output generated while your computer was charging. If not, please generate it at this point.

wub (wub) wrote :

I have made two more reports. One while running on battery (the icon showed an empty battery, said Computer was running on battery power and had 0% remaining, could not estimate time remaining), and one during charging. I was interested to see that when I plugged in my power supply, the icon changed to show running on AC, but the flyover box said "Computer is running on battery power." Of course, it also said "Laptop battery is charging (0%)."

wub (wub) wrote :

Second attachment.

The battery monitor does not report battery level, since it's backend (HAL) doesn't report it. It looks like current voltage is reported; but since there is no information about full voltage, it cannot calculate a percentage.

I'm opening this as a bug against HAL, even though the problems seem to be located even lower (your /proc/... output didn't report it either). I suppose it is a kernal problem, but I'm not sure; maybe someone else knows.

Changed in kde-guidance:
status: Incomplete → Invalid
Phillip Susi (psusi) wrote :

This looks like a defective ACPI bios failing to properly tell the kernel the battery charge state. Also 8.04 is reaching its end of life, and this does not seem to be an issue with hal so I am closing this report. If it is still an issue with a more recent release you can reopen it.

Changed in hal (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers