Unable to contact time server

Bug #668748 reported by Stan on 2010-10-30
54
This bug affects 11 people
Affects Status Importance Assigned to Milestone
kde-baseapps (Ubuntu)
Undecided
Unassigned

Bug Description

Kubuntu 10.10, KDE 4.5.1

When I try to modify the time server in the KDE Date and Time settings panel I get a message like:

"Unable to contact time server: europe.pool.ntp.org"

I can ping the time pool server:
PING europe.pool.org (64.99.80.30) 56(84) bytes of data.
64 bytes from url.hover.com (64.99.80.30): icmp_req=1 ttl=118 time=114 ms
......

The bug only occurs when the package "ntp" is installed. It does not occur when I uninstall the package or when I disable ntpd with "sudo service ntp stop".

Also, I noticed that the ntpdate startup script does behave nicely: it stops ntpd before running ntpdate.

Quoting /etc/network/if-up.d/ntpdate :
    ......
    invoke-rc.d --quiet ntp stop >/dev/null 2>&1 || true
    /usr/sbin/ntpdate-debian -s $OPTS 2>/dev/null || :
    invoke-rc.d --quiet ntp start >/dev/null 2>&1 || true
    .....

Is there perhaps another, less nicely behaving script or program somewhere (in KDE perhaps?) that invokes ntpdate-debian without stopping ntpd, when the user tries to change something in the Date and Time settings panel?

Book 'em Dano (heymrdjd) wrote :

Have you tried updated the time with different time servers?

tags: added: maverick
affects: ubuntu → ntp (Ubuntu)
Stan (brusco) wrote :

The time servers work OK.
It's the configuration panel that won't let me configure the time server settings while nptd is running. Need to hack daemons and config files to make NTP work.

Mathias Gug (mathiaz) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Seems to be unrelated to the ntp package itself - rather to the Kubuntu time panel.

affects: ntp (Ubuntu) → ubuntu
Kamus (kamus) wrote :

Have you tried to run in a terminal "sudo ntpdate -u europe.pool.ntp.org" and check the output information? any way for me is working fine here.

Changed in ubuntu:
status: New → Incomplete
Stan (brusco) wrote :

That's not the bug that I am reporting.
The bug is that the configuration panel won't let me configure the time server settings while nptd is running. The bug is that I need to hack daemons and config files and type silly formulas in terminals to make NTP work.

Launchpad Janitor (janitor) wrote :

[Expired for Ubuntu because there has been no activity for 60 days.]

Changed in ubuntu:
status: Incomplete → Expired
Paul Abrahams (abrahams) wrote :

I've encountered the same behavior -- KDE panel clock says it can't contact pool .ntp.org, but I can ping pool.ntp.org. I'm running Kubuntu Maverick 10.10.

wmccarty (wdmlist) wrote :

I also experience this bug on Kubuntu 10.10, and Kubuntu 11.04. Changed status to incomplete to reopen.

Changed in ubuntu:
status: Expired → Incomplete
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kde-baseapps (Ubuntu):
status: New → Confirmed
affects: ubuntu → kde-baseapps (Ubuntu)
Changed in kde-baseapps (Ubuntu):
status: New → Confirmed
tags: added: natty
ggallozz (ggallozz-gmail) wrote :

it's a bug.
That's true for me too.
and disabling ntpd, works as previous notice.

Natty fully updated

Paul Abrahams (abrahams) wrote :

Same problem in Precise 12.04.1. Longevity in bugs is not a virtue.

Ray-Ven (ray-ven) wrote :

same in quantal, workaround: Disabling ntpd

Tiedemate (bjoerntiedemann) wrote :

Same here with 13.04

Serhiy Yakovyn (syakovyn) wrote :

I have discovered the following thing after trying to set date&time synchronization. It's failed as described in the bug description and it also changed /etc/localtime link to point to non-existing file ../posix/Europe/Kiev instead of /usr/share/zoneinfo/Europe/Kiev

Another note. I don't have ntp package installed, so workaround doesn't work for me.

System: Kubuntu 13.04

Francesco (francesco-rizzi) wrote :

Hi Serhiy, I have the same issue here, (System: Kubuntu 13.04) can you please explain me how you did change the link?

from

../posix/Europe/Kiev (in my case is Amsterdam)

to

/usr/share/zoneinfo/Europe/Kiev

Thanks in advance!
fr2632

Serhiy Yakovyn (syakovyn) wrote :

Hi Francesco,

I have used the following command in the terminal: "sudo ln -f -s /usr/share/zoneinfo/Europe/Kiev /etc/localtime"

Serhiy Y

Francesco (francesco-rizzi) wrote :

Thank you Serhiy! :)

Andy (tipul07) wrote :

I can confirm too it's a bug in Time Panel in KDE.

I manually edited symlink in /etc/localtime to point to right file in /usr/share/zoneinfo/Europe/Bucharest (in my case). If I then go to "Adjust Date and Time..." (which opens Date & Time - KDE Control Module) and do any change, then /etc/localtime will point to "../posix/Europe/Bucharest".

And that's bcuz in Control Module it just copies the file from /usr/share/zoneinfo/Europe/Bucharest instead of symlinking to it as /usr/share/zoneinfo/Europe/Bucharest is also a symlink to "../posix/Europe/Bucharest", but for this location this is correct.

So if you do any changes to Date and Time from KDE Control Module (or System Settings) just remember you also have to fix /etc/localtime symlink.

Regards,
Andy

Juan Navarro (oneorjuan) wrote :

4 years later and it's still impossible to enable the automatic update of date and time; who is the maintainer of the Date & Time module in KDE?

Synthoms are the same as described above: just selecting any of the preconfigured servers (such as "europe.pool.ntp.org") will show the message "Unable to contact time server: europe.pool.ntp.org" when clicking on Apply.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers